Parse error: parse error, expecting`')''

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
PerYcut
Registered User
Posts: 5
Joined: Tue Jun 04, 2002 4:36 pm

Parse error: parse error, expecting`')''

Post by PerYcut »

Hello .
Can Anybody help me ?
i get after a registration the following message !
Parse error: parse error, expecting `')'' in /home/sites/site213/web/phpBB2/includes/usercp_avatar.php on line 302


:(
thank for your help

Bear
Registered User
Posts: 2586
Joined: Mon Dec 31, 2001 7:50 pm
Location: 127.0.0.1
Contact:

Post by Bear »

Could you let us know what version of phpBB? Upgrade or clean install? The usual stuff. :wink:
Bear
Got a thing for fashion? So do we at the Fashion Spot.
Let us give you the Royal Treatment at Les Tribunes Royales.

PerYcut
Registered User
Posts: 5
Joined: Tue Jun 04, 2002 4:36 pm

Post by PerYcut »

phpBB 2.0.0
clean install with space pilot 3k style

PerYcut
Registered User
Posts: 5
Joined: Tue Jun 04, 2002 4:36 pm

Post by PerYcut »

and when i click on the who is online link i get :
Parse error: parse error, expecting `'('' in /home/sites/site213/web/phpBB2/viewonline.php on line 110

puuhhhh :roll: i have many problems :?

zoid
Registered User
Posts: 743
Joined: Fri Oct 12, 2001 6:29 am
Location: $SCRIPT_NAME
Contact:

Post by zoid »

Have you done any modifications in the source code?

Line 302 of usercp_avatar.php should be

Code: Select all

"AVATAR_IMAGE" => $board_config['avatar_gallery_path'] . '/' . $avatar_images[$category][$i][$j],
and line 110 of viewonline.php should be

Code: Select all

if ( $user_id != $prev_user )
Alexander
Whatever you want to know, please do a Image Search before asking :).

Run your own Chatcommunity
>> PINO - Client/Server Chat for Windows <<

PerYcut
Registered User
Posts: 5
Joined: Tue Jun 04, 2002 4:36 pm

Post by PerYcut »

thats right . but did not work

User avatar
SHS`
Former Team Member
Posts: 6615
Joined: Wed Jul 04, 2001 9:13 am
Location: Yellow Beach, Nine Dragons, Hong Kong
Name: Jonathan Stanley
Contact:

Post by SHS` »

In the case you are running vanilla code.... then parse errors would prbably only come about if either:
  1. With whatever tool you use to extract the files from the phpBB2 .tar.gz/.zip archive. The Unix format text files aren't being handled correctly (IIRC, one Mac archive extractor has this problem.... )
  2. The PHP script files weren't uploaded as ASCII
Or worse still, both of the above. So check your program settings.
Jonathan “SHS`” Stanley • 史德信
Image

Bear
Registered User
Posts: 2586
Joined: Mon Dec 31, 2001 7:50 pm
Location: 127.0.0.1
Contact:

Post by Bear »

By chance, are you using CuteFTP?
Bear
Got a thing for fashion? So do we at the Fashion Spot.
Let us give you the Royal Treatment at Les Tribunes Royales.

PerYcut
Registered User
Posts: 5
Joined: Tue Jun 04, 2002 4:36 pm

Post by PerYcut »

Thanks for the tip and the help

it works

User avatar
SHS`
Former Team Member
Posts: 6615
Joined: Wed Jul 04, 2001 9:13 am
Location: Yellow Beach, Nine Dragons, Hong Kong
Name: Jonathan Stanley
Contact:

Post by SHS` »

PerYcut wrote: Thanks for the tip and the help

it works


For the benefit of others..... which of the two was the problem??
Jonathan “SHS`” Stanley • 史德信
Image

Locked

Return to “2.0.x Support Forum”