Page 1 of 1

Private Message Error

Posted: Tue Sep 07, 2004 12:24 am
by commanderyoda
Hi . . . I'm brand new and as the Administrator of my board I'm experiencing a problem regarding my ability to send Private Messages to others. I have enabled Private Messaging in all the appropriate configuration sections (at least in all the ones I could find). I can receive PM's but can't send them without the below error message. Can anyone help. Here is the error message:

Failed sending email :: PHP ::

DEBUG MODE

Line : 234
File : /MessageBoard/includes/emailer.php

Posted: Tue Sep 07, 2004 12:28 am
by Drexion
Do you have access to a mail server ?
Enable SMTP in Admin Panel --> General Admin --> Configuration, use as SMTP server localhost, leave username and password empty and see if it works.

If it still doesn't work, try as SMTP server the SMTP server of your hoster or your ISP as well as the respective username (if necessary) and your SMTP password (only possible, if the SMTP server supports authentication).

PM error message

Posted: Tue Sep 07, 2004 12:36 am
by commanderyoda
WoW! That's what I call a fast response! Ok, I'll try configuring the SMTP as you suggest. I'll let you know how this worked out. Thanks again for the blistering response! This is great!

Private Message Errors

Posted: Tue Sep 07, 2004 1:14 am
by commanderyoda
Well I tried every combination of SMTP I could and still the same error messages continue. It's odd because the private messages actually send. It's just nagging to receive a debug error message that something has gone wrong instead. I notice a number of others here have had a similar problem. Do you possibly have another solution?

I am currently running version 2.0.5 that I got from my Yahoo Web Hosting account. Is there a later version of phpBB that I can or should upgrade to that might fix this problem? If so how do I obtain the latest version?

Posted: Tue Sep 07, 2004 1:19 am
by Drexion
That error simply means the user who is on the receiving end of the PM has set in his profile for email notification on PMs, but the script has failed to send the email for some reason. The actual PM is internal to phpBB, and will still be sent.
Yahoo's hosting should indeed provide you with access to a mail server, does this error occur when new user's register ?

As for upgrading, If you have no mods installed (and this is not a forum installed by clicking a button in your hosting control panel, you actually installed it properly),
Backup the database and the forum files.
Download the changed files package from the downloads page.
Extract this package's contents to your hard disk.
Extract the zip file contents which is relevant for your board version (ex. if its from 2.0.5, then 2.0.5_to_2.0.10.zip) to your hard disk, and upload those files, and the 'install' folder into the root forum folder directory.(overwriting files)
Point your browser to the ../install/update_to_210.php
Delete the 'install' and 'contrib' directories.

Also, if you don't have access to a mail server, you could prevent the forum from attempting to send emails. The instructions are posted by Graham here
http://www.phpbb.com/phpBB/viewtopic.php?t=186493

PM error messages

Posted: Tue Sep 07, 2004 2:08 am
by commanderyoda
Yes the error still occurs even with Yahoo's smtp information and the users are all registered. I tried having someone shut off e-mail notification for PM's and still the the same error messages occur on both my end (Administrator) and the receiver's end (registered member).

I don't want to beat a dead horse here so I'll just give up on Private Messaging for this board. Even though the messages go through this "issue" is really disconcerting to all. We can live without it. Perhaps if in the future someone has a solution they can post it. I do want to thank you for your attempts to resolve this issue. It is very much appreciated.

Posted: Tue Sep 07, 2004 2:13 am
by geocator
If you like you could completley remove all email functions, so you dont keep getting erros like this in other places too. http://www.phpbbhacks.com/viewhack.php?id=1186