Can someone tell me why pictures are not obeying colspan=2 ?

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Rob-Rah
Registered User
Posts: 36
Joined: Tue Sep 07, 2004 9:53 pm

Can someone tell me why pictures are not obeying colspan=2 ?

Post by Rob-Rah »

On my forum, when a picture is posted as part of a post it stretches out the post to only fill the first column of the post title (the post subject and time), which then pushes the next column above (the one with the "quote", "edit", "delete", "IP", etc. in it) off the page.

Examples here:
http://www.rob-rah.com/phpBB2/viewtopic.php?t=63
http://www.rob-rah.com/phpBB2/viewtopic.php?t=65

This only happens with the pictures and you can see that the text in the posts is having no effect.

Any ideas what I need to do to correct this?

Cheers.

djr32
Registered User
Posts: 76
Joined: Fri Mar 07, 2003 10:49 am
Location: Cambridge, UK
Contact:

Post by djr32 »

This is behaving as expected - the photo makes the column that its in expand, making it too wide to fit on the screen. This column also contains the "Today at... Reply | Quote" part, which is supposed to expand to the full width of the column (so that the bar after "Quote" is at the far right, lined up with the right hand edge of the photo).

Rob-Rah
Registered User
Posts: 36
Joined: Tue Sep 07, 2004 9:53 pm

Post by Rob-Rah »

Does it make no difference that the column the picture is in is meant to be a composite column of the two (hence the colspan=2 question)?

The text runs over between the two columns and doesn't expand the first one. Only the pic does that.

Is there a way to stop it?

Rob-Rah
Registered User
Posts: 36
Joined: Tue Sep 07, 2004 9:53 pm

Post by Rob-Rah »

Ahhh. I worked round it by creating a new nested table for the post subject and the IP address (etc.) columns.

Cheers.

Locked

Return to “2.0.x Support Forum”