Page 1 of 1

Mass-email function problem ...

Posted: Tue Nov 16, 2004 9:27 am
by Metalium
okay, i got a weird problem with the email function on my phpBB 2.0.4
It sends mails for registration confirmation, it sends topic reply or private message notifications, so you would think there's nothing wrong with the email function....yet, when i want to send out a mass -email from the admin panel, i get
"Failed sending email :
Line : 225
File : /homepages/64/e13902591/htdocs/metalium/board/includes/emailer.php"

Now WHY is that eh ? How come it wont send mass emails but works perfectly for all other mail ??? :?

Posted: Tue Nov 16, 2004 11:21 am
by Metalium
C'mon....surely someone knows what could be the problem....please ?

Posted: Tue Nov 16, 2004 11:35 am
by primedomain
Metalium wrote: C'mon....surely someone reads what is outlined in the forum rules....please ?
Forum rule 4. h. wrote: When posting a support question bumping is permitted only after six hours have elapsed since the last post to that topic. Users who abuse this will be warned.
Excessively bumped topics will be locked.

As for your problem: it is very strongly recommended to update ASAP to the latest version (security fixes!). See the docs for details. Usually the changed-files-only package is the best option. Please note that email handling has been changed significantly since 2.0.4.

Posted: Tue Nov 16, 2004 11:41 am
by Metalium
My apologies :oops: I did not mean to "bump" this thread , that was not my intention at all ! It's just that i'm a bit stressed with time, and today i have a couple of "free" hours to solve some bugs that have been sitting there for ages ! :?

An update ....yes, perhabs that would solve it , Thanks for the suggestion and sorry for not keeping to the "houserules", that was not intended :cry:

Posted: Tue Nov 16, 2004 1:05 pm
by guysoft
maybe your smtp server carnt send so menny e-mails at once, there is a solution, its called "mega maill" no need even to edit pages, you just need to copy files. it worked for me.

http://www.phpbb.com/phpBB/viewtopic.php?p=663472
http://www.handykoelsch.de/phpBB/links. ... how&id=147

Posted: Tue Nov 16, 2004 1:31 pm
by Metalium
Well...i've done the update, i've installed that mega-mail, and i still get the same error :(

Posted: Tue Nov 16, 2004 1:34 pm
by primedomain
erm... please remove the MOD for the time being.

from what I can see, you had disabled SMTP so far (in Admin Panel --> General Admin --> Config)

Enable SMTP in Admin Panel --> General Admin --> Configuration, use as SMTP server localhost, leave username and password empty and see if it works.

If it still doesn't work, try as SMTP server the SMTP server of your hoster with SMTP username (password is usually not necessary, but you might want to try it with SMTP password as well).

Next step is to try it with the SMTP server of your ISP + SMTP username. Usually an SMTP password will be required; thus this last option is only possible, if the SMTP server supports authentication.

Please post detailed error messages (if any).

Posted: Tue Nov 16, 2004 1:53 pm
by Metalium
Nope, enabling the SMTP doesn't work either.

Warning: fsockopen(): unable to connect to localhost:25 in /homepages/65/E13495191/htdocs/metalium/board/includes/smtp.php on line 109

DEBUG MODE

Line : 111
File : /homepages/65/E13495191/htdocs/metalium/board/includes/smtp.php

Posted: Tue Nov 16, 2004 2:00 pm
by primedomain
surprising... that's 1&1, isn't? SMTP should work. Did you try it with the 1&1 SMTP server (not localhost)?

Posted: Tue Nov 16, 2004 2:16 pm
by Metalium
I just did that yes :) and now i FINALLY could send my mail !!! It required the smtp server name yes, NOT "localhost" ;)

Thanks for helping out :)

One more question now...as the other mail functions worked properly before, will they still do now with that smpt enabled ?

Posted: Tue Nov 16, 2004 2:25 pm
by primedomain
you will have to try it out :)

Posted: Tue Nov 16, 2004 2:28 pm
by Metalium
yep, seems to be working perfectly :)

So there, my day of "debugging" is done with....at least for today :wink:

Thanks again for your help ! 8)

Posted: Wed Nov 17, 2004 7:29 pm
by RogueScribner
It required the smtp server name yes, NOT "localhost"


I'm having a similar problem. Can someone explain to me the difference between server name and local host?

Thanks.

Posted: Wed Nov 17, 2004 9:53 pm
by A_Jelly_Doughnut
localhost automatically points to the machine on which it is being run. The actual server name is slightly slower than localhost because a lookup has to be run, often over the Internet.

Hopefully that helped.