Can't access posts

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
happydog
Registered User
Posts: 10
Joined: Sat Oct 18, 2003 2:28 pm

Can't access posts

Post by happydog »

Am using phpbb 2.0.11

I lost the ability to retrieve and view posts. The board is up, I can access profiles, priv messages etc - but when I go to retrieve a post I get this --
Warning: Unknown(/home/stvlin/www/viewtopic.php): failed to open stream: Permission denied in Unknown on line 0

Warning: (null)(): Failed opening '/home/stvlin/www/viewtopic.php' for inclusion (include_path='.:/usr/local/share/pear:/usr/local/lib/php') in Unknown on line 0


It was working this morning and when I checked an hour later -- It was doing the above.

I was able to down load the data base -- and it "looks" ok. Any ideas on what to do?

Thanks steve
Last edited by happydog on Wed Dec 08, 2004 3:03 pm, edited 2 times in total.

User avatar
Draegonis
Former Team Member
Posts: 3950
Joined: Mon Apr 22, 2002 3:12 pm
Location: Kµlt øƒ Ø
Contact:

Post by Draegonis »

Topic moved: phpBB Discussion -> phpBB Support.

User avatar
pentapenguin
Former Team Member
Posts: 11030
Joined: Thu Jul 01, 2004 4:15 am
Location: GA, USA

Post by pentapenguin »

Go to your FTP program and CHMOD viewtopic.php to 644.
See if that helps.
Support Resources: Support Request Template
If you need professional assistance with your board, please contact me for my reasonable rates.

happydog
Registered User
Posts: 10
Joined: Sat Oct 18, 2003 2:28 pm

Post by happydog »

Thank you - changing chmod to 644 did the trick -- it was at 600. Any idea how it may have gotten changed? I did nothing on my end to change it.

Again thanks!

steve

SlamChops
Registered User
Posts: 28
Joined: Thu Dec 11, 2003 5:56 am

Post by SlamChops »

thanks! had the same problem and this fixed it. :D

User avatar
pentapenguin
Former Team Member
Posts: 11030
Joined: Thu Jul 01, 2004 4:15 am
Location: GA, USA

Post by pentapenguin »

happydog wrote: Thank you - changing chmod to 644 did the trick -- it was at 600. Any idea how it may have gotten changed? I did nothing on my end to change it.

Again thanks!

steve

No, it shouldn't just change on itself.
Eveybody seems to have had that problem this weekend.
Must be the little green men. 8)

I would reset your FTP password and board admin password if I were you in just case of a hacker (though I doubt it).
Support Resources: Support Request Template
If you need professional assistance with your board, please contact me for my reasonable rates.

collectorfbody.com
Registered User
Posts: 90
Joined: Mon Feb 17, 2003 9:35 pm

Post by collectorfbody.com »

Do you use phpwebhosting? I had the same prob with my board on phpwebhosting. I have two other host and thos boards did not have one problem.

User avatar
wilkc
Registered User
Posts: 251
Joined: Wed Mar 27, 2002 2:43 am
Location: Tampa, FL
Contact:

Post by wilkc »

I, too, have phpwebhosting.

With WS_FTP I can't chmod by number, so what's the equivalent of 644 for Owner, Group, Other?
NWTAMPA.COM
Serving NW Tampa

collectorfbody.com
Registered User
Posts: 90
Joined: Mon Feb 17, 2003 9:35 pm

Post by collectorfbody.com »

Owner is read write
Group is read
other is read

4 = r-- = read

6 = rw- = read and write

happydog
Registered User
Posts: 10
Joined: Sat Oct 18, 2003 2:28 pm

Post by happydog »

Yes - I also use phpwebhosting -- sounds like the change was on their end.

Again, thanks.

ripperracing
Registered User
Posts: 5
Joined: Mon Dec 06, 2004 11:16 pm

Post by ripperracing »

I use them aswell and have the same problem. chmod the file worked?? I set it to 777 yesterday to see and it didnt work for me.

Phpwebhosting said to upgrade and it would work.. no.. it didnt.

ripperracing
Registered User
Posts: 5
Joined: Mon Dec 06, 2004 11:16 pm

Post by ripperracing »

WEll i'll be.. it worked this time. must not have taken last time. made it 644. Thanks people.

It looks like they just disabled it by chmodding the file.. I hope they dont come around and do it again. I did upgrade, I hope they look first.

nixem311
Registered User
Posts: 20
Joined: Mon Dec 06, 2004 10:47 pm
Contact:

Post by nixem311 »

ripperracing wrote: I use them aswell and have the same problem. chmod the file worked?? I set it to 777 yesterday to see and it didnt work for me.

Phpwebhosting said to upgrade and it would work.. no.. it didnt.



i also use PHPwebhosting... theychanged there phpo.ini permissions this weekened to bump up securit .. this was told to me by NICK fromthere tech support...

i am having a similar problem with tis error regarding my OSCOMMERCE file uploading also....
but changing viewtopic.php to 644 did the trick int his case...

thanks

ripperracing
Registered User
Posts: 5
Joined: Mon Dec 06, 2004 11:16 pm

Post by ripperracing »

I use oscommerce on another site I have with phpwebhosting. Can you fill me in on anything I need to change, I havent seen any problems yet, but I havent worked on it too much this week.

please pm me any details you have so I dont clutter up the post about phpbb

Thanks!

oh! and computers suck! I thought they were supposed to work FOR us.. not against us!!

tophorse
Registered User
Posts: 4
Joined: Wed Oct 20, 2004 1:02 am
Contact:

Thanks so much!

Post by tophorse »

Thanks so much! on my site http://www.tophorsepower.com i just checked and go tthat error and almost sh*t my pants, but this fixed it! Somehow my board permissions on viewtopic were changed to 500. anyone know how this could have happened??? THANKS SO MUCH!
Visit http://www.tophorsepower.com for auto forums, file hosting, free email, email spoofers, picture rating/voting, etc all for free!

Locked

Return to “2.0.x Support Forum”