Advice on moving ISP from a PHP 4.0.6, SQL 3.23.32

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
akslee
Registered User
Posts: 82
Joined: Sat Aug 02, 2003 6:54 pm
Location: Vancouver
Contact:

Advice on moving ISP from a PHP 4.0.6, SQL 3.23.32

Post by akslee »

Can anyone give me some tips on the transition?

What should be something I should be aware of?

1. I uploaded the php files that are 2.0.11, to my new ISP,
2. created a database, and uploaded thd sql file for their tech support to "dump" for me.

I made the appropriate changes to the config.php to match the new ISP.

The process failed.
"If you have a great time teaching your child, and your child has a great time, there simply isn't anyway you can lose."

www.ChildBrain.org
User avatar
aka_void
Registered User
Posts: 108
Joined: Tue May 20, 2003 7:01 pm
Location: Location: Lost
Name: Mark
Contact:

Post by aka_void »

how fo you mean failed. Did you get any error messages?
akslee
Registered User
Posts: 82
Joined: Sat Aug 02, 2003 6:54 pm
Location: Vancouver
Contact:

Post by akslee »

when i visit index.php

this is what I get

message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?
"If you have a great time teaching your child, and your child has a great time, there simply isn't anyway you can lose."

www.ChildBrain.org
User avatar
pentapenguin
Former Team Member
Posts: 11030
Joined: Thu Jul 01, 2004 4:15 am
Location: GA, USA

Post by pentapenguin »

Install this MOD to see if it will generate any more detailed error messages.
Support Resources: Support Request Template
If you need professional assistance with your board, please contact me for my reasonable rates.
akslee
Registered User
Posts: 82
Joined: Sat Aug 02, 2003 6:54 pm
Location: Vancouver
Contact:

Post by akslee »

Thank you, that is a good start. I now get this :

Critical Error!
message_die() was called multiple times.

--------------------------------------------------------------------------------
Error #1
Could not query attachment information

Line : 80
File : /home/wwwlee8/public_html/forum/attach_mod/attachment_mod.php
SQL : SELECT * FROM phpbb_phpbb_attachments_config

--------------------------------------------------------------------------------
Error #2
Error updating last visit time

Line : 169
File : /home/wwwlee8/public_html/forum/includes/sessions.php
SQL : UPDATE phpbb_phpbb_users SET user_session_time = 1104020439, user_session_page = 0, user_lastvisit = 1104013744, user_lastlogon = 1104020439, user_totallogon=user_totallogon+1 WHERE user_id = 2
"If you have a great time teaching your child, and your child has a great time, there simply isn't anyway you can lose."

www.ChildBrain.org
User avatar
pentapenguin
Former Team Member
Posts: 11030
Joined: Thu Jul 01, 2004 4:15 am
Location: GA, USA

Post by pentapenguin »

There's a problem with your Attachment MOD.
You should post for help on it's thread here.
Support Resources: Support Request Template
If you need professional assistance with your board, please contact me for my reasonable rates.
akslee
Registered User
Posts: 82
Joined: Sat Aug 02, 2003 6:54 pm
Location: Vancouver
Contact:

Post by akslee »

Yes, it turns out 3 tables that had to do with attachment was missing.

My gzipped file is 6MB when I backup, and its 60 MB without compression.

How can I split this up so that it can be uploaded in increments to my new host?

There's a file size limitation of 5MB, and a time out in 3600 seconds.
"If you have a great time teaching your child, and your child has a great time, there simply isn't anyway you can lose."

www.ChildBrain.org
akslee
Registered User
Posts: 82
Joined: Sat Aug 02, 2003 6:54 pm
Location: Vancouver
Contact:

Post by akslee »

I have successfully moved my forum to the new host, which is running sql4.

I am getting this error message when I reply, under the Topic Review mod :

Warning: mysql_fetch_array(): 29 is not a valid MySQL result resource in /home/wwwlee8/public_html/forum/db/mysql4.php on line 214

Warning: Cannot modify header information - headers already sent by (output started at /home/wwwlee8/public_html/forum/db/mysql4.php:214) in /home/wwwlee8/public_html/forum/includes/page_header.php on line 492

Warning: Cannot modify header information - headers already sent by (output started at /home/wwwlee8/public_html/forum/db/mysql4.php:214) in /home/wwwlee8/public_html/forum/includes/page_header.php on line 494

Warning: Cannot modify header information - headers already sent by (output started at /home/wwwlee8/public_html/forum/db/mysql4.php:214) in /home/wwwlee8/public_html/forum/includes/page_header.php on line 495

My page_header.php looks like this right now, and it doesn't give me errors, but it doesn't show
// Work around for "current" Apache 2 + PHP module which seems to not
// cope with private cache control setting
if (!empty($_SERVER['SERVER_SOFTWARE']) && strstr($_SERVER['SERVER_SOFTWARE'], 'Apache/2'))
{
header ('Cache-Control: no-cache, pre-check=0, post-check=0');
}
else
{
header ('Cache-Control: private, pre-check=0, post-check=0, max-age=0');
}
header ('Expires: 0');
header ('Pragma: no-cache');
"If you have a great time teaching your child, and your child has a great time, there simply isn't anyway you can lose."

www.ChildBrain.org
User avatar
pentapenguin
Former Team Member
Posts: 11030
Joined: Thu Jul 01, 2004 4:15 am
Location: GA, USA

Post by pentapenguin »

You should post for help on the MOD's preexisting thread in the MOD forums. ;)
Support Resources: Support Request Template
If you need professional assistance with your board, please contact me for my reasonable rates.
Locked

Return to “2.0.x Support Forum”