Page 1 of 1

Template problem!

Posted: Fri Dec 31, 2004 3:26 pm
by carolol
Hi!
I have a problem with my viewtopic template I think. When people have pictures in their sigs the layout is totally messed up and a horizontal scrollbar appears even though it's not necessary. Look by yourself => http://pinkrevolution.com/forum/viewtopic.php?t=2398
Does anybody know how I could fix it?

Here is the viewtopic_body.tpl code:

Code: Select all

<table width="100%" cellspacing="0" cellpadding="2" border="0" align="center">
  <tr> 
	<td align="left" valign="bottom"><span class="gensmall">
	<!-- BEGIN switch_user_logged_in -->
	{LAST_VISIT_DATE}<br />
	<!-- END switch_user_logged_in -->
	{CURRENT_TIME}<br />
	{S_TIMEZONE}
	</span></td>
  </tr>
</table>

<br class="nav" />

{NAVIGATION_BOX}

<table border="0" cellpadding="4" cellspacing="1" width="100%">
<tr> 
	<td><span class="maintitle">
		<a class="maintitle" href="{U_VIEW_TOPIC}">{TOPIC_TITLE}</a>
	</span><span class="gensmall"><br />
		<!-- BEGIN moderators -->
		<b>{L_MODERATORS}:&nbsp;</b>
		<!-- BEGIN mod -->
		<a href="{moderators.mod.U_MOD}" title="{moderators.mod.L_MOD_TITLE}" class="gensmall">{moderators.mod.L_MOD}</a>{moderators.mod.L_SEP}
		<!-- END mod -->
		<!-- END moderators -->
	</span></td>
</tr>
</table>

<table width="100%" cellspacing="2" cellpadding="2" border="0">
<tr>
	<td align="left" nowrap="nowrap"><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" /></a>&nbsp;&nbsp;&nbsp;<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a></span></td>
	<td width="100%" valign="bottom"><span class="gensmall">
		<!-- BEGIN pagination -->
		<b>{pagination.L_PAGE_OF}</b>&nbsp;{pagination.L_COUNT}
		<!-- END pagination -->
	</span></td>
	<td align="right" valign="bottom" nowrap="nowrap"><span class="gensmall">
		<!-- BEGIN watch -->
		<!-- BEGIN image -->
		<a href="{U_WATCH_TOPIC}" class="gensmall"><img src="{I_WATCH_TOPIC}" border="0" title="{L_WATCH_TOPIC}" alt="{L_WATCH_TOPIC}" /></a>
		<!-- END image -->
		<!-- BEGIN image_ELSE -->
		<a href="{U_WATCH_TOPIC}" class="gensmall">{L_WATCH_TOPIC}</a>
		<!-- END image_ELSE -->
		<br />
		<!-- END watch -->
		<!-- BEGIN unmark_read -->
		<a href="{U_UNREAD_TOPIC}" class="gensmall">{L_UNREAD_TOPIC}</a> ::
		<!-- END unmark_read -->
		<a href="{U_VIEW_OLDER_TOPIC}" class="gensmall">{L_VIEW_PREVIOUS_TOPIC}</a> :: <a href="{U_VIEW_NEWER_TOPIC}" class="gensmall">{L_VIEW_NEXT_TOPIC}</a><br/>
		<b>
		<!-- BEGIN pagination -->
		<!-- BEGIN unique_ELSE -->
		{pagination.L_GOTO}:&nbsp;
		<!-- END unique_ELSE -->
		<!-- BEGIN previous -->
		<a href="{pagination.U_PREVIOUS}" class="gensmall">{pagination.L_PREVIOUS}</a>&nbsp;
		<!-- END previous -->

		<!-- BEGIN page_number -->
		<!-- BEGIN number -->
		<!-- BEGIN current -->
		{pagination.page_number.PAGE}{pagination.page_number.L_SEP}
		<!-- END current -->
		<!-- BEGIN current_ELSE -->
		<a href="{pagination.page_number.U_PAGE}" class="gensmall">{pagination.page_number.PAGE}</a>{pagination.page_number.L_SEP}
		<!-- END current_ELSE -->
		<!-- END number -->
		<!-- BEGIN number_ELSE -->
		...,
		<!-- END number_ELSE -->
		<!-- END page_number -->

		<!-- BEGIN next -->
		<a href="{pagination.U_NEXT}" class="gensmall">{pagination.L_NEXT}</a>
		<!-- END next -->
		<!-- END pagination -->
	</b></span></td>
</tr>
</table>

<table class="forumline" width="100%" cellspacing="1" cellpadding="3" border="0">
	{POLL_DISPLAY}
	<tr>
		<th class="thCornerL" width="150" nowrap="nowrap">{L_AUTHOR}</th>
		<th class="thCornerR" nowrap="nowrap">{L_MESSAGE}</th>
	</tr>
	<!-- BEGIN postrow -->
	<tr> 
		<td width="150" align="left" valign="top" class="{postrow.ROW_CLASS}"><span class="name"><a name="{postrow.U_POST_ID}"></a><b>{postrow.POSTER_NAME}</b></span><br /><span class="postdetails">{postrow.POSTER_RANK}<br />{postrow.RANK_IMAGE}{postrow.POSTER_AVATAR}<br /><br />{postrow.POSTER_JOINED}<br />{postrow.POSTER_POSTS}<br />{postrow.POSTER_FROM}</span><br /></td>
		<td class="{postrow.ROW_CLASS}" width="100%" height="28" valign="top"><table width="100%" border="0" cellspacing="0" cellpadding="0">
			<tr>
				<td width="100%"><a href="{postrow.U_MINI_POST}"><img src="{postrow.MINI_POST_IMG}" width="12" height="9" alt="{postrow.L_MINI_POST_ALT}" title="{postrow.L_MINI_POST_ALT}" border="0" /></a><span class="postdetails">{L_POSTED}: {postrow.POST_DATE}<span class="gen">&nbsp;</span>&nbsp; &nbsp;{L_POST_SUBJECT}:
					<!-- BEGIN msg_icon -->
					<img src="{postrow.msg_icon.I_ICON}" border="0" title="{postrow.msg_icon.L_ICON}" align="absbottom" />
					<!-- END msg_icon -->
					{postrow.POST_SUBJECT}
					<!-- BEGIN sub_title -->
					<br />{L_SUB_TITLE}: {postrow.sub_title.SUB_TITLE}
					<!-- END sub_title -->
					<!-- BEGIN announce -->
					<br />{postrow.announce.S_ANNOUNCE}
					<!-- END announce -->
					<!-- BEGIN calendar_event -->
					<br />{postrow.calendar_event.S_CALENDAR_EVENT}
					<!-- END calendar_event -->
				</span></td>
				<td valign="top" nowrap="nowrap">{postrow.QUOTE_IMG} {postrow.EDIT_IMG} {postrow.DELETE_IMG} {postrow.IP_IMG}
				<!-- BEGIN unmark_read -->
				<a href="{postrow.U_UNREAD_POST}" class="gensmall"><img src="{I_UNREAD}" border="0" alt="{L_UNREAD_POST}" title="{L_UNREAD_POST}" /></a>
				<!-- END unmark_read -->
				</td>
			</tr>
			<tr> 
				<td colspan="2"><hr /></td>
			</tr>
			<tr>
				<td colspan="2"><span class="postbody">{postrow.MESSAGE}{postrow.SIGNATURE}</span><span class="gensmall">{postrow.EDITED_MESSAGE}</span></td>
			</tr>
		</table></td>
	</tr>
	<tr> 
		<td class="{postrow.ROW_CLASS}" width="150" align="left" valign="middle"><span class="nav"><a href="#top" class="nav">{L_BACK_TO_TOP}</a></span></td>
		<td class="{postrow.ROW_CLASS}" width="100%" height="28" valign="bottom" nowrap="nowrap"><table cellspacing="0" cellpadding="0" border="0" height="18" width="18">
			<tr> 
				<td valign="middle" nowrap="nowrap">{postrow.PROFILE_IMG} {postrow.PM_IMG} {postrow.EMAIL_IMG} {postrow.WWW_IMG} {postrow.AIM_IMG} {postrow.YIM_IMG} {postrow.MSN_IMG}<script language="JavaScript" type="text/javascript"><!-- 

	if ( navigator.userAgent.toLowerCase().indexOf('mozilla') != -1 && navigator.userAgent.indexOf('5.') == -1 && navigator.userAgent.indexOf('6.') == -1 )
		document.write(' {postrow.ICQ_IMG}');
	else
		document.write('</td><td>&nbsp;</td><td valign="top" nowrap="nowrap"><div style="position:relative"><div style="position:absolute">{postrow.ICQ_IMG}</div><div style="position:absolute;left:3px;top:-1px">{postrow.ICQ_STATUS_IMG}</div></div>');
				
				//--></script><noscript>{postrow.ICQ_IMG}</noscript></td>
			</tr>
		</table></td>
	</tr>
	<tr> 
		<td class="spaceRow" colspan="2" height="1"><img src="{I_SPACER}" alt="" width="1" height="1" /></td>
	</tr>
	<!-- END postrow -->
	<tr align="center"> 
		<td class="catBottom" colspan="2" height="28"><table cellspacing="0" cellpadding="0" border="0">
			<tr><form method="post" action="{S_POST_DAYS_ACTION}">
				<td align="center"><span class="gensmall">{L_DISPLAY_POSTS}: {S_SELECT_POST_DAYS}&nbsp;{S_SELECT_POST_ORDER}&nbsp;<input type="submit" value="{L_GO}" class="liteoption" name="submit" /></span></td>
			</form></tr>
		</table></td>
	</tr>
</table>

<table width="100%" cellspacing="2" cellpadding="2" border="0">
<tr>
	<td align="left" nowrap="nowrap"><span class="nav"><a href="{U_POST_NEW_TOPIC}"><img src="{POST_IMG}" border="0" alt="{L_POST_NEW_TOPIC}" align="middle" /></a>&nbsp;&nbsp;&nbsp;<a href="{U_POST_REPLY_TOPIC}"><img src="{REPLY_IMG}" border="0" alt="{L_POST_REPLY_TOPIC}" align="middle" /></a></span></td>
	<td width="100%" valign="top"><span class="gensmall">
		<!-- BEGIN pagination -->
		<b>{pagination.L_PAGE_OF}</b>&nbsp;{pagination.L_COUNT}
		<!-- END pagination -->
	</span></td>
	<td align="right" valign="top" nowrap="nowrap"><span class="gensmall"><b>
		<!-- BEGIN pagination -->
		<!-- BEGIN unique_ELSE -->
		{pagination.L_GOTO}:&nbsp;
		<!-- END unique_ELSE -->
		<!-- BEGIN previous -->
		<a href="{pagination.U_PREVIOUS}" class="gensmall">{pagination.L_PREVIOUS}</a>&nbsp;
		<!-- END previous -->

		<!-- BEGIN page_number -->
		<!-- BEGIN number -->
		<!-- BEGIN current -->
		{pagination.page_number.PAGE}{pagination.page_number.L_SEP}
		<!-- END current -->
		<!-- BEGIN current_ELSE -->
		<a href="{pagination.page_number.U_PAGE}" class="gensmall">{pagination.page_number.PAGE}</a>{pagination.page_number.L_SEP}
		<!-- END current_ELSE -->
		<!-- END number -->
		<!-- BEGIN number_ELSE -->
		...,
		<!-- END number_ELSE -->
		<!-- END page_number -->

		<!-- BEGIN next -->
		<a href="{pagination.U_NEXT}" class="gensmall">{pagination.L_NEXT}</a>
		<!-- END next -->
		<!-- BEGIN unique_ELSE -->
		<br />
		<!-- END unique_ELSE -->
		<!-- END pagination -->
		</b><a href="{U_VIEW_OLDER_TOPIC}" class="gensmall">{L_VIEW_PREVIOUS_TOPIC}</a> :: <a href="{U_VIEW_NEWER_TOPIC}" class="gensmall">{L_VIEW_NEXT_TOPIC}</a><br/>
		<!-- BEGIN watch -->
		<!-- BEGIN image -->
		<a href="{U_WATCH_TOPIC}" class="gensmall"><img src="{I_WATCH_TOPIC}" border="0" title="{L_WATCH_TOPIC}" alt="{L_WATCH_TOPIC}" /></a>
		<!-- END image -->
		<!-- BEGIN image_ELSE -->
		<a href="{U_WATCH_TOPIC}" class="gensmall">{L_WATCH_TOPIC}</a>
		<!-- END image_ELSE -->
		<!-- END watch -->
	</span></td>
</tr>
</table>

{NAVIGATION_BOX}

<table width="100%" cellspacing="2" border="0" align="center">
  <tr> 
	<td width="40%" valign="top" nowrap="nowrap" align="left">{S_TOPIC_ADMIN}</td>
	<td align="right" valign="top" nowrap="nowrap">
		<table cellspacing="0" cellpadding="0" border="0" width="100%">
		<tr>
			<td nowrap="nowrap" align="right"><span class="gensmall">{JUMPBOX}</span></td>
		</tr>
		</table><br /><span class="gensmall">{S_AUTH_LIST}
	</span></td>
  </tr>
</table>

Posted: Fri Dec 31, 2004 4:03 pm
by ScionCrow
Works fine in FireFox. Must be an issue with Internet Explorer... Have you looked at the posts? Some posts will deform the topic in a weird way and it takes the scrollbar when it doesn't need to. I remember a mod to force word wrap but I don't know if that's your problem.

Posted: Sat Jan 01, 2005 4:43 pm
by carolol
Word wrap is not the problem. It's kinda weird... does someone else can help me?

Posted: Sat Jan 01, 2005 9:09 pm
by carolol
I just found out it's normal for guests and registered users, the problem appears only for moderators and admins because of the 'edit', 'ip' and 'X' buttons! Does anyone know how to fix this?

Posted: Mon Jan 03, 2005 9:54 pm
by Valhala
I have exactly the same problem, only admin and moderators have the problem and in firefox it works perfectly. Nobody has a solution ?

Posted: Wed Apr 06, 2005 10:03 pm
by custmguru®