Cannot view XML input using XSL style sheet.. Anyone ?

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
nikos
Registered User
Posts: 30
Joined: Tue Feb 25, 2003 7:48 pm

Cannot view XML input using XSL style sheet.. Anyone ?

Post by nikos »

I have a forum with 4000 registered users, 8000 posts...

I clicked to see this one post a few minutes ago and I got this



The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


--------------------------------------------------------------------------------

End tag 'head' does not match the start tag 'meta'. Error processing resource 'http://XXXXXXXX/phpBB2/viewtopic.php?t=1519'. Line 75, Position 3


</head>
--^


I tried 3-4 times, kept getting the same message..

Finally I logged out and then logged back in and the error message was gone... I have the latest version...

Any ideas what happened?
Vic D'Elfant
Former Team Member
Posts: 6203
Joined: Sun May 02, 2004 6:21 pm
Location: NL, Maastricht
Contact:

Post by Vic D'Elfant »

This has something to do with the template you're using at your board. Have you tried using another template?

Vic
midd.ag • DTP, web development & printing
http://www.midd.ag
krustyx
Registered User
Posts: 110
Joined: Fri Jul 12, 2002 3:12 am
Location: Chicoutimi / Québec
Contact:

Post by krustyx »

some users have the same problem here
vwquebec.ca
The Techboy
Registered User
Posts: 207
Joined: Tue May 04, 2004 7:37 pm

Post by The Techboy »

Go into overall_header.tpl

find this:

Code: Select all

<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1">
<meta http-equiv="Content-Style-Type" content="text/css">
and change it to

Code: Select all

<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1"/>
<meta http-equiv="Content-Style-Type" content="text/css"/>
I'm directing that at krustyx, though, it should be the same problem for you both.

Oh and krusty...go into the same file...change

Code: Select all

<link rel="stylesheet" href="templates/iCGstation/iCGstation.css" type="text/css" -->
to

Code: Select all

<link rel="stylesheet" href="templates/iCGstation/iCGstation.css" type="text/css"/>
Eat recycled food. It's good for the environment and OK for you.
alycad
Registered User
Posts: 160
Joined: Thu Mar 04, 2004 10:13 am
Location: Portugal
Contact:

Post by alycad »

Has anyone tryed this solution?

thanls

Alvaro M
mtw
Registered User
Posts: 17
Joined: Wed Jan 05, 2005 3:13 am
Contact:

Try this!

Post by mtw »

I'm using the FISUBICE theme and been getting the same issues. Tried the things above and still had the issue. And I keep getting the error about the white space not being allowed.

Well, by accident, while doing something else, I was in my CSS file and stumbled across a tag in the HEADER data area of the CSS file and found this

WHITE SPACE:none

I deleted the entire comment of WHITESPACE:NONE and I haven't had a problem since. COuld be total coincidence or it could be the solution. But for now, my site is rocking again and I haven't seen in XML or XSL error since.

I hope this is the solution and all of you put down the gun, take the rope down from the ceiling fans, put away the blades, and your sites start working properly for you too.
Locked

Return to “2.0.x Support Forum”