Page 1 of 1

SQL error in admin_ug_auth when trying to set moderators

Posted: Thu Jan 06, 2005 12:22 pm
by tm6tech
Hi, hopefully someone can help me with this problem.

I'm getting the following error message when trying to set up moderators on my board:
Couldn't update private forum permissions

DEBUG MODE

SQL Error : 1064 You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near ' 1)' at line 2

INSERT INTO phpbb_auth_access (forum_id, group_id, auth_mod) VALUES (11, , 1)

Line : 390
File : /home/httpd/vhosts/titaniumarchives.com/httpdocs/board/admin/admin_ug_auth.php


It seems to me that the problem is that the " 1" being inserted into auth_mod has a blank space in front of it. I can't work out what part of the code I need to change to fix that though...

Am I barking up the right tree?

Here's the code from my admin_ug_auth.php, if that helps.

http://www.titaniumarchives.com/admin_ug_auth.txt

Thanks

Posted: Thu Jan 06, 2005 1:08 pm
by battye
Can you fill out the Support Request Template please? It's important to know whether you have any MOD's, Styles etc installed

Posted: Thu Jan 06, 2005 4:47 pm
by paradoxnj
I have the same issue:

URL: http://www.jet3d.com/forum
Template(s) used: SubSilver
Any and all MODs: IPLogger, RestrictGuestAccess
Do you use a port of phpBB: No
Version of phpBB: 2.0.11
Version of PHP: 4
Which database server and version: MySQL 3.23
Host: www.jet3d.com
Did someone install this for you/who: No. I did.
Is this an upgrade/from what to what: 2.0.5 -> 2.0.11
Is this a conversion/from what to what: No.
Have you searched for your problem: Yes. I found this thread.
If so, what terms did you try: admin_ug_auth.php
State the nature of your problem: I get an error in admin_ug_auth.php when adding a moderator.
Do you have a test account for us: I could make one if necessary.

Posted: Thu Jan 06, 2005 4:51 pm
by Drexion
tm6tech, paradoxnj >> Try the following:
Save the following script as <something>.php in your phpbb folder and run it from your browser: (by pointing your browser to it)
http://www.phpbb.com/phpBB/viewtopic.php?t=49996

Posted: Thu Jan 06, 2005 5:02 pm
by paradoxnj
It worked. Thanks a bunch. A very quick response too. :)

Posted: Fri Jan 07, 2005 12:48 am
by tm6tech
8) it worked for me too :)

thanks mate :)