Upgrading 2.0.3 to 2.0.11

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Up the Junction
Registered User
Posts: 23
Joined: Wed Apr 02, 2003 10:26 pm

Upgrading 2.0.3 to 2.0.11

Post by Up the Junction »

Problem: I need to upgrade from v 2.0.3 to 2.0.11 (I know, I know).

Mods: My forum is heavily modded but I'm happy to start from scratch with a clean software install.

Question: What in your opinion is the easiest way to upgrade? I understand some tables/the db index was changed from 2.0.3 to 2.0.4 (or some subsequent version) so is it a case of having to upgrade in stages (ie 0.3 to 0.4, then 0.4-0.8 etc) - or can I run a straight patch from 0.3 to 0.11?

I should add that my php and phpbb knowledge is reasonably limited (hence the delay in upgrading!) so the easiest route, the better really.

All advice appreciated. Many thanks.
User avatar
pentapenguin
Former Team Member
Posts: 11030
Joined: Thu Jul 01, 2004 4:15 am
Location: GA, USA

Post by pentapenguin »

Probably would be easiest to start fresh and reinstall any MODs (make sure they're compatible with 2.0.11).
The official upgrading phpBB knowledge base article ;)
Support Resources: Support Request Template
If you need professional assistance with your board, please contact me for my reasonable rates.
Up the Junction
Registered User
Posts: 23
Joined: Wed Apr 02, 2003 10:26 pm

Post by Up the Junction »

pentapenguin wrote: Probably would be easiest to start fresh and reinstall any MODs (make sure they're compatible with 2.0.11).
The official upgrading phpBB knowledge base article ;)


Thanks ... I had had a browse around there previously but could find nothing to confirm whether I needed to upgrade in stages or not.
Up the Junction
Registered User
Posts: 23
Joined: Wed Apr 02, 2003 10:26 pm

Post by Up the Junction »

Okay ... I'm looking at running a clean install of 2.0.11 - but can see no info with regard to compatibility with v2.0.3 db. The knowledge base re-install page says nothing about incompatibilities and how to deal.

I have been recommended to upgrade versions gradually - again, can anyone confirm? If so, which versions from 2.0.3 onwards do I need to install?

Thanks again in advance.
User avatar
Drexion
Former Team Member
Posts: 8892
Joined: Sat Jan 25, 2003 9:54 pm
Location: City 17

Post by Drexion »

Up the Junction>> The 'update_to_2011.php' file will modify the database to 2.0.11 standards.
So basically backup the database/forum files safely before doing anything.
You are getting rid of the MODs right ?
Then upload fresh 2.0.11 files, overwriting the ones on your server. (except the config.php file, don't upload that)
Then, run the update script. In the 'install' folder is the update_to_2011.php file. Point your browser to ...yoursite.com/.../install/update_to_2011.php , which will run it, then afterwards delete the install folder from your forum folder.

A possible problem I can see arising is any database modifications which your MODs may have required - they *may* conflict with the update script. If possible remove any tables/undo any changes to the database which your MODs may have needed. Which is why you should backup everything first.
Up the Junction
Registered User
Posts: 23
Joined: Wed Apr 02, 2003 10:26 pm

Post by Up the Junction »

Drexion: thanks. I'll give it a go.

It's been a while since I modded anything but I'm pretty sure all the mods I've made are layout changes (table wirths, form sizes, colours etc). Nothing much grander than that.
Up the Junction
Registered User
Posts: 23
Joined: Wed Apr 02, 2003 10:26 pm

Post by Up the Junction »

Just to say all went well, unbelievably not a single hitch 8O

http://www.kumb.com/forum/

Thanks again for the assistance chaps ... much appreciated.
Locked

Return to “2.0.x Support Forum”