Error after update to 2.0.12

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Ms Givings
Registered User
Posts: 17
Joined: Tue Feb 22, 2005 10:44 pm

Error after update to 2.0.12

Post by Ms Givings »

Hi,

I'm getting the following error in the ACP:

Your installation does not seem to be up to date. Updates are available for your version of phpBB, please visit http://www.phpbb.com/downloads.php to obtain the latest version.
The latest available version is phpBB 2.0.12.You are running phpBB 2.0.11.


Not true. We have uploaded all the changed files in the 2.0.11 - 2.0.12 update pack.

I think this may be related to one of the mods we have but I haven't a clue which one. Anyone have any idea of what I need to fix to get rid of this spurious message?

TIA
Miranda
a fool and his honey are soon parted

Forau
Registered User
Posts: 57
Joined: Sat Apr 26, 2003 9:44 pm
Contact:

Post by Forau »

Did you use the update.php in the package? That one will update your version in the database to 2.0.12 as well.

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK »

You need to put the file update_to_latest.php in a folder called install and point your browser to
http://yourdomain/phpBB2/install/update_to_latest.php


Jim

Ms Givings
Registered User
Posts: 17
Joined: Tue Feb 22, 2005 10:44 pm

Post by Ms Givings »

Nope. I uploade all three files supplied in ..updater/install/
install.php
upgrade.php
update_to_latest.php
to the phpBB root and tried to run them. They all fail will erors like:

Warning: main(./../extension.inc): failed to open stream: No such file or directory in /usr/local/psa/home/vhosts/utterpants.co.uk/httpdocs/pantsbb/upgrade.php on line 35

Confused... :cry:
Miranda
a fool and his honey are soon parted

groundfighter
Registered User
Posts: 1909
Joined: Sat Nov 08, 2003 2:15 am
Location: Las Vegas, NV
Contact:

Post by groundfighter »

put the file update_to_latest.php in the phpbb/install directory or any other directory below phpbb and then run it and delete it.

Hawk-G-
Registered User
Posts: 3
Joined: Wed Nov 10, 2004 3:37 pm

Post by Hawk-G- »

change the version number in the database: phpbb_config - version
change .0.11 to .0.12

Ms Givings
Registered User
Posts: 17
Joined: Tue Feb 22, 2005 10:44 pm

Post by Ms Givings »

Jim_UK wrote: You need to put the file update_to_latest.php in a folder called install and point your browser to
http://yourdomain/phpBB2/install/update_to_latest.php


Jim, you're a gem and I'm an idiot. All spiffy now, ta! ;-)

Thanks to everyone else who replied so quickly too. You folks are the best and don't let anyone tell you differently. You're all welcome on my board (and site) anytime:
Utterpants

:lol:
Miranda
a fool and his honey are soon parted

Locked

Return to “2.0.x Support Forum”