upgrading from 2.0.6 to 2.0.13

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
hoofinitnorth
Registered User
Posts: 20
Joined: Mon Dec 27, 2004 9:58 pm
Location: South-Central Alaska
Contact:

upgrading from 2.0.6 to 2.0.13

Post by hoofinitnorth »

REPOST from another thread:

I'm also having trouble upgrading to 2.0.13 from 2.0.6. I use Start Logic as a host and they provided 2.0.6. They said I have to do my own upgrades/updates so I came here and downloaded the full version and followed the instructions as best I could. It is not working. It was doing the same thing over and over this AM but suddenly it is doing something different but still not working. It keeps giving me grief. Ideas?
hoofinitnorth
Registered User
Posts: 20
Joined: Mon Dec 27, 2004 9:58 pm
Location: South-Central Alaska
Contact:

upgrade - forum lost?

Post by hoofinitnorth »

OK, I think I figured it out using Jim's suggestion to just do the change files.

Now I have a bigger problem. How do I get my forum back (all the posts & users, etc.)? I did a back-up (complete and data and structure in both formats just in case) but when I restore any of them, I get critical errors.
hoofinitnorth
Registered User
Posts: 20
Joined: Mon Dec 27, 2004 9:58 pm
Location: South-Central Alaska
Contact:

Post by hoofinitnorth »

No matter what I do, if I try to restore my files (even using the old version of 2.0.6), I get this when trying to access the forums:
message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?
User avatar
SnowManrcd
Registered User
Posts: 155
Joined: Tue Oct 21, 2003 6:05 pm

Post by SnowManrcd »

did you upload the install dir and run upgrade_to_latest.php?
-SnowMan
hoofinitnorth
Registered User
Posts: 20
Joined: Mon Dec 27, 2004 9:58 pm
Location: South-Central Alaska
Contact:

Post by hoofinitnorth »

Yes, I ran the upgrade to latest page but that is when I started getting the aforementioned error.
flogger12
Registered User
Posts: 14936
Joined: Tue Nov 25, 2003 2:13 am

Post by flogger12 »

did you then delete the install directory like it says to.


robert
User avatar
SnowManrcd
Registered User
Posts: 155
Joined: Tue Oct 21, 2003 6:05 pm

Post by SnowManrcd »

did you get to the point where it askes you to delete the above directorys?
-SnowMan
User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK »

If you used the "Changed files only" method why would you need to restore your database? The idea with that method is that it will upgrade your database without damaging the tables. It will just add any extra tables or fields and the extra files added since version 2.0.6 will also be there.

Jim
hoofinitnorth
Registered User
Posts: 20
Joined: Mon Dec 27, 2004 9:58 pm
Location: South-Central Alaska
Contact:

Post by hoofinitnorth »

Yes, I deleted the install files. It never told me to, the install directions did. I need to restore my database because I originally followed the directions for full version, not the changed files version (which tells you to delete EVERYTHING and of course I backed-up my database first).

OK, the problem I have now is that if I start from scratch now with a full version how do I get my database (from version 2.0.6) back? If I go back to 2.0.6 for some reason I still can't restore the database and make it work. :?
thegcfgroup
Registered User
Posts: 7
Joined: Mon Mar 07, 2005 5:01 am
Contact:

Post by thegcfgroup »

This is why I havent updated from 2.0.6. Its a pain in the ass especially if you have thousaneds of threads and members. Its not very user friendly if you have little or no experience with php and message boards. You would think it their would be a link where it did an auto updated and let you pick the options you wanted to keep and install.
flogger12
Registered User
Posts: 14936
Joined: Tue Nov 25, 2003 2:13 am

Post by flogger12 »

this is not difficult, the instructions are simplet an straight forward.

follow them exactly and in order and you will not have a problelm


now, your members, posts, settings everything is in the database, so no matter what you do to the phpbb files, you can't hurt that.

if you do a complete new install with a new database or at least new table prefix. then once it is all up with the default message and working, you can just change the new config.php file to the correct info for your old database.

then you will have to run the database update_to_latest.php file and you are done.


robert
hoofinitnorth
Registered User
Posts: 20
Joined: Mon Dec 27, 2004 9:58 pm
Location: South-Central Alaska
Contact:

Post by hoofinitnorth »

flogger12 wrote: this is not difficult, the instructions are simplet an straight forward.


They seemed simple and straight-forward to me too, they just didn't work. Actually, the changed files version install worked fine but then it wouldn't restore my database. Now I can get the full version install to the same point but I again cannot restore my database. Plus I'm not sure what happens to the database when I upgrade the forum to 2.0.13 and then try to restore a 2.0.6 database...?
flogger12 wrote: follow them exactly and in order and you will not have a problelm


I thought I had done that, yet I am still having a problem.
flogger12 wrote: now, your members, posts, settings everything is in the database, so no matter what you do to the phpbb files, you can't hurt that.


I hope it's still ok, it SHOULD be.
flogger12 wrote: if you do a complete new install with a new database or at least new table prefix. then once it is all up with the default message and working, you can just change the new config.php file to the correct info for your old database.

then you will have to run the database update_to_latest.php file and you are done.


OK so you are saying do the upgrade, change the prefix (how?), restore the database, THEN do the update_to_latest?
I need step-by-step recipes for this. Help?
hoofinitnorth
Registered User
Posts: 20
Joined: Mon Dec 27, 2004 9:58 pm
Location: South-Central Alaska
Contact:

Post by hoofinitnorth »

Flogger, in your suggestion, please specify whether you are talking about doing a changed-files-only upgrade or a full version install/upgrade? See my previous post concerning what happens to a 2.0.6 database installed on a 2.0.13 phpbb...
hoofinitnorth
Registered User
Posts: 20
Joined: Mon Dec 27, 2004 9:58 pm
Location: South-Central Alaska
Contact:

Post by hoofinitnorth »

No further help available on this topic?
User avatar
Hawk-Metal
Registered User
Posts: 34
Joined: Sun Jun 13, 2004 5:56 pm
Location: Croatia
Contact:

Post by Hawk-Metal »

did you have any mods installed on your old forum?
A tip: Usually I backup my database directly from CPanel or phpmyadmin, not phpbb, & data never gets corrupted. Maybe you should do the same, specially if you have moded forum.
Locked

Return to “2.0.x Support Forum”