Config.php is Empty?

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
wickedintense
Registered User
Posts: 52
Joined: Mon Oct 25, 2004 2:42 am

Config.php is Empty?

Post by wickedintense »

normal or not?

if it isn't normal does anyone know where i can get the

Code: Select all

 to put in the config.php file?

Bury Me In Smoke
Registered User
Posts: 144
Joined: Wed Mar 23, 2005 6:46 am
Location: Canada

Post by Bury Me In Smoke »

Config.php stays blank until you install phpBB onto your server.

wickedintense
Registered User
Posts: 52
Joined: Mon Oct 25, 2004 2:42 am

Post by wickedintense »

phpbb is installed. everything is set up in myphpadmin.. it seems like everything in there is in tact and all the files seem. but my bb is coming up as "page not found" is there a file i should look for or one that is missing that i should replace because i am completely lost here.


when i try to reinstall or upgrade.php etc etc it comes up with errors like this...

Warning: main(./../extension.inc): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 35

Warning: main(./../extension.inc): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 35

Warning: main(): Failed opening './../extension.inc' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/tantri3/public_html/bulletinboard/upgrade.php on line 35

Warning: main(./../config.): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 36

Warning: main(./../config.): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 36

Warning: main(): Failed opening './../config.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/tantri3/public_html/bulletinboard/upgrade.php on line 36

Warning: main(./../includes/constants.): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 37

Warning: main(./../includes/constants.): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 37

Warning: main(): Failed opening './../includes/constants.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/tantri3/public_html/bulletinboard/upgrade.php on line 37

Warning: main(./../includes/functions.): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 38

Warning: main(./../includes/functions.): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 38

Warning: main(): Failed opening './../includes/functions.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/tantri3/public_html/bulletinboard/upgrade.php on line 38

Warning: main(./../includes/db.): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 51

Warning: main(./../includes/db.): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 51

Warning: main(): Failed opening './../includes/db.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/tantri3/public_html/bulletinboard/upgrade.php on line 51

Warning: main(./../includes/bbcode.): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 52

Warning: main(./../includes/bbcode.): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 52

Warning: main(): Failed opening './../includes/bbcode.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/tantri3/public_html/bulletinboard/upgrade.php on line 52

Warning: main(./../includes/functions_search.): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 53

Warning: main(./../includes/functions_search.): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 53

Warning: main(): Failed opening './../includes/functions_search.' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/tantri3/public_html/bulletinboard/upgrade.php on line 53

Warning: file(schemas/mysql_schema.sql): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 197

Warning: file(schemas/mysql_basic.sql): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 283

Fatal error: Call to a member function on a non-object in /home/tantri3/public_html/bulletinboard/upgrade.php on line 145

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom »

Warning: main(./../extension.inc): failed to open stream: No such file or directory in /home/tantri3/public_html/bulletinboard/upgrade.php on line 35


This means that you put upgrade.php in the root directory of the PHPBB install, rather than in /install, as it should be. It's expecting "extension.inc" to be one directory above it; it's currently in the same directory.
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

wickedintense
Registered User
Posts: 52
Joined: Mon Oct 25, 2004 2:42 am

Post by wickedintense »

thanks espi

so i made the install folder and put the install in there now i get this error message



Parse error: parse error, unexpected T_STRING in /home/tantri3/public_html/bulletinboard/includes/functions.php on line 134

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom »

Lines 131-135 of includes/functions.php are:

Code: Select all

	$category_rows = array();
	while ( $row = $db->sql_fetchrow($result) )
	{
		$category_rows[] = $row;
	}
Nothing in that should give an error, unless it's been modified somewhere along the line.
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

wickedintense
Registered User
Posts: 52
Joined: Mon Oct 25, 2004 2:42 am

Post by wickedintense »

i haven't modified that but i did replace the functions file with the new functions.php and when i ran the install i get this message now...

phpBB : Critical Error

Could not connect to the database


any ideas on y it won't connect to the database?

User avatar
ChALkeR
Registered User
Posts: 58
Joined: Thu Apr 07, 2005 5:55 pm
Location: Russia

Post by ChALkeR »

check the login, DB, server and password in config file.
Sorry for my bad English

wickedintense
Registered User
Posts: 52
Joined: Mon Oct 25, 2004 2:42 am

Post by wickedintense »

the config file is completely empty

User avatar
ChALkeR
Registered User
Posts: 58
Joined: Thu Apr 07, 2005 5:55 pm
Location: Russia

Post by ChALkeR »

ok.
What caused this, is this the first install of phpbb?
or an upgrade?
Sorry for my bad English

User avatar
ChALkeR
Registered User
Posts: 58
Joined: Thu Apr 07, 2005 5:55 pm
Location: Russia

Post by ChALkeR »

If the first then just reupload the full (!!!) folder with phpbb and fun index.php

If not, add something like this in config.php:


Code: Select all

<?php
$dbms = 'mysql4';//if you are using mysql4 =)

$dbhost = 'localhost';//your host
$dbname = 'phpbb';//the name of your DB
$dbuser = 'root';//DB user =)
$dbpasswd = '';//Password

$table_prefix = '';//you need to remember wat this was... if you do not use phpmyadmin to find it out

define('PHPBB_INSTALLED', true);//better not tho change this line

?>
Sorry for my bad English

wickedintense
Registered User
Posts: 52
Joined: Mon Oct 25, 2004 2:42 am

Post by wickedintense »

earlier this am the board was hacked. but i ran the toolkit.php to regain my username and password then i ran the fix.php to regain the theme of the board. I then had to fix all the files that were previously modded because i had to update the BB db in order to get the theme completely right. when i did this it shadowed some of my files in the attachment mod so i deleted them because they weren't there before. before this the board was just about 95% fixed :? now i can't access the board and when i run it says "page not found" I've looked in phpmyadmin to see what the db looks like and it seems like everything is still there as well as all the files in mysite.com/bulletinboard yet i can't figure out y i can't connect to the board or for that matter even get onto the index page?

so when i check the config file because that was one of the errors coming up it's empty yet the db and tables etc seem intact??

wickedintense
Registered User
Posts: 52
Joined: Mon Oct 25, 2004 2:42 am

Post by wickedintense »

ChALkeR wrote: If the first then just reupload the full (!!!) folder with phpbb and fun index.php

If not, add something like this in config.php:


Code: Select all

<?php
$dbms = 'mysql4';//if you are using mysql4 =)

$dbhost = 'localhost';//your host
$dbname = 'phpbb';//the name of your DB
$dbuser = 'root';//DB user =)
$dbpasswd = '';//Password

$table_prefix = '';//you need to remember wat this was... if you do not use phpmyadmin to find it out

define('PHPBB_INSTALLED', true);//better not tho change this line

?>


that doesn't seem to be working either -- this is really frustrating but i appreciate your help so much thanx

User avatar
ChALkeR
Registered User
Posts: 58
Joined: Thu Apr 07, 2005 5:55 pm
Location: Russia

Post by ChALkeR »

i ment you have to change the config values into your config params... if you have done so, what does it say?
Sorry for my bad English

wickedintense
Registered User
Posts: 52
Joined: Mon Oct 25, 2004 2:42 am

Post by wickedintense »

ChALkeR wrote: i ment you have to change the config values into your config params... if you have done so, what does it say?


i did add the values and i think they are correct and it has this error


Fatal error: Cannot instantiate non-existent class: sql_db in /home/tantri3/public_html/bulletinboard/includes/db.php on line 60

Locked

Return to “2.0.x Support Forum”