Could not connect to database

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
oojafink
Registered User
Posts: 16
Joined: Fri Apr 22, 2005 5:22 pm

Could not connect to database

Post by oojafink » Fri Apr 22, 2005 5:27 pm

I have been trying to get a forum running from my home PC (Windows XP Pro).

I followed all the install notes and made my Apache 2.0 WebServer PHP enabled. With MySQL i used the Windows installer and used the Standard Configuration.
MySql service is installed and works. I created a database called 'forum'. I have a 'root' account with a password that i set during the MySQL config wizard.

Everything seems to be ok, but when i go to the install.php page of phpbb2 and put in all the info (database localhost, username = root, password = password i set during the mysql config wizard) and i try to install it just says 'PHPBB: CRITICAL ERROR COULD NOT CONNECT TO THE DATABSE'

It doesnt give any line errors, and google doesnt seem to throw up much that helps me.

Ive checked mysql and the database 'forum' definately exists, and the password im using for user 'root' is definately right.

Any ideas?? Or shall I just give up?

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Post by Wo1f » Fri Apr 22, 2005 6:05 pm

Maybe this article can help you out oojafink. Good luck!

oojafink
Registered User
Posts: 16
Joined: Fri Apr 22, 2005 5:22 pm

Post by oojafink » Fri Apr 22, 2005 7:02 pm

Thanks Wo1f.i forgot to say before, im running Apache 2.0/MySql 4.1.11/php 4.3.11/phpbb 2.0.14

I followed the advice in that thread - my config.ini was blank so i copied the info but inserting my details where needed. That didnt work.

So i got the mysqladmin gui application and created a new user and moved the privileges to that user. I then changed the config.ini to reflect the new users details. It still wont work. Same error message.

I read the post where the guy linked in his sig to here - http://dev.mysql.com/doc/mysql/en/old-client.html - but im not sure what i'd be doing there. The guy in the thread says he went from 4.1 to version 4.0 of mysql and it worked.

Would you suggest that I do the same?

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Post by Wo1f » Sat Apr 23, 2005 4:43 pm

I don't believe you need to go that far... yet! There is an option you can check within the "Administrator" to use old passwords (under "Start-up variables").

Image

NOTE: Restart the database server after this change.

I would also recheck folder permissions for PHP and MySQL. If this fails, I'm afraid I don't have anymore suggestions for you. Downgrading might work for you as it has for the other member, but I can tell you there are many successful installations using your configuration.

Let us know the outcome!

PS: Config.ini = Config.php

oojafink
Registered User
Posts: 16
Joined: Fri Apr 22, 2005 5:22 pm

Post by oojafink » Sun Apr 24, 2005 12:35 pm

Sorry Wo1f I saw your post too late.

Indeed I downgraded to 4.0 and did a manual install this time, and now it works fine.

Thank-you for putting me on the right track though :) much appreciated

Wo1f
Registered User
Posts: 2039
Joined: Fri Jan 28, 2005 3:20 am

Post by Wo1f » Sun Apr 24, 2005 3:59 pm

Glad you got it working, and your welcome!

Locked

Return to “2.0.x Support Forum”