2.0.15 upgrade caused ACP link to disappear

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
tplowe
Registered User
Posts: 40
Joined: Mon May 09, 2005 3:50 am

2.0.15 upgrade caused ACP link to disappear

Post by tplowe »

After upgrade to 2.0.15 my ACP link disappeared and I have no administration access. Anyone had this problem? The toolkit hack doesn't work as it reports my database is not MySQL, although it is SQL. This is a brand new forum with no posts. Can I just save the config. file and do a new install, to regain access?

I've looked at all the ACP threads and none seem to be addressing a missing ACP link.
User avatar
nuckfan15
Registered User
Posts: 1849
Joined: Fri Jul 09, 2004 4:46 am
Location: Vancouver, BC
Name: Travis

Post by nuckfan15 »

Travis aka Nuckfan15 - No Private Support
Make use of the Support Request Template when seeking support.
tplowe
Registered User
Posts: 40
Joined: Mon May 09, 2005 3:50 am

Post by tplowe »

I have been through that thread. My ACP link does not even appear anymore. I think most of the problems on that thread concern people wh can't get access after clicking the link.
cybrid3
Registered User
Posts: 1358
Joined: Sun Aug 22, 2004 4:25 am
Location: Midwest somewhere, I think...
Contact:

Post by cybrid3 »

What style are you using?
--Never leave home without a towel and peril sensitive sunglasses!!
arod-1
Registered User
Posts: 1327
Joined: Mon Sep 20, 2004 1:33 pm

Post by arod-1 »

did you try to load the admin file directly?
(ie: if your forum is normally at http://something.something.com/fofo, try http://something.something.com/fofo/admin/index.php
?
not saying this is a solution, more like an experiment....
tplowe
Registered User
Posts: 40
Joined: Mon May 09, 2005 3:50 am

Post by tplowe »

I'm using subsilver, no mods.

I think I'm just plain locked out, when I load the admin page directly I get "You are not authorised to administer this board"

I think the php "toolkit.php" would solve my problem but when I run it, it says it is only compatable with a MySQL database. I think mine is SQL 2000 or SQL-ODBC. This is not my forte, obviously.
cybrid3
Registered User
Posts: 1358
Joined: Sun Aug 22, 2004 4:25 am
Location: Midwest somewhere, I think...
Contact:

Post by cybrid3 »

To save time....

Copy your config.php to your local computer.

Delete the all the phpbb files

Upload a fresh set of phpBB files *excluding* install and contrib directories

Upload the config.php back to the forum directory and give that a try
--Never leave home without a towel and peril sensitive sunglasses!!
Locked

Return to “2.0.x Support Forum”