Please help! admin problems

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
kUr4m4
Registered User
Posts: 13
Joined: Tue May 17, 2005 2:28 pm

Please help! admin problems

Post by kUr4m4 » Tue May 17, 2005 5:18 pm

Just finished installing the forum.
When I log in, I'm considered admin as expected.
I click on admin settings
It brings me to password verification, as predicted but when I put in the right one, it brings me back to the password verification screen and asks for my password again. If it's wrong it says its wrong, but it says nothing when it's right.
We tried all the different codes the other thread had to offer but nothing would work.
We really need help and it's really frustrating. We've tried to understand the code but it's too complex for us yet. Can anyone suggest a way of dealing with this other than the snippets of code we already tried to use.

User avatar
MichaelTunnell
Registered User
Posts: 211
Joined: Fri Apr 29, 2005 9:46 pm
Location: don't rush me
Name: Michael Tunnell
Contact:

Post by MichaelTunnell » Tue May 17, 2005 5:23 pm

once you login to the forum as the admin user it shouldnt ask your for a password to get into the admin. It is suppose to automatically notice who your from your first login...are you getting a login like that?

kUr4m4
Registered User
Posts: 13
Joined: Tue May 17, 2005 2:28 pm

Post by kUr4m4 » Tue May 17, 2005 5:34 pm

Well, now nothing happens, and everything we changed we always brought it back to what it was originally. Admin clicks on go to admin panel and nothing happens. Just refreshs the screen, very frustrating.

User avatar
MichaelTunnell
Registered User
Posts: 211
Joined: Fri Apr 29, 2005 9:46 pm
Location: don't rush me
Name: Michael Tunnell
Contact:

Post by MichaelTunnell » Tue May 17, 2005 5:38 pm

it sounds like your admin/index.php has been removed or corrupted...first, when you go to the bottom what url shows in your browser at the bottom... is it something like this? http://www.yoursite.com/admin/index.php ... i2424sh21a

kUr4m4
Registered User
Posts: 13
Joined: Tue May 17, 2005 2:28 pm

Post by kUr4m4 » Tue May 17, 2005 5:40 pm

the bottom of which now?

kUr4m4
Registered User
Posts: 13
Joined: Tue May 17, 2005 2:28 pm

Post by kUr4m4 » Tue May 17, 2005 5:49 pm

Yup, admin/index.php?sid= blah blah blah yup I goot that.

User avatar
MichaelTunnell
Registered User
Posts: 211
Joined: Fri Apr 29, 2005 9:46 pm
Location: don't rush me
Name: Michael Tunnell
Contact:

Post by MichaelTunnell » Tue May 17, 2005 5:53 pm

now when you click that does it try to go to that page or just it just go back to the initial index page?

StefanL
Registered User
Posts: 2265
Joined: Wed Jul 23, 2003 10:10 pm

Post by StefanL » Tue May 17, 2005 5:55 pm

Try this:

Open admin/pagestart.php
FIND

Code: Select all

 if (!$userdata['session_admin'])
{
	redirect(append_sid("login.$phpEx?redirect=admin/&admin=1", true));
}
REPLACE WITH (Comment the line out)

Code: Select all

 if (!$userdata['session_admin'])
{
//	redirect(append_sid("login.$phpEx?redirect=admin/&admin=1", true));
}
Save and upload it and try to log in. Report back here.
When I suggest that you should alter your files, BACKUP them BEFORE.

kUr4m4
Registered User
Posts: 13
Joined: Tue May 17, 2005 2:28 pm

Post by kUr4m4 » Tue May 17, 2005 5:56 pm

Simply goes back to the original index screen(similar to refresh)
((btw do u have msn, easier to talk that way)) (I'll delete your account after this is sorted if that's what you'd like).

User avatar
MichaelTunnell
Registered User
Posts: 211
Joined: Fri Apr 29, 2005 9:46 pm
Location: don't rush me
Name: Michael Tunnell
Contact:

Post by MichaelTunnell » Tue May 17, 2005 5:57 pm

How would make the code not visible change anything?

kUr4m4
Registered User
Posts: 13
Joined: Tue May 17, 2005 2:28 pm

Post by kUr4m4 » Tue May 17, 2005 6:00 pm

Tried the code,
It now brings me from the initial index page to a password verification page where when the password is put in correctly it asks for the password again for no reason, wrong password tells me that it's a bad password and asks again.

kUr4m4
Registered User
Posts: 13
Joined: Tue May 17, 2005 2:28 pm

Post by kUr4m4 » Tue May 17, 2005 6:15 pm

Any ideas?

StefanL
Registered User
Posts: 2265
Joined: Wed Jul 23, 2003 10:10 pm

Post by StefanL » Tue May 17, 2005 6:19 pm

kUr4m4 wrote: Any ideas?


Yes. Try this:
Open admin/pagestart.php
FIND

Code: Select all

if (!$userdata['session_logged_in'])
{
	redirect(append_sid("login.$phpEx?redirect=admin/", true));
}
REPLACE WITH

Code: Select all

if (!$userdata['session_logged_in'])
{
	die("I'm not logged in!");
	redirect(append_sid("login.$phpEx?redirect=admin/", true));
}
Save and upload it and try to log in. Report back here.
When I suggest that you should alter your files, BACKUP them BEFORE.

kUr4m4
Registered User
Posts: 13
Joined: Tue May 17, 2005 2:28 pm

Post by kUr4m4 » Tue May 17, 2005 6:23 pm

It works, GLORY, thanks alot guys. Thumbs up to you.

Locked

Return to “2.0.x Support Forum”