Page 1 of 2

Problem restoring forums

Posted: Tue May 24, 2005 1:07 am
by Jadestone
I`m cleaning up my server and i decided that i wanted to move my forums from yourdomain.com/forums to just yourdomain.com. I thouhgt this would be simple and fast..... i was wrong (or stupid)

I had phpbb 2.0.13 on the old forums and then i installed phpbb 2.0.15 in the new directory and i set up a new database so that the old ones would work for awhile after.

to make a long story short... I backedup my old forums and installed the new version in my html folder. Did the install, no prob. Now when i do the full restore i keep on getting errors.

IE:

phpBB : Critical Error

Error creating new session

DEBUG MODE

SQL Error : 1054 Unknown column 'session_admin' in 'field list'

INSERT INTO phpbb_sessions (session_id, session_user_id, session_start, session_time, session_ip, session_page, session_logged_in, session_admin) VALUES ('b48504ad80e6d3f7a444a58bea6ddbca', 2, 1116895924, 1116895924, '458b3026', 0, 1, 0)

Line : 172
File : sessions.php



I`m guessing that this has to do with me making a new database? So i then erased my old database and then set my new forums to work on it. Same error, but for some reason it backedup my old forums.


All i`m trying to find out is, is it possible to move my forums without lossing any info? If so how? I never thought i was this stupid..... and it`s making me angry.

thanks in advance :D

almost forgot.

url: (new) http://thebladepact.com (old) http://bladerunnerslinkshell.com/forums

mysql: MySQL 4.1.11
host: aplus.net
no mods

Posted: Tue May 24, 2005 2:44 am
by cybrid3
Run:

/install/upgrade_to_latest.php

Your database restore deleted some required tables in 2.0.15

Posted: Tue May 24, 2005 3:03 am
by Jadestone
No input file specified.


i`m getting this error when i try to upgrade. also do i need to edit any file since i`m using a different domain? and i dropped the /forums.... I think thats the main problem. or not..... man i hate coding.

Posted: Tue May 24, 2005 3:09 am
by cybrid3
/cgi-sys/php.cgi//install1/upgrade_to_latest.php


Your forum is located in a cgi folder?!? 8O

Anways, what you need to do is create an install folder in the root of your forum:

/yourdomain/forum/install

Then put the update_to_latest.php file in the install folder:

/yourdomain/forum/install/update_to_latest.php

Then point your browser to:

http://www.yourdomain.com/forum/install ... latest.php

***Replace yourdomain.com and forum with your own info....

Posted: Tue May 24, 2005 3:25 am
by Jadestone
this is a pain... thanks for the help tho

:D


no my site isn`t in the cgi folder its in the html folder.

ok i deleted my databases and reinstalled phpbb. then i did the restore. then i did the upgrade. now i have this error.

phpBB : Critical Error

Could not query config information

DEBUG MODE

SQL Error : 1146 Table 'test.phpbb_config' doesn't exist

SELECT * FROM phpbb_config

Line : 219
File : common.php


some one must really hate me today... :(

Posted: Tue May 24, 2005 3:29 am
by Jadestone
ahh! i fixed it! apparently it was duplicating the phpbb_config file in MySQL. so all i had to do was delete the copies.

now i need to get this fourm moved... what i was trying to do before this happened was to move it from thebladepact.com/forums to thenbladepact.com..... unfortunatly i keep on getting errors and i`m not understanding how to change the phpbb_config file to do this. I basically dont understand how phpmyadmin works. :x

Posted: Tue May 24, 2005 3:31 am
by cybrid3
Hmmm....

And your restore completed without error?

How big is your backup?

Posted: Tue May 24, 2005 3:37 am
by Jadestone
3.11 MB these forums are fairly new, i`m just trying to clean up my server and i wanted to move the location...

well now i can view the forums and use everything but i can`t get to the admin panel......

getting this error again.

phpBB : Critical Error

Could not query config information

DEBUG MODE

SQL Error : 1146 Table 'test.phpbb_config' doesn't exist

SELECT * FROM phpbb_config

Line : 219
File : common.php


ill have to look in MySQL for another duplicate.

now i`m going to have to edit the phpbb_config file so i can move these too...

Posted: Tue May 24, 2005 3:39 am
by cybrid3
Did you change the domain setting in the ACP before you moved the forums?

You can also change it in the database _config table.

Posted: Tue May 24, 2005 3:40 am
by Jadestone
no i havent moved it yet i`m still trying to fix the admin error first then im going to move it. i dont see any duplicates in the MySQL tho...

Posted: Tue May 24, 2005 3:43 am
by cybrid3
How are you restoring?

Most hosts (and php) have a 2MB limit on uploads, so I would wonder if your backup is completely restoring.....

Unless your using ssh or phpmyadmin.

Posted: Tue May 24, 2005 3:54 am
by Jadestone
im using cuteftp pro, as far as i know i don`t have an upload limit only a 50 GB transfer a month.. I think the problem is i`m workingon 2 forums at the same time, i`m doing the one in the html folder and the one in the forums folder, and the problem also with me changing the directory is that i`m using a different database so when i`m using the backup on the new forums its causing conflict.

but i`m also using phpmyadmin, but when i`m doing the restore from the backup i`m using the one from my boards.

Posted: Tue May 24, 2005 3:58 am
by live2die
i am having this exact problem
phpBB : Critical Error

Error creating new session

DEBUG MODE

SQL Error : 1054 Unknown column 'session_admin' in 'field list'

INSERT INTO phpbb_sessions (session_id, session_user_id, session_start, session_time, session_ip, session_page, session_logged_in, session_admin) VALUES ('b48504ad80e6d3f7a444a58bea6ddbca', 2, 1116895924, 1116895924, '458b3026', 0, 1, 0)

Line : 172
File : sessions.php


but what i am trying to do is move from a free webhost to my own webhost. What i had done is reinstalled phpBB and when i restore the database this is the error i get. I tried all the other solutions but nothing seems to work

Posted: Tue May 24, 2005 3:58 am
by cybrid3
OK....

Are you trying to clean up your database?

It might be simpler to install 2.0.15 where you want it

Copy the old config.php to the new location

Change the Domain Setting on the old forum to the new location to update the database.

And Wah La....Instant move to a new location.

Posted: Tue May 24, 2005 4:38 am
by live2die
I don't have access to the old config.php file and how do you change the domain setting