Session error

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
crazykiller_dude
Registered User
Posts: 33
Joined: Sun Apr 24, 2005 7:52 am

Session error

Post by crazykiller_dude »

I reinstalled phpBB after installing a modification that corrupted a few files.
I reinstalled the whole lot. I got a fresh database and fresh phpBB files from here.

Now its installed i try view the index.php page and it comes up with:

Fatal error: Call to undefined function: session_pagestart() in /home/hjkclanc/public_html/phpBB2/index.php on line 31

On line 31 is this:

$userdata = session_pagestart($user_ip, PAGE_INDEX);

Please if i could get any help possible id greatly appreciate it.

User avatar
zeroK
Former Team Member
Posts: 20964
Joined: Sun Jan 20, 2002 7:36 pm
Location: Klagenfurt / Austria
Contact:

Post by zeroK »

Have you already tried to reupload your includes/sessions.php?
Image My weblog | gamerslog.com | No support via PM or ICQ or email - If you don't know a term or a program mentioned in a post -> Google is your friend

crazykiller_dude
Registered User
Posts: 33
Joined: Sun Apr 24, 2005 7:52 am

Post by crazykiller_dude »

just tried it.

Comes up with same error.

Fatal error: Call to undefined function: session_pagestart() in /home/hjkclanc/public_html/phpBB2/index.php on line 31

User avatar
zeroK
Former Team Member
Posts: 20964
Joined: Sun Jan 20, 2002 7:36 pm
Location: Klagenfurt / Austria
Contact:

Post by zeroK »

Does your includes/sessions.php has a line that starts with

Code: Select all

function session_pagestart
?
Image My weblog | gamerslog.com | No support via PM or ICQ or email - If you don't know a term or a program mentioned in a post -> Google is your friend

crazykiller_dude
Registered User
Posts: 33
Joined: Sun Apr 24, 2005 7:52 am

Post by crazykiller_dude »

its ok now i reinstalled it again completely and it seems to have done the trick

Locked

Return to “2.0.x Support Forum”