emailer.php problem in PHPBB 2.0.16

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
snoopy11hk
Registered User
Posts: 9
Joined: Fri Apr 29, 2005 2:54 pm

emailer.php problem in PHPBB 2.0.16

Post by snoopy11hk »

MYSQL: 4.X
PHPBB: 2.0.16
Mod Installed: CH 2.1.1 ( installed ver. )
EM (ver ??)

problem in Line 234

From Line 229-249 (without install MOD)

Code: Select all

		}

		// Did it work?
		if (!$result)
		{
			message_die(GENERAL_ERROR, 'Failed sending email :: ' . (($this->use_smtp) ? 'SMTP' : 'PHP') . ' :: ' . $result, '', __LINE__, __FILE__);
		}

		return true;
	}

	// Encodes the given string for proper display for this encoding ... nabbed 
	// from php.net and modified. There is an alternative encoding method which 
	// may produce lesd output but it's questionable as to its worth in this 
	// scenario IMO
	function encode($str)
	{
		if ($this->encoding == '')
		{
			return $str;
		}

From Line 229-249 (with install MOD)

Code: Select all

		}

		// Did it work?
		if (!$result)
		{
			message_die(GENERAL_ERROR, 'Failed sending email :: ' . (($this->use_smtp) ? 'SMTP' : 'PHP') . ' :: ' . $result, '', __LINE__, __FILE__);
		}

		return true;
	}

	// Encodes the given string for proper display for this encoding ... nabbed 
	// from php.net and modified. There is an alternative encoding method which 
	// may produce lesd output but it's questionable as to its worth in this 
	// scenario IMO
	function encode($str)
	{
		if ($this->encoding == '')
		{
			return $str;
		}
How can i do for fixing this bug?
Last edited by snoopy11hk on Fri Jul 01, 2005 3:27 pm, edited 1 time in total.

snoopy11hk
Registered User
Posts: 9
Joined: Fri Apr 29, 2005 2:54 pm

Re: emailer.php problem in PHPBB 2.0.16

Post by snoopy11hk »

snoopy11hk wrote: MYSQL: 4.X
PHPBB: 2.0.16
Mod Installed: CH 2.1.1 ( 而 install ver. )
EM (ver ??)

problem in Line 234

From Line 229-249 (without install MOD)

Code: Select all

		}

		// Did it work?
		if (!$result)
		{
			message_die(GENERAL_ERROR, 'Failed sending email :: ' . (($this->use_smtp) ? 'SMTP' : 'PHP') . ' :: ' . $result, '', __LINE__, __FILE__);
		}

		return true;
	}

	// Encodes the given string for proper display for this encoding ... nabbed 
	// from php.net and modified. There is an alternative encoding method which 
	// may produce lesd output but it's questionable as to its worth in this 
	// scenario IMO
	function encode($str)
	{
		if ($this->encoding == '')
		{
			return $str;
		}

From Line 229-249 (with install MOD)

Code: Select all

		}

		// Did it work?
		if (!$result)
		{
			message_die(GENERAL_ERROR, 'Failed sending email :: ' . (($this->use_smtp) ? 'SMTP' : 'PHP') . ' :: ' . $result, '', __LINE__, __FILE__);
		}

		return true;
	}

	// Encodes the given string for proper display for this encoding ... nabbed 
	// from php.net and modified. There is an alternative encoding method which 
	// may produce lesd output but it's questionable as to its worth in this 
	// scenario IMO
	function encode($str)
	{
		if ($this->encoding == '')
		{
			return $str;
		}
How can i do for fixing this bug?

please help, I don't use the account opened by member this function

User avatar
Lumpy Burgertushie
Registered User
Posts: 67413
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie »

what is the complete error message?

most likely, it has nothing to do with any MOD but is because your email settings are not correct for your server.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

snoopy11hk
Registered User
Posts: 9
Joined: Fri Apr 29, 2005 2:54 pm

Post by snoopy11hk »

Lumpy Burgertushie wrote: what is the complete error message?

most likely, it has nothing to do with any MOD but is because your email settings are not correct for your server.


robert

Code: Select all

Failed sending email :: PHP :: 

DEBUG MODE 

Line : 234 
File : emailer.php
I have been disable the email service, but the problem still here~

snoopy11hk
Registered User
Posts: 9
Joined: Fri Apr 29, 2005 2:54 pm

Post by snoopy11hk »

snoopy11hk wrote:
Lumpy Burgertushie wrote:what is the complete error message?

most likely, it has nothing to do with any MOD but is because your email settings are not correct for your server.


robert

Code: Select all

Failed sending email :: PHP :: 

DEBUG MODE 

Line : 234 
File : emailer.php
any people??
I have been disable the email service, but the problem still here~

User avatar
Lumpy Burgertushie
Registered User
Posts: 67413
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie »

ok, here we go,

phpbb in standard form, requires some type of email server to be available for sending notices of replies, registrations, etc,.

normally , this is handled by the built-in mail function of php.

some providers turn that off, for reasons of their own. that leaves you with one choice and that is to use smtp, now, to use smtp , you have to have access to a smtp server.

If you have your own domain name and hosting account, you can probably use your own smtp server, the same one you use for your email accounts at your domain name.

If you don't have that, then sometimes you can use your ISP's smtp server, not often though.

You might be able to find a free one that is not banned by everyone for spam.

If you are on your own home computer, especially running windows, then the php mail function is not available to you and you will have to install some kind of smtp server on your computer or find one that will let you access it.


Now, if none of that works for you, you can completely disable the email capabilities of phpbb by installing this hack:
http://www.phpbbhacks.com/viewhack.php?id=1186
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

Locked

Return to “2.0.x Support Forum”