Page 1 of 1

Most ever online

Posted: Fri Jul 22, 2005 3:40 pm
by tomlarose
I'm having a problem at the bottom of the main page of my forum where it show's the current users online, and the most ever online. I will show the current number of users online, but the most ever online is the current amount of users.. It dosen't keep track of the most ever online.. here's an example of what I'm talking about:

When I visited at 7:31pm :

In total there are 6 users online :: 5 Registered, 0 Hidden and 1 Guest [ Administrator ] [ Who is Online ]
Most users ever online was 6 on Fri Jul 22, 2005 7:31 pm

When I visited 2 minutes later at 7:33pm :

In total there are 3 users online :: 3 Registered, 0 Hidden and 0 Guest [ Administrator ] [ Who is Online ]
Most users ever online was 3 on Fri Jul 22, 2005 7:33 pm

You can check out what I'm talking about here: http://www.unknownsoldiers.org/barracks

Now I noticed that the date my board created was incorrect, and I had to manually add the date it was created in the sql db to get it to function correctly, could this be the problem? Mabye where it's looking for to find store the highest number of users online and it's date and time is missing and updates nothing in the DB?

Does anyone know where this table is? Or what I have to add to get it to work?

Any help would be apriciated..

- Tom

Posted: Fri Jul 22, 2005 3:57 pm
by fumbalah
Do you have any modifications installed?

Posted: Fri Jul 22, 2005 4:05 pm
by tomlarose
I do, however nothing that would affect this.. and this has been going on before any mods were installed.

Posted: Fri Dec 16, 2005 8:06 pm
by tomlarose
bump

Posted: Fri Dec 16, 2005 8:25 pm
by sikhism
just curious...at the bottom of your site is says "powered by the unknown soldiersphp"

who is unknown soldiersphp?

Posted: Fri Dec 16, 2005 8:43 pm
by tomlarose
Didn't even notice that.

Looks like one of my admins thought it would be cute to slap his name (Dread) at the bottom. Looks like he changed a the powered by phpbb thing too.

Anyhow, any insight on how to fix my problem?

Posted: Fri Dec 16, 2005 8:55 pm
by Marshalrusty
Please change that from "Powered by the unknown soldiersphpBB" to "Powered by phpBB" as per the rules. I will then be happy to help you.
The Board-wide Policies wrote: Members are requested to retain the full copyright as shown on the default subSilver template. If for good reason this message cannot be displayed we request at least the "Powered by phpBB" be retained with phpBB linked to www.phpbb.com... said message should be plainly visible and not hidden in the background colour, and so forth. Members who remove this message will receive no support here.

Posted: Sat Dec 17, 2005 5:54 pm
by tomlarose
Okay, it's fixed. I do apoligize I wasn't aware.

Thanks in advance for the help. :wink:

Posted: Sat Dec 17, 2005 7:11 pm
by Lumpy Burgertushie
you have a couple of MODs installed that might be causing it.

rename your viewonline.php file and upload a good fresh copy from the phpbb zip file. it that works and nothing else is broken, leave it. If it works and your donor MOD or anything else is broke, then figure out what part of that file has been MODed and redo the MODs to it.
If it doesn't fix it then go back to your original copy and we will try something else.

robert

Posted: Sat Dec 17, 2005 7:25 pm
by killerid
Check ur language/lang_english/lang_main.php file for this line :

$lang['Record_online_users'] = 'Most users ever online was <b>%s</b> on %s'; // first %s = number of users, second %s is the date.


If its not found ad it at around line : 142

Hoping that fixes it. But i fail to recall exactly which file it uses in includes i think. Maybe someone can throw more light.

Posted: Sat Dec 17, 2005 8:42 pm
by tomlarose
Well I tried replacing viewonline.php and that didn't work.

I also checked to see if that line was in lang_main.php and it was, and it was correct.


Stil didn't work.

:?

Posted: Sat Dec 17, 2005 9:12 pm
by Andrew Kucienski
If you open the phpbb_config table in mySQL and browse to record_online_users, what value do you see?

Posted: Sat Dec 17, 2005 9:31 pm
by tomlarose
Andrew Kucienski wrote: If you open the phpbb_config table in mySQL and browse to record_online_users, what value do you see?


That did the trick :P I was missing those entries.

Thanks a million! :D :D

Posted: Sat Dec 17, 2005 9:39 pm
by Andrew Kucienski
tomlarose wrote: That did the trick :P I was missing those entries.


I'm glad it worked, but I would be concerned that this was missing (maybe there is more).

Check here to see if you are missing anything else.