Error importing backup file

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
lessur
Registered User
Posts: 132
Joined: Mon Jun 27, 2005 5:19 pm

Error importing backup file

Post by lessur » Sun Jul 24, 2005 5:47 pm

Ok, I need to do this now:

Ii need to change the mysql version that phpbb thinks my database is, when I installed I ly put 3x when it was 4x, how can I change this?

My database version is 4.0.25, thats 4x right?
Last edited by lessur on Sun Jul 24, 2005 9:05 pm, edited 1 time in total.

fumbalah
Registered User
Posts: 2000
Joined: Sat Jan 24, 2004 3:02 pm
Location: Lexington, Kentucky
Contact:

Post by fumbalah » Sun Jul 24, 2005 6:56 pm

Are you trying to restore this via phpmyadmin or the phpBB restore tool?. How big is the database backup?

tunafish
Registered User
Posts: 152
Joined: Sat Jul 23, 2005 1:29 pm

Post by tunafish » Sun Jul 24, 2005 7:15 pm

he looks like he is using the phpbb db restore, try using phpmyadmin to restore it
phpBB Problems? PM ME :)

User avatar
MHobbit
Former Team Member
Posts: 4761
Joined: Thu Mar 18, 2004 5:32 pm
Location: There and Back Again

Re: Error importing backup file

Post by MHobbit » Sun Jul 24, 2005 8:22 pm

lessur wrote: [ EDIT: I think i need to change the mysql version that phpbb thinks my database is, it thinks its 3x , but my database version is 4.0.25 , how can I change this? ]


I'm not sure if this would fix it, but here:

In config.php, find "mysql" and replace it with "mysql4".

Also, instead of using phpBB's built-in database import tool, you can try the following articles:

http://www.phpbb.com/kb/article.php?article_id=266
http://www.phpbb.com/kb/article.php?article_id=264
http://www.phpbb.com/kb/article.php?article_id=140
http://www.phpbb.com/kb/article.php?article_id=59
Former phpBB MOD Team member
No private support is offered.
"There’s too many things to get done, and I’m running out of days..."

lessur
Registered User
Posts: 132
Joined: Mon Jun 27, 2005 5:19 pm

Post by lessur » Sun Jul 24, 2005 9:05 pm

Ok, I need to do this now:

Ii need to change the mysql version that phpbb thinks my database is, when I installed I ly put 3x when it was 4x, how can I change this?

My database version is 4.0.25, thats 4x right?

User avatar
MHobbit
Former Team Member
Posts: 4761
Joined: Thu Mar 18, 2004 5:32 pm
Location: There and Back Again

Post by MHobbit » Sun Jul 24, 2005 9:07 pm

lessur wrote: Ok, I need to do this now:

Ii need to change the mysql version that phpbb thinks my database is, when I installed I ly put 3x when it was 4x, how can I change this?

My database version is 4.0.25, thats 4x right?

MennoniteHobbit wrote: I'm not sure if this would fix it, but here:

In config.php, find "mysql" and replace it with "mysql4".
Former phpBB MOD Team member
No private support is offered.
"There’s too many things to get done, and I’m running out of days..."

lessur
Registered User
Posts: 132
Joined: Mon Jun 27, 2005 5:19 pm

Post by lessur » Sun Jul 24, 2005 9:10 pm

uh....
// phpBB 2.x auto-generated config file
// Do not change anything in this file!

geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Post by geocator » Sun Jul 24, 2005 9:48 pm

And your point. You are being told by someone who knows that you should change it.

Locked

Return to “2.0.x Support Forum”