PHPBB2 sql data switch from mysql localhost to mysql webhost

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
PHPMagic
Registered User
Posts: 42
Joined: Mon Jul 18, 2005 5:29 pm
Contact:

PHPBB2 sql data switch from mysql localhost to mysql webhost

Post by PHPMagic » Sun Jul 24, 2005 5:51 pm

URL: localhost
Template(s) used: subSilver (customized)
Any and all MODs: flash chat v1
Do you use a port of phpBB: ?
Version of phpBB: 2.0
Version of PHP: 5 on localhost 4 on web host
Which database server and version: mysql 4
Host: localhost to online godaddy.com account
Did someone install this for you/who: no
Is this an upgrade/from what to what: no
Is this a conversion/from what to what: no
Have you searched for your problem: no
If so, what terms did you try: none
State the nature of your problem: Read below
Do you have a test account for us: no


I have my PHPbb2 set up on my localhost and I wanted to switch it to my web host account. I created the mysql database (with different name) on my godaddy.com account. I went into my localhost phpmyadmin and exported the sql for the phpbb2. I chose 'gzip' and 'save to file', and also selected all the tables. I then went into the phpmyadmin for my godaddy.com mysql account and browsed for the now unzipped phpbb2.sql file. When I located it and pressed 'next' I get an error.
Is there something I need to do or select on the export to get it to work on my web host account?

fumbalah
Registered User
Posts: 2000
Joined: Sat Jan 24, 2004 3:02 pm
Location: Lexington, Kentucky
Contact:

Post by fumbalah » Sun Jul 24, 2005 6:59 pm

What is the error you get?

PHPMagic
Registered User
Posts: 42
Joined: Mon Jul 18, 2005 5:29 pm
Contact:

Post by PHPMagic » Mon Jul 25, 2005 12:24 am

Error

SQL-query :

CREATE TABLE IF NOT EXISTS `phpbb_auth_access` (

`group_id` mediumint( 8 ) NOT NULL default '0',
`forum_id` smallint( 5 ) unsigned NOT NULL default '0',
`auth_view` tinyint( 1 ) NOT NULL default '0',
`auth_read` tinyint( 1 ) NOT NULL default '0',
`auth_post` tinyint( 1 ) NOT NULL default '0',
`auth_reply` tinyint( 1 ) NOT NULL default '0',
`auth_edit` tinyint( 1 ) NOT NULL default '0',
`auth_delete` tinyint( 1 ) NOT NULL default '0',
`auth_sticky` tinyint( 1 ) NOT NULL default '0',
`auth_announce` tinyint( 1 ) NOT NULL default '0',
`auth_vote` tinyint( 1 ) NOT NULL default '0',
`auth_pollcreate` tinyint( 1 ) NOT NULL default '0',
`auth_attachments` tinyint( 1 ) NOT NULL default '0',
`auth_mod` tinyint( 1 ) NOT NULL default '0',
KEY `group_id` ( `group_id` ) ,
KEY `forum_id` ( `forum_id` )
)ENGINE = MYISAM DEFAULTCHARSET = utf8

MySQL said:


You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8' at line 18

Back

geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Post by geocator » Mon Jul 25, 2005 2:49 am

Edit your backup in a text editor and remove every occurence of DEFAULTCHARSET = utf8

Locked

Return to “2.0.x Support Forum”