Forum Crashed [EDIT: Forum Up, Members/Threads/Posts gone!]

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
MFM
Registered User
Posts: 32
Joined: Tue Feb 01, 2005 4:38 am

Forum Crashed [EDIT: Forum Up, Members/Threads/Posts gone!]

Post by MFM » Fri Jul 29, 2005 4:58 am

Forums Crashed -- what do I do.

Hey guys, my forum has crashed, it seems that the MySQL database was deleated, and I tried installing the forums again and just uploading the back-up file but it would work, I keep getting the same error page --
phpBB : Critical Error

Error creating new session

DEBUG MODE

SQL Error : 1054 Unknown column 'session_admin' in 'field list'

INSERT INTO phpbb_sessions (session_id, session_user_id, session_start, session_time, session_ip, session_page, session_logged_in, session_admin) VALUES ('f9c196a0f324aecbe08a8bdf7c557e31', 2, 1122612478, 1122612478, '46708a66', 0, 1, 0)

Line : 172
File : sessions.php


can anyone help me?

Thanks,
Last edited by MFM on Sat Jul 30, 2005 12:00 am, edited 1 time in total.
/// Matt
Msquared-Designs.com
matt@msquared-designs.com

User avatar
Anon
Former Team Member
Posts: 7019
Joined: Fri Jan 02, 2004 7:33 am
Location: Christchurch, New Zealand

Post by Anon » Fri Jul 29, 2005 5:23 am

You've done an update lately?

If so, download the full pack, and unzip it. Upload the install/ and contrib/ directories only, and run www.yoursite.tld/phpBB2/install/update_to_latest.php

Then delete the install/ and contrib/ folders

cybrid23
Former Team Member
Posts: 9877
Joined: Wed Jun 29, 2005 5:55 am
Location: Somewhere in the Midwest...
Contact:

Post by cybrid23 » Fri Jul 29, 2005 5:23 am

Upload the install folder from the full version 2.0.17

POint your browser to:

http://www.yoursite.com/install/update_to_latest.php

Delete teh install folder

***Note: Replace yoursite.com and forum with your stuff
---Never leave home without a towel and your peril sensitive sunglasses.
---Do Not PM Me For Support. It will go unanswered.
Thanks.

geocator
Registered User
Posts: 16242
Joined: Fri Jan 09, 2004 11:56 pm
Location: On dry land
Contact:

Post by geocator » Fri Jul 29, 2005 5:24 am

You need to upload and run install/update_to_latest.php

MFM
Registered User
Posts: 32
Joined: Tue Feb 01, 2005 4:38 am

Post by MFM » Sat Jul 30, 2005 12:02 am

NEW:

Ok guys I got the forums back up, but now something really wierdo is going on. It seems that everything is fine, except the fact that all the members are gone. Not only that, something really wierd is going on. It seems when you go to the forum index, it says we have all the threads and posts still there, yet when you click on a forum -- it says no posts in the forum.

http://www.magicformagicians.info/forums

If you could help, it would be GREATLY Appreciated.

Thanks,
/// Matt
Msquared-Designs.com
matt@msquared-designs.com

StefanL
Registered User
Posts: 2265
Joined: Wed Jul 23, 2003 10:10 pm

Post by StefanL » Sat Jul 30, 2005 12:07 am

Your theme isn’t uploaded. Use the toolkit in my sign to restore it to subSilver.
When I suggest that you should alter your files, BACKUP them BEFORE.

StefanL
Registered User
Posts: 2265
Joined: Wed Jul 23, 2003 10:10 pm

Post by StefanL » Sat Jul 30, 2005 12:23 am

Your next problem:

You didn’t a complete restore, or your backup is corrupt.
When I suggest that you should alter your files, BACKUP them BEFORE.

MFM
Registered User
Posts: 32
Joined: Tue Feb 01, 2005 4:38 am

Post by MFM » Sat Jul 30, 2005 12:25 am

Hey Man,

My backup is currupt? How do I fix that?

Thanks,
/// Matt
Msquared-Designs.com
matt@msquared-designs.com

StefanL
Registered User
Posts: 2265
Joined: Wed Jul 23, 2003 10:10 pm

Post by StefanL » Sat Jul 30, 2005 12:31 am

Search for all these in your backup:

Code: Select all

phpbb_auth_access
phpbb_banlist
phpbb_categories
phpbb_config
phpbb_confirm
phpbb_disallow
phpbb_forum_prune
phpbb_forums
phpbb_groups
phpbb_posts
phpbb_posts_text
phpbb_privmsgs
phpbb_privmsgs_text
phpbb_ranks
phpbb_search_results
phpbb_search_wordlist
phpbb_search_wordmatch
phpbb_sessions
phpbb_smilies
phpbb_themes
phpbb_themes_name
phpbb_topics
phpbb_topics_watch
phpbb_user_group
phpbb_users
phpbb_vote_desc
phpbb_vote_results
phpbb_vote_voters
phpbb_words
The prefix ‘phpbb’ could be something else in your backup. If you got them, your backup is probably correct. Report back.
When I suggest that you should alter your files, BACKUP them BEFORE.

MFM
Registered User
Posts: 32
Joined: Tue Feb 01, 2005 4:38 am

Post by MFM » Sat Jul 30, 2005 12:38 am

Hi,

I am pretty sure I have all of those in my back up, although I did not read through it really, it is hard to read through. It's a bunch of clutter.

But I think I have all of those, any other ideas of why the users/threads/posts are not there anymore?

Thanks,
/// Matt
Msquared-Designs.com
matt@msquared-designs.com

MFM
Registered User
Posts: 32
Joined: Tue Feb 01, 2005 4:38 am

Post by MFM » Sat Jul 30, 2005 12:54 am

Code: Select all

phpbb_confirm ----- NO

phpbb_smilies ------- NO

phpbb_topics ------ NO
phpbb_topics_watch ------NO
phpbb_user_group ------ NO
phpbb_users ------ NO
phpbb_vote_desc ------- NO
phpbb_vote_results ------- NO
phpbb_vote_voters ------ No
phpbb_words------NO
Update, I guess I don't have a lot of them, the above are the one's I don't have.

What can I do?

Thanks,
/// Matt
Msquared-Designs.com
matt@msquared-designs.com

StefanL
Registered User
Posts: 2265
Joined: Wed Jul 23, 2003 10:10 pm

Post by StefanL » Sat Jul 30, 2005 1:09 am

Do you have an older backup?
When I suggest that you should alter your files, BACKUP them BEFORE.

MFM
Registered User
Posts: 32
Joined: Tue Feb 01, 2005 4:38 am

Post by MFM » Sat Jul 30, 2005 1:10 am

I do, but I looked at that as well, and it has the same problem. it doesn't have the last couple of tables.

Is it hopless?

Thanks,
/// Matt
Msquared-Designs.com
matt@msquared-designs.com

StefanL
Registered User
Posts: 2265
Joined: Wed Jul 23, 2003 10:10 pm

Post by StefanL » Sat Jul 30, 2005 1:15 am

It doesn’t look good. Can you upload a backup to your site and PM me the URL?
When I suggest that you should alter your files, BACKUP them BEFORE.

StefanL
Registered User
Posts: 2265
Joined: Wed Jul 23, 2003 10:10 pm

Post by StefanL » Sat Jul 30, 2005 1:42 am

I have looked on you backup, and sorry to say, it’s corrupt. Here is where everything goes wrong:

Code: Select all

 #
# Table Data for phpbb_themes
#

INSERT INTO phpbb_themes (themes_id, template_name, style_name, head_stylesheet, body_background, body_bgcolor, body_text, body_link, body_vlink, body_alink, body_hlink, tr_color1, tr_color2, tr_color3, tr_class1, tr_class2, tr_class3, th_color1, th_color2, th_color3, th_class1, th_class2, th_class3, td_color1, td_color2, td_color3, td_class1, td_class2, td_class3, fontface1, fontface2, fontface3, fontsize1, fontsize2, fontsize3, fontcolor1, fontcolor2, fontcolor3, span_class1, span_class2, span_class3, img_size_poll, img_size_privmsg, fontcolor5, fontcolor6) VALUES('9', 'NoseBleed', 'NoseBleed', 'NoseBleed.css', '', 'FFFFFF', '111111', '9F0002', '9F0002', '9F0002', '9F0002', 'F3F3F3', 'EBEBEB', 'E3E3E3', '', '', '', '111111', '111111', 'FFFFFF', '', '', '', 'FAFAFA', 'FFFFFF', '000000', 'row1', 'row2', 'row3', 'Verdana, Arial, Helvetica, sans-serif', 'Verdana, Arial, Helvetica, sans-serif', 'Verdana, Arial, Helvetica, sans-serif', '10', '11', '12', '111111', '668400', 'A76100', '', '', '', '0', '0', NULL, NULL);
INSERT INTO phpbb_themes (themes_id, template_name, style_name, head_stylesheet, body_background, body_bgcolor, body_text, body_link, body_vlink, body_alink, body_hlink, tr_color1, tr_color2, tr_color3, tr_class1, tr_class2, tr_class3, th_color1, th_color2, th_color3, th_class1, th_class2, th_class3, td_color1, td_color2, td_color3, td_class1, td_class2, td_class3, fontface1, fontface2, fontface3, fontsize1, fontsize2, fontsize3, fontcolor1, fontcolor2, fontcolor3, span_class1, span_class2, span_class3, img_size_poll, img_size_privmsg, fontcolor5, fontcolor6) VALUES('12', 'BBTech', 'BBTech', 'BBTech.css', '', '1E1E2A', 'e4e4e4', 'e4e4e4', 'e4e4e4', 'e4e4e4', 'EFC70A', '1E1E2A', '1E1E2A', '1E1E2A', '', '', '', '1E1E2A', '1E1E2A', '1E1E2A', 'cellpic1.gif', 'cellpic3.gif', 'cellpic2.jpg', '1E1E2A', '1E1E2A', '', 'row1', 'row2', '', 'Verdana, Arial, Helvetica, sans-serif', 'Trebuchet MS', 'Courier, \'Courier New\', sans-serif', '11', '11', '12', '444444', 'F8D61A', '5B5B73', '', '', '', '0', '0', NULL, NULL);
#
# TABLE: phpbb_themes_name
#

<------------------------------- HERE!!!!!! ----------------------------->

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"  />
<style type="text/css">
<!--
/*
  The original NoseBleed Theme for phpBB version 2+
  Created by Mike Lothar
  http://www.mikelothar.com

  NOTE: These CSS definitions are stored within the main page body so that you can use the phpBB2
  theme administration centre. When you have finalised your style you could cut the final CSS code
  and place it in an external file, deleting this section to save bandwidth.
*/
When I suggest that you should alter your files, BACKUP them BEFORE.

Locked

Return to “2.0.x Support Forum”