Page 1 of 1

Registration Problem with smtp.php

Posted: Wed Aug 17, 2005 7:29 pm
by JooK
well, I checked my settings, tried differen logins, emails, etc.
I set the registration in to Admin confirmation.


Code: Select all

Ran into problems sending Mail. Response: 502 unimplemented (#5.5.1) 

DEBUG MODE

Line : 125
File : smtp.php 
That's the error I get,
any clue as what I should do?

Posted: Wed Aug 17, 2005 7:40 pm
by Marshalrusty
Take a look at this topic. Pay special attention to geocator's post.

Posted: Wed Aug 17, 2005 8:04 pm
by JooK
that seemed to do a lot, but now i get the follwing error:

Code: Select all

No email Subject specified

DEBUG MODE

Line : 128
File : smtp.php 

The line mentioned in the code above is the following:

Code: Select all

message_die(GENERAL_ERROR, "No email Subject specified", "", __LINE__, __FILE__);

ideas?

Posted: Wed Aug 17, 2005 8:15 pm
by geocator

Posted: Thu Aug 18, 2005 12:44 am
by JooK
URL: www.sporka.com/forum/
Template(s) used: default
Any and all MODs: None
Do you use a port of phpBB: not sure, don't think so, standard installation
Version of phpBB: Newest
Version of PHP: 4.3.10
Which database server and version: MYSQL 4.0.18
Host: iPowerweb.com
Did someone install this for you/who: No, I installed this myself.
Is this an upgrade/from what to what: Fresh install.
Is this a conversion/from what to what: No conversion.
Have you searched for your problem: Yes.
If so, what terms did you try: smtp.php
State the nature of your problem: Unresolved.
Do you have a test account for us: I would, but only the admin account works, I am currently unable to register new accounts.

Posted: Thu Aug 18, 2005 2:54 am
by geocator
And did you modify the code acording to that other post?

Posted: Thu Aug 18, 2005 3:02 am
by JooK
I did, but now it gives me that other error, about the no subject.
Appearantly, there is no subject in the e-mail.
I don't even know what sends the message, what the context of it is or anything. I am assuming there is a default message set by the phpBB team within the email, and that the code above just fixates the way it is sent, however, it still doesn't seem to be working. Any other suggestions?

Posted: Thu Aug 18, 2005 5:14 am
by JooK
Nobody has ANY other suggestions at all?
Should I paste all of the lines or something?

Posted: Fri Aug 19, 2005 2:13 am
by JooK
Shameful bump.


I thought perhaps the versions I was using are getting in the way. I am using the newest version from everything, is there anything I should downgrade you think?


now the error I get gives me this:

Code: Select all

Ran into problems sending Mail. Response: 502 unimplemented (#5.5.1) 

DEBUG MODE

Line : 144
File : smtp.php

the line mentioned is this one, in smtp.php:

Code: Select all

		server_parse($socket, "334", __LINE__);

PS, here is the line that I added to smtp, maybe you can scan it for problems:

Code: Select all

function smtpmail($mail_to, $subject, $message, $headers = 'Reg Request') 
{ 
$mail = new PHPMailer(); 
$mail->IsSMTP();// set mailer to use SMTP 
$mail->Host = "mail.sporka.com"; // specify main and backup server 
$mail->SMTPAuth = true; // turn on SMTP authentication 
$mail->Username = "sporkaco@sporka.com"; // SMTP username 
$mail->Password = "******"; // SMTP password 

$mail->From = "sporkaco@sporka.com"; 
$mail->FromName = "Da Spawt"; 
$mail->AddAddress("$mail_to");// Do not touch this line  
$mail->AddReplyTo("sporkaco@sporka.com", "n"); 

$mail->WordWrap = 50;// set word wrap to 50 characters 
$mail->IsHTML(true);// set email format to HTML 
$xmessage = str_replace("\n","<br />",$message);// Make sure newlines get turned into real newlines  
$mail->Subject = "rEG rEQ"; 
$mail->Body = "This guy requested a forum reg."; 
$mail->AltBody = "yeah"; 

if(!$mail->Send()) 
{ 
echo "Message could not be sent. <p>"; 
echo "Mailer Error: " . $mail->ErrorInfo; 
exit; 
} 
return TRUE; 
}