Group Permissions

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Registered User
Posts: 3
Joined: Wed Aug 17, 2005 7:59 pm

Group Permissions

Post by aleron »

I've got a bunch of boards set up, along with users and groups (and users belonging to groups), and I want to restrict certain boards to certain groups. Reading the userguide I need to edit the groups permissions. However, when I edit a groups permissions, the middle column, the 'Simple Permissions' column, contains no way for me to edit the permissions for the different forums. It's blank!. The drop-down boxes for setting moderator status are there, but thats it. Is there something I have done or haven't done that would cause this? The table looks exactly like this, without any drop-down boxes at all in the middle column. Your help is greatly appreciated!

phpBB Version: 2.0.11
User avatar
Registered User
Posts: 376
Joined: Fri Dec 05, 2003 2:42 pm

Post by Tallaroo9 »

First, please upgrade your version of phpBB. Second, you need to set the forums (in ACP, Forum Permissions) to private (or private [hidden]). Then when you go into group permissions you will see the drop down box offering to allow that group to see that forum.
Having problems restoring your database or changing forum hosts? <(Read this)>
Trouble logging in? Try the <(Auto Cookies Mod)> or <(Manual Cookie Setting Fix)>
Getting a blank page when you search?<(Read this)>
Registered User
Posts: 463
Joined: Mon Jul 25, 2005 1:34 am

Post by gmex2006 »

As Tallaroo9 stated, you should imperatively update your forum to the latest version of phpbb (2.0.17). Please follow this link for more information about the updating process.

For your forum permissions, please read the Forum Permissions Guide found in the phpbb extensive User Guide.

Thank you

Return to “2.0.x Support Forum”