New Install But want the old database... Help Please!

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
eq4bits
Registered User
Posts: 49
Joined: Fri Jan 21, 2005 3:01 pm

New Install But want the old database... Help Please!

Post by eq4bits » Sat Aug 20, 2005 12:28 am

I tried searching but couldn't find anything that quite fit my situation.
so here goes:

Have been running phpbb 2.0.11 since January, then upgraded to 2.0.13 a in March I think it was. Anywho... was getting ready to upgrade to 2.0.17 (hadn't done ANYTHING yet) and suddenly started getting critical errors (critical error could not connect to database) when I tried going to the mydomain.org/forum/phpBB2/index.php (white screen with the error message) went to myPHP and the d/b ( myname_forum) was there so.... went back to my admin cp and made a backup just to be on the safe side.

since i was going to upgrade anyway and the board was heavily moded, i figured it would be easier to do a fresh install making the new path: mydomain.org/phpBB2/ ; created a new d/b called myname_forum1 now
how do i get the new install to use the 'old' d/b (myname_forum)? Is this possible?

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29252
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty » Sat Aug 20, 2005 12:33 am

Edit the config.php file. Make it use the old database. Make sure to run install/update_to_latest.php
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

ScionCrow
Registered User
Posts: 3621
Joined: Fri Feb 13, 2004 6:59 am
Location: Darkness

Post by ScionCrow » Sat Aug 20, 2005 12:34 am

Although, it might not be your config.php file as it is said by you.. that you haven't changed it at all. Contact your host if they are having a little problem with their server.
No longer supporting phpBB. PM or email me regarding support and you will be ignored. I'm fully done with phpBB and everything.

eq4bits
Registered User
Posts: 49
Joined: Fri Jan 21, 2005 3:01 pm

Post by eq4bits » Sat Aug 20, 2005 12:53 am

Marshalrusty wrote: Edit the config.php file. Make it use the old database.


edit the config.php at the 'new' location (mydomain.org/phpBB2) where ver. 2.0.17 is?
Marshalrusty wrote: Make sure to run install/update_to_latest.php


at my 'old' forum files location or the 'new' one?
ScionCrow wrote: Although, it might not be your config.php file as it is said by you.. that you haven't changed it at all. Contact your host if they are having a little problem with their server.


I can access all the pages at the site HERE and can access my admin cp at DirectAdmin and the d/b cp at phpMyAdmin 2.5.0 (MySQL 4.0.14) all running (as far as I know on the same host/server)

for some reason ( I guess it was a server thing) the original is back and working properly (so far at least) but since I really should switch to the newest phpbb version and the old one is HEAVILY mod'ed (and i think some of the things the mods added were included in the more recent versions of phpbb...) wouldn't it be easier to just do the config.php editing Marshalrusty suggested?

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29252
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty » Sat Aug 20, 2005 12:58 am

At the new location, make the config.php point to the old database. When you do this successfully, you will likely get the sessions error. Run install/update_to_latest to update the database to the latest version. After that, run the Auto Cookies MOD to fix the cookie settings. Then you should be up and running.
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

ScionCrow
Registered User
Posts: 3621
Joined: Fri Feb 13, 2004 6:59 am
Location: Darkness

Post by ScionCrow » Sat Aug 20, 2005 12:59 am

If you'd like to start clean with no MODs, just download the full package here, run the install/update_to_latest.php file included, and make sure to replace all the files EXCEPT config.php. It'll be easier and a bit of less work for you.
No longer supporting phpBB. PM or email me regarding support and you will be ignored. I'm fully done with phpBB and everything.

eq4bits
Registered User
Posts: 49
Joined: Fri Jan 21, 2005 3:01 pm

Post by eq4bits » Sat Aug 20, 2005 1:17 am

i really hate to be such a PITA but are you saying to download the full package, then ftp everything BUT the 'new' config.php file to the 'old'(mydomain.org/forum/phpBB2/) location (overwriting all the 'old' version files)? THEN run mydomain.org/forum/phpBB2/install/update_to_latest.php file, then delete the install and contrib files?
I'm really confused now.... :oops:

ScionCrow
Registered User
Posts: 3621
Joined: Fri Feb 13, 2004 6:59 am
Location: Darkness

Post by ScionCrow » Sat Aug 20, 2005 1:20 am

Either way you go about it works.. either by me or Marshalrusty. It's up to you.

But, in a sense, that is what I mean. If you do have tables in the Database, they shouldn't be much of a problem if you replace all the files with stock phpBB ones.
No longer supporting phpBB. PM or email me regarding support and you will be ignored. I'm fully done with phpBB and everything.

eq4bits
Registered User
Posts: 49
Joined: Fri Jan 21, 2005 3:01 pm

Post by eq4bits » Sat Aug 20, 2005 1:24 am

thanks, will try it
just didn't want to wipe out my 'old' d/b and all it contains

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29252
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty » Sat Aug 20, 2005 1:26 am

eq4bits wrote: thanks, will try it
just didn't want to wipe out my 'old' d/b and all it contains


Make sure you backup before you attempt anything.
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

eq4bits
Registered User
Posts: 49
Joined: Fri Jan 21, 2005 3:01 pm

Post by eq4bits » Sat Aug 20, 2005 3:18 am

Oh my I really am a pain aren't I?

what i did:

using the 'new' install edited the config.php to point to the 'old' d/b;
ran *mydomain.org/forum/install/update_to_latest.php*
but now i'm getting
phpBB : Critical Error

Could not open DSW2 template config file

DEBUG MODE

Line : 361
File : functions.php

when i try to go to *mydomain.org/forum/phpBB2/index.php*

I realize the error is saying that its looking for the cfg file for the DSW2 template (the heavily mod'ed and individualized for our site), so now what file do I change in the 'new' install to point to the subSilver.cfg located in the new install files?

The 'old' phpbb forum is running/working fine since the update, I thought maybe if i went into the old ones admincp and unchecked the override user style it would make the new forum 'work', alas.... it didn't... i still get the error quoted above.....

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29252
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty » Sat Aug 20, 2005 3:28 am

Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

Locked

Return to “2.0.x Support Forum”