Weird error... help?

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
thebassman
Registered User
Posts: 103
Joined: Fri Mar 26, 2004 2:00 am
Location: Toronto, Ontario, Canada

Weird error... help?

Post by thebassman » Sat Aug 20, 2005 5:12 am

my forum members (and myself) are getting the following error when trying to post to a specific topic.... people can post to other topics fine, though.

Code: Select all

Could not insert new word matches

DEBUG MODE

SQL Error : 1016 Can't open file: 'phpbb_search_wordmatch.MYI'. (errno: 145)

INSERT INTO phpbb_search_wordmatch (post_id, word_id, title_match) SELECT 126601, word_id, 0 FROM phpbb_search_wordlist WHERE word_text IN ('test')

Line : 251
File : functions_search.php
Any ideas?

User avatar
AdamR
Former Team Member
Posts: 9731
Joined: Tue Mar 02, 2004 5:40 pm
Location: Tampa, Florida
Name: Adam Reyher
Contact:

Post by AdamR » Sat Aug 20, 2005 5:14 am

If you have access to phpMyAdmin, try running the following query on the database:

Code: Select all

REPAIR TABLE phpbb_search_wordmatch;
If you need help with running queries in phpMyAdmin, here is a great tutorial on it:
http://www.phpbb.com/kb/article.php?article_id=151

If you don't have access to phpMyAdmin, paste that code into a text file and save it on your computer.

Then, login to your forum, go to Admin Panel > General Admin > Restore Database

Browse to the location where you saved the file, and restore it.

- Adam
phpBB Support: Welcome | Userguide | Knowledge Base | Search
Honored supporter of the phpBB Group!
"If I have seen a little further it is by standing on the shoulders of Giants." - Isaac Newton

thebassman
Registered User
Posts: 103
Joined: Fri Mar 26, 2004 2:00 am
Location: Toronto, Ontario, Canada

Post by thebassman » Sat Aug 20, 2005 5:21 am

I won't lose any info doing that, will I?

User avatar
AdamR
Former Team Member
Posts: 9731
Joined: Tue Mar 02, 2004 5:40 pm
Location: Tampa, Florida
Name: Adam Reyher
Contact:

Post by AdamR » Sat Aug 20, 2005 5:21 am

No. All data should be preserved. :)

- Adam
phpBB Support: Welcome | Userguide | Knowledge Base | Search
Honored supporter of the phpBB Group!
"If I have seen a little further it is by standing on the shoulders of Giants." - Isaac Newton

thebassman
Registered User
Posts: 103
Joined: Fri Mar 26, 2004 2:00 am
Location: Toronto, Ontario, Canada

Post by thebassman » Sat Aug 20, 2005 5:24 am

Thanks Adam! :D Worked like a charm. Now, just out of curiosity, why did that happen in the first place?

User avatar
AdamR
Former Team Member
Posts: 9731
Joined: Tue Mar 02, 2004 5:40 pm
Location: Tampa, Florida
Name: Adam Reyher
Contact:

Post by AdamR » Sat Aug 20, 2005 5:30 am

Error 145 means a corrupted table, or the like, and is in need of repair, which is what you did. This is almost impossible to prevent from happening as it can be caused by numerous things, from a query being interrupted while being executed or another "bump" in the server. If it only happens rarely, it's nothing to be worried about. However, if it becomes an often experience, there's probably something more serious behind it, in which case you should contact your hosting provider. Though, as I said, rarely is absolutly nothing to worry about. :)

- Adam
phpBB Support: Welcome | Userguide | Knowledge Base | Search
Honored supporter of the phpBB Group!
"If I have seen a little further it is by standing on the shoulders of Giants." - Isaac Newton

thebassman
Registered User
Posts: 103
Joined: Fri Mar 26, 2004 2:00 am
Location: Toronto, Ontario, Canada

Post by thebassman » Sat Aug 20, 2005 5:31 am

Cool... good to know. Thanks Adam. :)

Locked

Return to “2.0.x Support Forum”