emailer.php error

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
User avatar
SixthSphere
Registered User
Posts: 116
Joined: Fri Aug 08, 2003 4:32 pm

emailer.php error

Post by SixthSphere »

i'm having some users report this after upgrading to 2.0.17

Code: Select all

Failed sending email :: PHP :: 

DEBUG MODE 

Line : 234 
File : emailer.php
the only similarity between the users getting it is having "Always notify me of replies" checked on their accounts.

my board is extensively modded, yet the emailer.php on the server and a completely "stock" unedited emailer.php are identical (as reported by BBEdit, a mac text editor)

so anyways, after unchecking "Always notify me of replies" on these user's accounts, they have reported still receiving the error when sending PM's...

The pm's and posts go through even tho the user gets the error

so i'm wonering if i make this change in emailer.php:

BEFORE

Code: Select all

		// Did it work?
		if (!$result)
		{
			message_die(GENERAL_ERROR, 'Failed sending email :: ' . (($this->use_smtp) ? 'SMTP' : 'PHP') . ' :: ' . $result, '', __LINE__, __FILE__);
		}

		return true;
and change that to:

Code: Select all

		// Did it work?
		if (!$result)
		{
			message_die(GENERAL_ERROR, 'Failed sending email :: ' . (($this->use_smtp) ? 'SMTP' : 'PHP') . ' :: ' . $result, '', __LINE__, __FILE__);
		}

		return false;
will that return false statement make the error NOT display to users?
Are you a Saturn Car Enthusiast?
Check out www.SixthSphere.com!

User avatar
SixthSphere
Registered User
Posts: 116
Joined: Fri Aug 08, 2003 4:32 pm

Post by SixthSphere »

anybody? :(
Are you a Saturn Car Enthusiast?
Check out www.SixthSphere.com!

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29256
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty »

Take a look at this KB article
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

User avatar
SixthSphere
Registered User
Posts: 116
Joined: Fri Aug 08, 2003 4:32 pm

Post by SixthSphere »

thanks
Are you a Saturn Car Enthusiast?
Check out www.SixthSphere.com!

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29256
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty »

Welcome :wink:
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

Faylin
Registered User
Posts: 3
Joined: Tue Sep 20, 2005 12:52 am
Location: Baton Rouge, LA
Contact:

Post by Faylin »

I to am having this problem. I just recently switched and getting things set up. I am using phpBB 2.0.17. No mail function works with either php mail or smtp servers.
I know that the local phpmail function is activated on my hosts (yahoo small bussiness) server because my old board used it. I can not get this resolved.
technology is imposible to understand.

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29256
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty »

Faylin wrote: I to am having this problem. I just recently switched and getting things set up. I am using phpBB 2.0.17. No mail function works with either php mail or smtp servers.
I know that the local phpmail function is activated on my hosts (yahoo small bussiness) server because my old board used it. I can not get this resolved.

So it works on a board on the same server?
Have you disabled the SMTP mail feature in the Administration Panel?
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

smithtrdon
I've Been Banned!
Posts: 14
Joined: Tue Sep 13, 2005 12:46 am

SMTP Field

Post by smithtrdon »

hi, I don't understand what is doing failure my SMTP username and password.

  • 1.Use SMTP server for email:___________. (smithtr_@hotmail.com)

    2.SMTP Server Address:________________. (1.00.20.03.01)

    3.SMTP Server Username:_______________. (smithtr)

    4.SMTP Server Password:________________. (*******)
what do you did think so better than different to on forum?

Faylin
Registered User
Posts: 3
Joined: Tue Sep 20, 2005 12:52 am
Location: Baton Rouge, LA
Contact:

Post by Faylin »

Marshalrusty wrote: So it works on a board on the same server?
Have you disabled the SMTP mail feature in the Administration Panel?


I used Invision power board and the php mail function worked just fine with that board on the same server, host, etc. It just gives me errors on phpBB. smtp server is turned off.
technology is imposible to understand.

smithtrdon
I've Been Banned!
Posts: 14
Joined: Tue Sep 13, 2005 12:46 am

that is error code?

Post by smithtrdon »

Code: Select all


1.login_name.phpbb.stmp

2.password.phpbb.stmp
how find wrong on way find on error code language?
Maybe I thought not right not access or not perfect suggestion fight to fix new program and code language.


Code: Select all

[list=]To lock or unlock a topic, click the Lock Topic button or unlock topic button. I click the Lock Topic Button.[/list]
[/code]

Code: Select all

 click to lock the topic

ScionCrow
Registered User
Posts: 3621
Joined: Fri Feb 13, 2004 6:59 am
Location: Darkness

Post by ScionCrow »

smithrdon, post useful information. If you don't have any, don't post at all. If I see one more off-topic post from you, you should know what your getting in your inbox. (unless someone did already)

Faylin, sorry about the topic lock, you are more than welcome to create a new topic with your issue.

Lockified™
No longer supporting phpBB. PM or email me regarding support and you will be ignored. I'm fully done with phpBB and everything.

Locked

Return to “2.0.x Support Forum”