Page 1 of 1

Lost Access to Admin CP

Posted: Mon Oct 03, 2005 6:28 am
by RogueScribner

Template(s) used: SubSilver, Cobalt 2.0

Any and all MODs: COPPA MOD (13 or older), Active Members Only, Disallow Editing of Replied Posts, FAQ Admin, FAQ Edit, Hide Style Selection, mw3 (Prevent Any Layout from Being Broken), Prune User Posts, Today/Yesterday, View Topic Name While Posting, Disable Spambots

Do you use a port of phpBB: I have no idea what that means

Version of phpBB: 2.0.17

Version of PHP: 4.3.11

Which database server and version: Linux server running a MySQL 4.0.25 database


Did someone install this for you/who: No

Is this an upgrade/from what to what: Recently upgraded from 2.0.10 to 2.0.17

Is this a conversion/from what to what: n/a

Have you searched for your problem: Yes, but the search function was not working properly. I therefore skimmed the first ten pages of the support forum for anything mentioning "admin link" or "admin control panel."

If so, what terms did you try: See above

State the nature of your problem: I have full administrator rights at my forum, yet I cannot access the administrator control panel. I can move, delete, lock, and unlock topics at will, but only those functions I can access via the forum index pages. The link to the admin CP is no longer on the bottom of the page. I tried to access it directly through the address bar ( but I only get returned to the index page. I checked the MySQL database and I am ranked as an administrator. I also ran that Auto Cookie MOD but it did not help.

Do you have a test account for us: No

Any assistance anyone can provide me will be greatly appreciated.

Thank you.

Posted: Mon Oct 03, 2005 6:50 am
by RogueScribner
Okay, weird thing. If I log in and peruse the boards then I have the problem as described above.

However, if I log out and then attempt to access the Admin CP directly, it will prompt for me to log in and then prompt again to verify access. After that, I'm in! But there is still no link on the forum index pages and, as stated above, if I log-in normally and peruse the boards first, it'll just kick me back to the index if I try to access the Admin CP. Even if I navigate to the index from the Admin CP and try to navigate to it again (via link access, not going back with the back button), it'll kick me back to the index.

Any thoughts?

Posted: Mon Oct 03, 2005 6:55 am
by Lumpy Burgertushie
your settings for cookies etc. are wrong in the admin.

try this:
Auto Reset

Posted: Mon Oct 03, 2005 6:59 am
by RogueScribner
Yeah, I downloaded and ran that already, but I didn't see any weird values so I left the default values it displayed intact. What exactly should I look for?

Posted: Mon Oct 03, 2005 7:09 am
by Lumpy Burgertushie
RogueScribner wrote: Yeah, I downloaded and ran that already, but I didn't see any weird values so I left the default values it displayed intact. What exactly should I look for?

that is a common mistake that people make with that mod. the values that it shows you are not what you have but what you should have. so run it again, and then click the save button to write those settings to your database.

don't forget, after you do this, you MUST do this:

log out
clear cookies
clear cache/temp internet files
close browser

go back and test.


Posted: Mon Oct 03, 2005 7:38 am
by RogueScribner
I did everything as instructed and I still have the same problem. It's only possible for me to access the ACP if I only attempt to do so directly before logging in. Even after I gain access, the link does not appear on the index pages and if I try to jump forward to the ACP it will redirect me back to the main page.

If it's a cookie problem, I guess I'll try to play around with it some more. At least I know I can get to the ACP, even if it takes an extra step or two.


Posted: Mon Oct 03, 2005 5:35 pm
by RogueScribner
So no extra thoughts on this? Okay. I guess I'll just work around it until I figure something else out.

I wish I knew what could cause such an error, outside of cookies. At least then I could do my own little investigation and see what I find.


On a hunch, I uninstalled the picture resizing MOD since it used javascript. After the uninstall, I regained normal access to my ACP. So I guess I'll jump over to the MOD forum and see what else can be done to fix this.