smtp.php error, 535 authorization failed

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
mysticviper
Registered User
Posts: 8
Joined: Mon Oct 17, 2005 6:59 am

smtp.php error, 535 authorization failed

Post by mysticviper »

when trying to register i get this error...

Code: Select all

Ran into problems sending Mail. Response: 535 authorization failed (#5.7.0) 

DEBUG MODE

Line : 131
File : smtp.php
does anyone know what that means and how to fix it??

i have checked the username and password for the smtp and its correct...
mysticviper
Registered User
Posts: 8
Joined: Mon Oct 17, 2005 6:59 am

Post by mysticviper »

could someone please help me??
this is line 131

Code: Select all

server_parse($socket, "235", __LINE__);
so what could be wrong with it?
MarkTheDaemon
Former Team Member
Posts: 2770
Joined: Thu Oct 20, 2005 2:42 am
Location: United Kingdom
Name: Mark Barnes

Post by MarkTheDaemon »

If you are trying to send via the built in mail server you need requirements


If not check the smtp.myisp.com addess and also the username and password


Mark
mfest
Registered User
Posts: 18
Joined: Sat Mar 20, 2004 5:36 am
Location: New Jersey, USA
Contact:

Post by mfest »

I was watching this topic and having similar problems. Here's what fixed it for me.

I had set up a secondary email account with my hosting provider and tried to use it in my smtp settings on the board. It wouldn't work, I kept getting the 535 authentication error like you. I changed the smtp settings to use my main email account (the main address and password I use to log on to cpanel and all that other good stuff) and then it started working.

example:
smtp server address festzone.com
smtp user name mfest
password ******

Using a secondary email address on my server would not work, only the main one did.
Learning to fly is easy, just throw yourself at the ground and miss.
mysticviper
Registered User
Posts: 8
Joined: Mon Oct 17, 2005 6:59 am

Post by mysticviper »

im using yahoo for my email... (unless someone could help set it up to use gmail that would be awsome)
these are the setting
admin email address: viperxw@yahoo.com
smtp server address: smtp.mail.yahoo.com
smtp username: viperxw
smtp password: password

would your main email be the admin email??
MarkTheDaemon
Former Team Member
Posts: 2770
Joined: Thu Oct 20, 2005 2:42 am
Location: United Kingdom
Name: Mark Barnes

Post by MarkTheDaemon »

I would use your ISP smtp settings;

they usually keep the protocals default etc.



Mark
mysticviper
Registered User
Posts: 8
Joined: Mon Oct 17, 2005 6:59 am

Post by mysticviper »

how would i look up my ISP smtp setting?
MarkTheDaemon
Former Team Member
Posts: 2770
Joined: Thu Oct 20, 2005 2:42 am
Location: United Kingdom
Name: Mark Barnes

Post by MarkTheDaemon »

what isp do you use;


its usually smtp.myisp.com
user: whatever your internet username is
pass: whatever your internet pass is

mark
mysticviper
Registered User
Posts: 8
Joined: Mon Oct 17, 2005 6:59 am

Post by mysticviper »

r u talkin about my internet connection??? if so im using comcast... and i dont have any username or password for it...

im not understanding what your asking for... please put in something else beside smtp.myisp.com
MarkTheDaemon
Former Team Member
Posts: 2770
Joined: Thu Oct 20, 2005 2:42 am
Location: United Kingdom
Name: Mark Barnes

Post by MarkTheDaemon »

Your internet service provider;

if your supplier was http://www.virgin.net

smtp address ;smtp.virgin.net
username ;my.name
password ;***********
mysticviper
Registered User
Posts: 8
Joined: Mon Oct 17, 2005 6:59 am

Post by mysticviper »

so you saying to put in smtp.virgin.net (if thats my provider) even though im using a yahoo mail account???
MarkTheDaemon
Former Team Member
Posts: 2770
Joined: Thu Oct 20, 2005 2:42 am
Location: United Kingdom
Name: Mark Barnes

Post by MarkTheDaemon »

no no no

if you use yahoo you will have to find what port thay use and change it. I believe that yahoo don't use the standard smtp port, and so you need to change it to the port that they use

That is probably the cause of your problem


Mark
User avatar
cybermonsters
Registered User
Posts: 47
Joined: Sun Jan 19, 2003 5:34 am
Location: Seattle, WA

Post by cybermonsters »

I'm getting same errors. I did a test on a forum and received activations and PM's to an AOL account so figured it was ok, but now getting these error messages.

My forums are on a dedicated server and I'm using the same info that I use to access email via Outlook.

mail.domainname.net
emailaddress@domanname.net
password

This info is correct as far as what I use in outlook. Suggestions?
User avatar
CTCNetwork
Former Team Member
Posts: 15424
Joined: Fri Dec 19, 2003 3:50 am
Location: In that Volvo behind you!
Contact:

Post by CTCNetwork »

Hi,

The first thing to try when getting this error when using smtp mail is to use either the user name or the password, not both.

Hope ths helps,

Des. . . :wink:
Density:- Not just a measurement~Its a whole way of Life.! ! !
| Welcome! | RTFM!!! | Search! It's Easy! | Problem? | Spam? | Advice! |
User avatar
cybermonsters
Registered User
Posts: 47
Joined: Sun Jan 19, 2003 5:34 am
Location: Seattle, WA

Post by cybermonsters »

Hi,
Ok, tried that, still errors.

I guess what I'm not understanding is I have several forums, changed all to same smtp settings, but not all forums are having errors. Some are sending emails fine, some are not.

Is there somewhere else I'm supposed to set something?
Locked

Return to “2.0.x Support Forum”