Upgrade from 2.0.17 to 2.0.18

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29257
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty »

killerid wrote: Thanks but why is it not listed on the mods area ?

I asked that too.
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

ttyR2
Registered User
Posts: 88
Joined: Fri May 16, 2003 8:42 pm

Post by ttyR2 »

Where do I find the EasyMOD-specific patch file (the one EasyMOD can install) for 2.0.18?

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29257
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty »

Marshalrusty wrote: It can be found here
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

ttyR2
Registered User
Posts: 88
Joined: Fri May 16, 2003 8:42 pm

Post by ttyR2 »

When looking at the different update packages, I don't see anything that resembles what I used in the past (when .17 first came out). Yeah...so I forgot exactly what I was looking for.

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29257
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty »

Acyd Burn wrote: Code Changes
Contains step-by-step instructions in MOD format for updating heavily MODified installs
Download zip | Download tar.gz | Download tar.bz2
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

ttyR2
Registered User
Posts: 88
Joined: Fri May 16, 2003 8:42 pm

Post by ttyR2 »

Brother....sharp am I! Thanks dude.

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29257
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty »

Welcome :wink:
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

ttyR2
Registered User
Posts: 88
Joined: Fri May 16, 2003 8:42 pm

Post by ttyR2 »

I've modified the board somewhat and haven't ever had all the previous EasyMOD applied updates fail. This time on 2.0.18, I got:

Critical Error

FIND FAILED: In file [templates/subSilver/overall_header.tpl] could not find:

{L_FAQ}</a></span><span class="mainmenu">

MOD script line #2965 :: FAQ :: Report

Searching for the line doesn't turn up anything at all. I'm thinking I probably moved it to another spot. Among other things, I know I moved the memberlist to the admin CP, and may well have gotten rid of the FAQ fuction as well if that's what L_FAQ relates to. No...I didn't document all my changes at the time I made them :-)

Is it safe to just ignore the error?

ttyR2
Registered User
Posts: 88
Joined: Fri May 16, 2003 8:42 pm

Post by ttyR2 »

Oops...seems I didn't run the update_to_latest.php before installing the MOD. Bad news? I get "Please read: INSTALL.html before attempting to update." when trying to run the update_to_latest file after installing the MOD.

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29257
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty »

ttyR2 wrote: Oops...seems I didn't run the update_to_latest.php before installing the MOD. Bad news? I get "Please read: INSTALL.html before attempting to update." when trying to run the update_to_latest file after installing the MOD.

Make sure that you upload it to the install folder.
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

Taipo
Registered User
Posts: 174
Joined: Fri Jan 07, 2005 9:25 pm
Contact:

Post by Taipo »

Code: Select all

#################################################################
## MOD Title: phpBB 2.0.17 to phpBB 2.0.18 Code Changes
## MOD Author: markus_petrux < N/A > (Markus) N/A
## MOD Description: These are the Changes from phpBB 2.0.17 to phpBB 2.0.18 summed up into a little
##     Mod. This might be very helpful if you want to update your Board and have installed a bunch
##     of Mods. Then it's normally easier to apply the Code Changes than to install all Mods again.
##
## MOD Version: 1.0.0
##
## Installation Level: Advanced
## Installation Time: 1 Hour
1 hour...heh

ttyR2
Registered User
Posts: 88
Joined: Fri May 16, 2003 8:42 pm

Post by ttyR2 »

I didn't have the <root of board>/install folder. Created it and then update_to_latest worked.

Okay, after doing the update in the correct order, I still get:

Critical Error

FIND FAILED: In file [templates/subSilver/overall_header.tpl] could not find:

{L_FAQ}</a></span><span class="mainmenu">

MOD script line #2965 :: FAQ :: Report

I assume I can ignore it as the code isn't there at all. Right?

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29257
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty »

ttyR2 wrote: I assume I can ignore it as the code isn't there at all. Right?

Yes, that particular change can be ignored.
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

Bleed
Registered User
Posts: 139
Joined: Fri Jan 21, 2005 12:28 am
Contact:

Post by Bleed »

I get this error --

Warning: main(./pagestart.php): failed to open stream: No such file or directory in /home/removed/public_html/lostforum/admin/index.php on line 31

Warning: main(./pagestart.php): failed to open stream: No such file or directory in /home/removed/public_html/lostforum/admin/index.php on line 31

Fatal error: main(): Failed opening required './pagestart.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/removed/public_html/lostforum/admin/index.php on line 31

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29257
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty »

Looks like you are missing the {root}/admin/pagestart.php file
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

Locked

Return to “2.0.x Support Forum”

cron