Re-install!

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Viskar
Registered User
Posts: 33
Joined: Fri Dec 10, 2004 11:36 pm
Location: Fl.
Contact:

Re-install!

Post by Viskar »

OK So I'm re-installing my forums after a year of playing around. And I'm having the same probablem I had last time. only I can't remember how I fixed it. I'm at the install screen when you put 'Database name" and such. Well I went into MySQL made a database for forums called "forum" And MySQL is in a folder called db2

Database Server Hostname / DSN:
Your Database Name: forum
Database Username: *****
Database Password: *****
Prefix for tables in database:

didn't work

Database Server Hostname / DSN:
Your Database Name: db2
Database Username: *******
Database Password: *******
Prefix for tables in database:

didn't work I keep getting "Can't connect to database" any help would be grateful!
People Hate what they don't understand.
People don't understand what they fear.
Alot of people hate me
User avatar
IP-Dope
Registered User
Posts: 261
Joined: Fri Dec 07, 2001 4:35 pm
Location: Whistler BC, Canada

Post by IP-Dope »

Hi,

Your problem could be the DSN setting. You havent filled in anything at all, so the install script has no idea which server it should connect to.
If the mysql database is running on the same server as your web server, try either "localhost" or "127.0.0.1", at least one of them should work. If the server is running on a different server and you have no knowledge of it's ip address, contact your webhost and ask them for the server IP.

Hope this helps.

[Edit: typo]
Viskar
Registered User
Posts: 33
Joined: Fri Dec 10, 2004 11:36 pm
Location: Fl.
Contact:

Post by Viskar »

It's on same server. I have the MySQL version set up right. I pointed it to 'forumdb" (sql I made for it) tried it with DSN as 127.0.0.1 and localhost, everything

I keep getting " phpBB : Critical Error

Could not connect to the database " tried searching but for some reason all the searches bring up a white screen?
People Hate what they don't understand.
People don't understand what they fear.
Alot of people hate me
Locked

Return to “2.0.x Support Forum”