Can't get Enable Visual Confirmation- can anyone help?

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
MCPB
Registered User
Posts: 198
Joined: Wed Jan 14, 2004 3:07 am

Can't get Enable Visual Confirmation- can anyone help?

Post by MCPB »

I have phpbb up to date 2.0.18.

In the ACP, under Configuration I have an option for: Enable Visual Confirmation

It has two radio buttons one says yes the other no.

I select the YES button, then click SUBMIT at the bottom and I get this:

Code: Select all

Forum Configuration Updated Successfully
But when I go back to the Configuration page it is set back to NO by default.

For some reason it will not stay on YES. Anyone have an idea why it would do this? And how i can fix it?


Thanks!
Last edited by MCPB on Mon Jan 09, 2006 5:07 am, edited 2 times in total.

User avatar
jwunderly
Registered User
Posts: 5740
Joined: Sun Mar 30, 2003 2:18 pm
Location: Easton, PA (in the groove)

Re: Enable Visual Confirmation - Error?

Post by jwunderly »

MCPB wrote:

Code: Select all

Forum Configuration Updated Successfully
But when I go back to the Configuration page it is set back to NO by default.


Please copy the Support Request Template body into a reply to this topic and complete it as fully as possible, so that we may provide assistance.
John (A cranky old man. "Looking for an echo ...")
using any control-panel install/update is like shooting yourself in the foot. It won't kill you, but you're really going to hobble around until it heals.
Using the wrong tools (Front Page, DreamWeaver) gives the same results
Do not PM me for Support!

MCPB
Registered User
Posts: 198
Joined: Wed Jan 14, 2004 3:07 am

Post by MCPB »

URL: no url to error, no error msg shown
Template(s) used: SubSilver
Any and all MODs:
Do you use a port of phpBB:
Version of phpBB: 2.0.18
Version of PHP:
Which database server and version:
Host: ehostpros.com
Did someone install this for you/who: I did
Is this an upgrade/from what to what:
Is this a conversion/from what to what:
Have you searched for your problem: yes
If so, what terms did you try: Enable Visual Confirmation
State the nature of your problem: When I clike the Enable Visual Confrimation button to yes, it does not take effect.
Do you have a test account for us: YES

User avatar
jwunderly
Registered User
Posts: 5740
Joined: Sun Mar 30, 2003 2:18 pm
Location: Easton, PA (in the groove)

Post by jwunderly »

We need a link to your forum, since you didn't put it in the support template and also the version of PHP.
John (A cranky old man. "Looking for an echo ...")
using any control-panel install/update is like shooting yourself in the foot. It won't kill you, but you're really going to hobble around until it heals.
Using the wrong tools (Front Page, DreamWeaver) gives the same results
Do not PM me for Support!

MCPB
Registered User
Posts: 198
Joined: Wed Jan 14, 2004 3:07 am

Post by MCPB »

PHP version: 4.3.10

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom »

Using a database tool like phpmyadmin, browse the table phpbb_config. You are looking for an entry with a config_name of "enable_confirm". If it is not present (check all pages of the display), you need to add it:

Code: Select all

insert into phpbb_config (config_name, config_value) values ("enable_confirm", "1");
The configuration editor can change values, but it can not add them. Some people do updates by manually changing databases, rather than running update_to_latest.php, but leave out things they're not using... The update script will not add items that a previous update would have done, if the version number shown in the database says the change should have already been completed.
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

MCPB
Registered User
Posts: 198
Joined: Wed Jan 14, 2004 3:07 am

Post by MCPB »

got this:

Code: Select all

SQL query: 

INSERT INTO phpbb_config( config_name, config_value ) 
VALUES (

"enable_confirm", "1"
) 
MySQL said:  

#1054 - Unknown column 'config_name' in 'field list' 

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom »

That's not right... config_name is the column name in a standard PHPBB install. The config table has two columns:

Code: Select all

CREATE TABLE `phpbb_config` (
  `config_name` varchar(255) NOT NULL default '',
  `config_value` varchar(255) NOT NULL default '',
  PRIMARY KEY  (`config_name`)
) TYPE=MyISAM;
The query I posted should either get a "duplicate on key 1" error (the value is already there), or "1 row affected". Check the properties of your config table, for column names!
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

MCPB
Registered User
Posts: 198
Joined: Wed Jan 14, 2004 3:07 am

Post by MCPB »

so you want me to run the code you posted of look for somthing else?

MCPB
Registered User
Posts: 198
Joined: Wed Jan 14, 2004 3:07 am

Post by MCPB »

I ran

Code: Select all

insert into phpbb_config (config_name, config_value) values ("enable_confirm", "1");
This is what it said:

Code: Select all

Error 
SQL query: 

INSERT INTO phpbb_config( config_name, config_value ) 
VALUES (

"enable_confirm", "1"
) 
MySQL said:  

#1054 - Unknown column 'config_name' in 'field list' 
 

MCPB
Registered User
Posts: 198
Joined: Wed Jan 14, 2004 3:07 am

Post by MCPB »

This is all I have in my config_table:

Code: Select all

 Field             Type                Attributes      Null    Default Extra Action 
config_value       varchar(255)                         No     1               

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom »

If that's all you have in your config table, something has screwed it up. Do you have a backup from before your latest round of modifications, that you can use to restore just the config table? Without the config_name column, the table has no useful data in it...
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

MCPB
Registered User
Posts: 198
Joined: Wed Jan 14, 2004 3:07 am

Post by MCPB »

I have a bunch of back up files...


What should I look for to add or run?

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom »

You need to drop the current (defective) config table. Find the section of your backup that deals with the config table, copy and paste it into a new file, and restore just that. It should start with a "create table phpbb_config" statement, and end just before the next "create table" statement. It will include a couple of dozen INSERT statements, looking a lot like this, from the v2.0.15 install (I don't have 2.0.18's handy):

Code: Select all

CREATE TABLE phpbb_config (
    config_name varchar(255) NOT NULL,
    config_value varchar(255) NOT NULL,
    PRIMARY KEY (config_name)
);

# -- Config
INSERT INTO phpbb_config (config_name, config_value) VALUES ('config_id','1');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('board_disable','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('sitename','yourdomain.com');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('site_desc','A _little_ text to describe your forum');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('cookie_name','phpbb2mysql');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('cookie_path','/');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('cookie_domain','');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('cookie_secure','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('session_length','3600');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('allow_html','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('allow_html_tags','b,i,u,pre');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('allow_bbcode','1');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('allow_smilies','1');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('allow_sig','1');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('allow_namechange','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('allow_theme_create','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('allow_avatar_local','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('allow_avatar_remote','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('allow_avatar_upload','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('enable_confirm', '0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('override_user_style','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('posts_per_page','15');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('topics_per_page','50');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('hot_threshold','25');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('max_poll_options','10');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('max_sig_chars','255');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('max_inbox_privmsgs','50');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('max_sentbox_privmsgs','25');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('max_savebox_privmsgs','50');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('board_email_sig','Thanks, The Management');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('board_email','youraddress@yourdomain.com');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('smtp_delivery','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('smtp_host','');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('smtp_username','');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('smtp_password','');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('sendmail_fix','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('require_activation','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('flood_interval','15');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('board_email_form','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('avatar_filesize','6144');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('avatar_max_width','80');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('avatar_max_height','80');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('avatar_path','images/avatars');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('avatar_gallery_path','images/avatars/gallery');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('smilies_path','images/smiles');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('default_style','1');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('default_dateformat','D M d, Y g:i a');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('board_timezone','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('prune_enable','1');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('privmsg_disable','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('gzip_compress','0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('coppa_fax', '');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('coppa_mail', '');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('record_online_users', '0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('record_online_date', '0');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('server_name', 'www.myserver.tld');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('server_port', '80');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('script_path', '/phpBB2/');
INSERT INTO phpbb_config (config_name, config_value) VALUES ('version', '.0.15');
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

MCPB
Registered User
Posts: 198
Joined: Wed Jan 14, 2004 3:07 am

Post by MCPB »

ok did that and it said this:

Code: Select all

Your SQL query has been executed successfully:
The content of your file has been inserted. (: 107 Instructions)

But it still wont let me change the Enable account activation to on.

Locked

Return to “2.0.x Support Forum”