Email system not working (template used)

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
MFM
Registered User
Posts: 32
Joined: Tue Feb 01, 2005 4:38 am

Email system not working (template used)

Post by MFM » Thu Dec 22, 2005 4:45 am

URL: http://www.magicformagicians.info/forums/
Template(s) used: Subza
Any and all MODs: Userlist, ModCP, XS MOD
Do you use a port of phpBB: ??? port 80 im guessing....
Version of phpBB: .18
Version of PHP: ???? dont know
Which database server and version: dont know
Host: Godaddy.com
Did someone install this for you/who: I did
Is this an upgrade/from what to what: No
Is this a conversion/from what to what: No
Have you searched for your problem: Seems like the search feature doesn't work for me....
If so, what terms did you try: "Email Error"
State the nature of your problem: When someone replies to a thread, or sometimes registers, the email is not sent, yes everything is turned on.
Do you have a test account for us: in light of the error, i dont think it would help, you would have to register under your own email.


It seems that whenever a member replies to a thread, the "reply" email is not sent out (yes this option is turned on). Also my forum has been having problems with new members, either they dont get the registration email at all, or the confirmation link doesn't work...

If you can help me, it would be much appreciated.

Thanks you,
/// Matt
Msquared-Designs.com
matt@msquared-designs.com

argus
Registered User
Posts: 501
Joined: Sun Feb 27, 2005 12:14 am

Post by argus » Thu Dec 22, 2005 5:33 am

Unfortunately, this is a known problem with hosting phpbb on godaddy. Most of the godaddy users just don't realize it though. 'tis a shame because Topic Reply Emails are pretty darned important in helping a board thrive.

Anyway, the fix may be found within the following Topic: http://www.phpbb.com/phpBB/viewtopic.ph ... 03#1862103

User avatar
UseLess
Registered User
Posts: 521
Joined: Mon Jul 22, 2002 7:26 pm
Location: North East UK

Post by UseLess » Thu Dec 22, 2005 6:02 am

Greetings,

You could also try this, but it may not work as it depends on how the host has configured sendmail, but it's worth a try;

Code: Select all

# 
#-----[ OPEN ]-------------------------------------------------------
#

includes/emailer.php

# 
#-----[ FIND ]-------------------------------------------------------
#

			$result = @mail($to, $this->subject, preg_replace("#(?<!\r)\n#s", "\n", $this->msg), $this->extra_headers);

# 
#-----[ REPLACE WITH ]----------------------------------------------- 
#

//			$result = @mail($to, $this->subject, preg_replace("#(?<!\r)\n#s", "\n", $this->msg), $this->extra_headers);  
			// Replacement for the above line to include the '-f' (from) switch along with the forum email address
			$result = @mail($to, $this->subject, preg_replace("#(?<!\r)\n#s", "\n", $this->msg), $this->extra_headers, "-f" . $board_config['board_email']); 

# 
#-----[ SAVE/CLOSE ALL FILES ]--------------------------------------- 
# 
# EoM
Movie Quote:
It's not the years honey, it's the mileage...
phpBB 3 Mods @ phpBBStyles

MFM
Registered User
Posts: 32
Joined: Tue Feb 01, 2005 4:38 am

Post by MFM » Wed Dec 28, 2005 11:34 pm

argus wrote: Unfortunately, this is a known problem with hosting phpbb on godaddy. Most of the godaddy users just don't realize it though. 'tis a shame because Topic Reply Emails are pretty darned important in helping a board thrive.

Anyway, the fix may be found within the following Topic: http://www.phpbb.com/phpBB/viewtopic.ph ... 03#1862103


Thanks Dude, that actually fixed the problem.

Thanks again,
/// Matt
Msquared-Designs.com
matt@msquared-designs.com

argus
Registered User
Posts: 501
Joined: Sun Feb 27, 2005 12:14 am

Post by argus » Wed Dec 28, 2005 11:43 pm

No problem. Am glad it helped.

So far, that's the only bug I've run across hosting phpBB on godaddy linux servers. No other tweaks required.

net83it
Registered User
Posts: 500
Joined: Sun Jan 15, 2006 2:42 pm
Location: Sicily
Contact:

Post by net83it » Fri Jan 20, 2006 6:29 pm

hello people

i have a similar problem. godaddy server doesn't send email created from the following function of the file includes/functions_post.php

Code: Select all

//
// Handle user notification on new post
//
[...]
this function creates notification emails of new replies.
all other emails (registration email, user group notification...) are sent. so it is very strange.

actually i solved by using the smtp relay option but often the godaddy relay server is busy and i get debug errors on my pages (Couldn't get mail server response codes on line 201 of smtp.php)

i'll check the discussion that argus indicated hoping it'll solve the problem

Locked

Return to “2.0.x Support Forum”