UPDATE FROM 2.0.17 TO 2.0.18

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Bicester Town
Registered User
Posts: 30
Joined: Thu Dec 29, 2005 7:17 pm
Location: Bicester, Oxforshire, UK
Contact:

UPDATE FROM 2.0.17 TO 2.0.18

Post by Bicester Town » Thu Dec 29, 2005 8:48 pm

Hi all. I was trying to find an online tutorial to do this update. I have found a few, quite difficult ones. I need a simple one. Can anyone help me?


p.s. I have been told that 2.0.18 has more security bugs than the previous one. Is this true? :roll:
Regards

Radio Bicester | Computer Repairs in Bicester | Bicester Town Forum

"He who desires, but acts not, breeds pestilence." - William Blake (1757-1827)

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Re: UPDATE FROM 2.0.17 TO 2.0.18

Post by Jim_UK » Thu Dec 29, 2005 8:58 pm

Bicester Town wrote: Hi all. I was trying to find an online tutorial to do this update. I have found a few, quite difficult ones. I need a simple one. Can anyone help me?


p.s. I have been told that 2.0.18 has more security bugs than the previous one. Is this true? :roll:
Regards

The update from 2.0.17 to 2.0.18 was written to be easymod compatible as it involved edits to 58 files.
http://www.phpbb.com/files/releases/php ... 2.0.18.zip
If you do not have Easymod then install that first.
Can be found here http://sourceforge.net/projects/easymod

As for the second part of your question the answer is "of course not".
As phpBB2 is so popular and open source it will remain a prime target of hackers. Just keep your board up to date and all should be ok.

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Thu Dec 29, 2005 9:01 pm

Whoever said there are "more bugs" doesn't understand how math works. In all cases in my universe, "X-1" is fewer than "X"... :wink:

Doing the changes off-line is not difficult. You just need a test environment. http://www.easyphp.org has an installer that will build the environment on a Windows computer. Then you just need a text editor and the ability to follow instructions...
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

Bicester Town
Registered User
Posts: 30
Joined: Thu Dec 29, 2005 7:17 pm
Location: Bicester, Oxforshire, UK
Contact:

Post by Bicester Town » Thu Dec 29, 2005 9:09 pm

i do have a lot of mods installed. is that gonna affect the way i should do the upgrade?

Radio Bicester | Computer Repairs in Bicester | Bicester Town Forum

"He who desires, but acts not, breeds pestilence." - William Blake (1757-1827)

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK » Thu Dec 29, 2005 9:24 pm

Mods do alter the way you do the upgrade but the link I posted was a mod method. Install Easymod if you have not already done so and it will do the update for you. I have now updated 5 boards using it and all went without a hitch. One of the boards had 30 mods on it.

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

Bicester Town
Registered User
Posts: 30
Joined: Thu Dec 29, 2005 7:17 pm
Location: Bicester, Oxforshire, UK
Contact:

Post by Bicester Town » Fri Dec 30, 2005 2:54 am

fantastic!
so far so good.
i have installed the easymod. (great tool)
now...i am a little bit confused:
-----------------------------------------------------------------
BEFORE installing this MOD, you have to upload the file
install/update_to_latest.php, execute it and then delete it
from your webspace.
-----------------------------------------------------------------
where shall i upload the update to?
regards

Radio Bicester | Computer Repairs in Bicester | Bicester Town Forum

"He who desires, but acts not, breeds pestilence." - William Blake (1757-1827)

p3980
Registered User
Posts: 1311
Joined: Sat Jul 23, 2005 5:02 pm

Post by p3980 » Fri Dec 30, 2005 2:59 am

You create a folder called install, and put update_to_latest.php into it.
Support Request Template <> Knowledge Base<>starfoxtj's Admin Toolkit
Member of the Unofficial Forum for phpBB.com Supporters
Image

Bicester Town
Registered User
Posts: 30
Joined: Thu Dec 29, 2005 7:17 pm
Location: Bicester, Oxforshire, UK
Contact:

Post by Bicester Town » Fri Dec 30, 2005 4:07 am

thanks a lot. i have managed to update it but,....

this is what my board keeps saying:

Version Information
Your installation does not seem to be up to date. Updates are available for your version of phpBB, please visit http://www.phpbb.com/downloads.php to obtain the latest version.
The latest available version is phpBB 2.0.18. You are running phpBB 2.0.17.

For the latest information on updates to phpBB, why not subscribe to our mailing list.



Powered by phpBB 2.0.17 © 2001 phpBB


how come? :?:

Radio Bicester | Computer Repairs in Bicester | Bicester Town Forum

"He who desires, but acts not, breeds pestilence." - William Blake (1757-1827)

User avatar
Lumpy Burgertushie
Registered User
Posts: 66738
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie » Fri Dec 30, 2005 4:15 am

you have not done the update yet.

you either create a folder named install or you just uplaod the install folder from the phpbb zip file.

then make sure that the update_to_latest.php file is in that folder,

then in your browser, go to:

yourdomain.com/yourphpbb/install/update_to_latest.php then delete the install folder and you are done with that part of the update


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

Bicester Town
Registered User
Posts: 30
Joined: Thu Dec 29, 2005 7:17 pm
Location: Bicester, Oxforshire, UK
Contact:

Post by Bicester Town » Fri Dec 30, 2005 4:38 am

this is exactly what i have done. at the end of the process i have been asked to remove the those files. i can check my database and it is updated. just my board shows me that i still have the old version. :?

Radio Bicester | Computer Repairs in Bicester | Bicester Town Forum

"He who desires, but acts not, breeds pestilence." - William Blake (1757-1827)

User avatar
Lumpy Burgertushie
Registered User
Posts: 66738
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie » Fri Dec 30, 2005 5:14 am

what style are you using?

also, do you have more than one database or more than one set of phpbb tables in your database?


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.2 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

Bicester Town
Registered User
Posts: 30
Joined: Thu Dec 29, 2005 7:17 pm
Location: Bicester, Oxforshire, UK
Contact:

Post by Bicester Town » Fri Dec 30, 2005 12:52 pm

2 databases
1 for the forum, the other one for a search engine. has no business with the forum one( i hope)
the template that i use is subportal but i have tried subsilver too and i get the same results.
regards

Radio Bicester | Computer Repairs in Bicester | Bicester Town Forum

"He who desires, but acts not, breeds pestilence." - William Blake (1757-1827)

Bicester Town
Registered User
Posts: 30
Joined: Thu Dec 29, 2005 7:17 pm
Location: Bicester, Oxforshire, UK
Contact:

A new version - .19

Post by Bicester Town » Fri Dec 30, 2005 6:12 pm

.............it's getting even worse now...presuming that I want to update it to .19 version....I am not sure what version I run at this point. Trying an update from .18 to .19 may not work. I am in a real chaos right now. Apparently I have .18 but my board say that I have .17 I want to get .19 but I do not know how to do it considering the above details. :cry:

Radio Bicester | Computer Repairs in Bicester | Bicester Town Forum

"He who desires, but acts not, breeds pestilence." - William Blake (1757-1827)

iNfLuX
Registered User
Posts: 108
Joined: Thu Jul 10, 2003 2:55 pm
Contact:

Post by iNfLuX » Sat Dec 31, 2005 5:17 am

i am now getting this error after updating when trying to view any topic on my board.

Code: Select all

Failure when looking up date entry for topic.

DEBUG MODE

SQL Error : 1146 Table 'flynotep_xmb.phpbb_mycalendar' doesn't exist
i see that it has something to do with my mycalendar mod... but it used to work fine before the update, and now it's not working and i'm not sure what is actually causing it.

any help would be greatly appreciated.[/code]

Bicester Town
Registered User
Posts: 30
Joined: Thu Dec 29, 2005 7:17 pm
Location: Bicester, Oxforshire, UK
Contact:

Post by Bicester Town » Wed Feb 08, 2006 12:02 am

i have managed to do it. everything seems to be ok except when a new user try to register. It creates a new user but it comes up with this error:

Failed sending email :: PHP ::

DEBUG MODE

Line : 236
File : emailer.php

what does that mean?

Radio Bicester | Computer Repairs in Bicester | Bicester Town Forum

"He who desires, but acts not, breeds pestilence." - William Blake (1757-1827)

Locked

Return to “2.0.x Support Forum”