Page 1 of 1

Solution Found.

Posted: Sun Jan 08, 2006 5:37 am
by felguard
I get this message:

Code: Select all

message_die() was called multiple times. This isn't supposed to happen. Was message_die() used in page_tail.php?
I had back up everything from my old host, so I'm trying to get things back to where they were with my new host. Heres what I've done:

1. Restored Home Directory in Cpanel (came with directory named forums)
2. Installed phpbb (in directory forum without the s)
3. Logged in to adminstration panel in phpbb, and restored phpbb_sql_db
4. I then changed the config.php in forums directory to the one in forum directory
5. I get the above message when accessing it
6. I have no idea how off my way of trying to restore was

I have no clue in how to restore a database, can anyone help me with this? Thank you.

Posted: Sun Jan 08, 2006 6:13 am
by Lumpy Burgertushie
first , make sure that the install and contrib folders are deleted.

then make sure that the config.php file is not empty


robert

Posted: Sun Jan 08, 2006 6:21 am
by felguard
Both folders deleted.

The file config.php is not clear.

Thanks though.

Posted: Sun Jan 08, 2006 6:46 am
by Lumpy Burgertushie
felguard wrote: Both folders deleted.

The file config.php is not clear.

Thanks though.


how about a link to your board so we can see.

robert

Posted: Sun Jan 08, 2006 6:51 am
by felguard
http://www.deimonhigh.com/forums/

Could you tell me step by step how to restore the forums correctly please if possible? Thanks.

Posted: Sun Jan 08, 2006 8:13 am
by Lumpy Burgertushie
your config.php file is either corrupted or blank.

open it in a text editor, like wordpad or even notepad

make sure it looks like this:

Code: Select all

<?php


// phpBB 2.x auto-generated config file
// Do not change anything in this file!

$dbms = 'mysql4';

$dbhost = 'localhost';   // this might be different for you
$dbname = 'your info here'; //your database name
$dbuser = 'your info here';  //your database username
$dbpasswd = 'your info here';  //your database password

$table_prefix = 'phpbb_'; //this is default, yours may be different

define('PHPBB_INSTALLED', true);

?>
and make sure there are no empty lines and/or spaces before the opening <? or after the ending ?>

robert

Posted: Sun Jan 08, 2006 8:45 am
by felguard
My config.php is:

Code: Select all

<?php


// phpBB 2.x auto-generated config file
// Do not change anything in this file!

$dbms = 'mysql';

$dbhost = 'localhost';
$dbname = 'dbnamehere';
$dbuser = 'dbuserhere';
$dbpasswd = 'dbpwhere';

$table_prefix = 'phpbb_';

define('PHPBB_INSTALLED', true);

?>

Posted: Sun Jan 08, 2006 8:58 am
by felguard
Errr, I fixed the solution. Why am I going Err, when I fixed it? Heres why:

http://www.codedfx.com/forums/index.php?showtopic=6886

Thank you for your help though, means a lot especially when no one else is answering. :D

Posted: Sun Jan 08, 2006 10:06 am
by Lumpy Burgertushie
felguard wrote: Errr, I fixed the solution. Why am I going Err, when I fixed it? Heres why:

http://www.codedfx.com/forums/index.php?showtopic=6886

Thank you for your help though, means a lot especially when no one else is answering. :D

that link requires registering or something.

how about just sharing what the problem was.

robert

Posted: Sun Jan 08, 2006 10:12 am
by felguard
Install phpBB, export the queries on your old database with phpMyAdmin, run those same queries on your new database.

The end.

That was it. lol. :D