Trying to update deleted my entire board!

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Rei-chan
Registered User
Posts: 3
Joined: Wed Oct 12, 2005 8:21 pm
Contact:

Trying to update deleted my entire board!

Post by Rei-chan »

Okay...I seriously need some help here.
I tried to upgrade to 2.0.19 - copied all the files into the directory, etc. where I had my board.
Now, when I try to access it, an 'install' window comes up (I get a "Could not connect" error if I try to use this). However, if I delete the /install directory, it claims that it cannot find it and I get a 404 error.
Anyway, it seems like my entire message board is gone and I have no clue what happened!

biscuitkeeper
Registered User
Posts: 778
Joined: Wed Jan 26, 2005 11:44 am
Location: NE Scotland

Post by biscuitkeeper »

What package did you download and put on your website? Is it an update package or fresh install?

It may be that you have overwritten your config while which has the dbname,username and password required to access the database. Also as well as updating files you have to run the file in the install folder which will be called /install/update_to_latest.php which updates the db tables.

check that your config.php contains the info you think it should (don't post the information in it for others to see as has been done in the past)
Patience of a Saint :: Memory of a Goldfish.

Locked

Return to “2.0.x Support Forum”