2.0.4 to 2.0.5 upgrade

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
brihan
Registered User
Posts: 24
Joined: Wed Jan 21, 2004 7:57 am

2.0.4 to 2.0.5 upgrade

Post by brihan »

Hi,

I searched for this info first and could not come up with anything.

I have been put in charge to upgrade a client's message board. Their current version is 2.0.4

The earliest upgrad conversion I can find is 2.0.5 to 2.0.6 and all the rest.

I need to know how to upgrade from 2.0.4 to 2.0.5 so that I can continue with all the upgrades so I can bring the board up to the current version.

Any help would be greatly appreciated.

Thank you,

Brian
snab
Registered User
Posts: 8
Joined: Mon Nov 24, 2003 8:06 pm
Location: Perth, Scotland

Post by snab »

This'll be the page you're looking for

http://www.phpbb.com/downloads.php
Cheers

Snab
brihan
Registered User
Posts: 24
Joined: Wed Jan 21, 2004 7:57 am

Post by brihan »

Hi Snab,

I appreciate the reply & link however all I see is the upgrade to 2.0.19.

I have also been to this page:
http://www.phpbb.com/phpBB/catdb.php?cat=48

but the upgrades start a 2.0.5 to 2.0.6


I need to find 2.0.4 to 2.0.5

Again, I appreciate any help anyone can give.

Thank you,

Brian
argus
Registered User
Posts: 501
Joined: Sun Feb 27, 2005 12:14 am

Post by argus »

Has the message board been modified? If not, then try the link that snab provided. The Changed Files package has several zip files within, including one that allows you to upgrade from 2.0.4 to 2.0.19.

The Changed Files method of upgrading will break many modifications though. That would be the only reason you would want to use the Code Changes you are seeking instead and update incrementally.

Even if it is a modified board, before I performed 15 sets of Code Changes, I would rather use the Changed Files package instead and then reinstall any mods after the fact.
gamepro
Registered User
Posts: 184
Joined: Sun Mar 27, 2005 4:17 am
Contact:

Post by gamepro »

The history of phpbb can be found at http://sourceforge.net/projects/phpbb

Updating instructions can be found here
User avatar
Lumpy Burgertushie
Registered User
Posts: 68171
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie »

start over with a brand new installation then decide which, if any, MODs you want to add back. anything that old is just not worth saving.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
brihan
Registered User
Posts: 24
Joined: Wed Jan 21, 2004 7:57 am

Post by brihan »

I would like to start over but I can't lose the current hacks/information that is with the board.

OK, I found and manually changed all code to upgrade from 2.0.4 to 2.0.5 (what a pain that was) but it is done.

2.0.5 on up shouldn't be to bad because I can use EZ mod for the updates.

My problem (now) is finding all of the update_to_205.php, update_to_206.php, etc. files.

These files seem to be the biggest secret on the Internet.

There are a million sites that say you must run these files, but no one has the files available.

Can someone please point me in the right direction to find the "upgrade_to_xxx" files? I need 205 on up.

Thank you,

Brian
SER
Registered User
Posts: 1308
Joined: Fri Sep 06, 2002 6:09 am
Location: N 34 3 8 / W 118 14 33

Post by SER »

Important, make sure you run update_to_latest.php after every upgrade, and check your forums functionality after each upgade.

NOTE: the update_to_XXX.php files were numbered up to and including 2.0.11, after that (going from 2.0.11 to 2.0.12 and up) the name of the file was changed to update_to_latest.php

The update_to_205.php or update_to_latest.php (depending on the update you are doing) can be found in the install folder inside each update. Load the install folder to your forum root.
Using your browser, go to:
http://{yoursite}/{your forum}/install/update_to_latest.php (or update_to_xxx.php if you are updating anything below version 2.0.11).
Once this is done, delete the install folder.

It would be smart to back everything up after each update so that if you screw it up, you can go back to the last working version and try the upgrade again.

That said,
You can find all versions of the phpBB files (1.0.0 to 2.0.19) at:
LINK>> Source Forge <<LINK
Visual Guide to Avatar Galleries
The Unoficial Staff Forum For The Unofficial Support Team | Join me at HauntX Remember, if it's Haunted, it's here!
"Support helps those who help themselves." | "You can lead a fool to wisdom, but you cannot make him think."
brihan
Registered User
Posts: 24
Joined: Wed Jan 21, 2004 7:57 am

Post by brihan »

THANK YOU!!!

That is exactly what I needed.

Brian
Locked

Return to “2.0.x Support Forum”