upgrade from 2.017 to 2.019

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
User avatar
mad72
Registered User
Posts: 74
Joined: Thu Mar 13, 2003 4:20 pm
Location: Milan, Italy
Contact:

upgrade from 2.017 to 2.019

Post by mad72 »

Hello everybody!

Is it possible to upgrade directly from 2.017 to 2.019?
I didn't find the files...

Thank you, bye, Marco

User avatar
thecharmed01
Former Team Member
Posts: 2637
Joined: Sun May 16, 2004 10:07 am
Location: Wellington, NZ
Contact:

Post by thecharmed01 »

No, you will need to go from 17 to 18 and then check it is still all working fine.

Then go from 18 to 19.

Best of luck.
Please refrain from PM'ing me for support unless I specifically ask you to.......

Helpful Pages: ~ [Styles FAQ] ~ [Styles User Guide] ~ [Styles Submission Policy]
My Site: [C1 Web Design]
| Mummy | Web Designer | Slave | Digi-Scrap Addict | Vampire |

User avatar
-ds-
Registered User
Posts: 554
Joined: Wed Sep 14, 2005 7:12 pm

Post by -ds- »

If you have problems with the auto login and keep getting logged out randomly (more so if you are using firefox), keep the updated copy of includes/sessions.php and revert to the version used with 2.0.17. This seemed to have fixed the error for me.

No word from support on this issue as yet though.

User avatar
mad72
Registered User
Posts: 74
Joined: Thu Mar 13, 2003 4:20 pm
Location: Milan, Italy
Contact:

Post by mad72 »

thank you :(

in the download section I didn't find the files for updating... do you know where I can get them?

thank you, bye, Marco

User avatar
-ds-
Registered User
Posts: 554
Joined: Wed Sep 14, 2005 7:12 pm

Post by -ds- »

http://prdownloads.sourceforge.net/phpbb/

get the patch files for 2.0.18 and 2.0.19

User avatar
mad72
Registered User
Posts: 74
Joined: Thu Mar 13, 2003 4:20 pm
Location: Milan, Italy
Contact:

Post by mad72 »

this file: phpBB-2.0.18-patch.zip
and the one for 19...

ok, thank you!!!

I hope this will work...

bye, Marco

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Re: upgrade from 2.017 to 2.019

Post by Jim_UK »

mad72 wrote: Hello everybody!

Is it possible to upgrade directly from 2.017 to 2.019?
I didn't find the files...

Thank you, bye, Marco


With no mods on your board use the changed files download.
With mods installed then see this Step by step upgrade mods http://www.phpbb.com/phpBB/catdb.php?cat=48

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK »

-ds- wrote: If you have problems with the auto login and keep getting logged out randomly (more so if you are using firefox), keep the updated copy of includes/sessions.php and revert to the version used with 2.0.17. This seemed to have fixed the error for me.

No word from support on this issue as yet though.


I take it you did try running the auto cookies mod.
If not give it a try. http://www.phpbb.com/phpBB/viewtopic.php?t=228741
Accept all suggested settings - then log out and clear cache and cookies in your browser.
Close and restart browser and then log in.


Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

User avatar
mad72
Registered User
Posts: 74
Joined: Thu Mar 13, 2003 4:20 pm
Location: Milan, Italy
Contact:

Re: upgrade from 2.017 to 2.019

Post by mad72 »

Jim_UK wrote: With no mods on your board use the changed files download.
With mods installed then see this Step by step upgrade mods http://www.phpbb.com/phpBB/catdb.php?cat=48
Jim


Hello Jim, sorry, I did not understand well.


I have only 2, 3 mods but I don't care if I loose them, I can reinstall later (who is online in last 24 hours, see invisible...).

Can I use the patch from 17 to 18 and then to 19 or better do it step by step manually?

Thank you, ciao, Marco

User avatar
-ds-
Registered User
Posts: 554
Joined: Wed Sep 14, 2005 7:12 pm

Post by -ds- »

Jim_UK wrote:
-ds- wrote:If you have problems with the auto login and keep getting logged out randomly (more so if you are using firefox), keep the updated copy of includes/sessions.php and revert to the version used with 2.0.17. This seemed to have fixed the error for me.

No word from support on this issue as yet though.


I take it you did try running the auto cookies mod.
If not give it a try. http://www.phpbb.com/phpBB/viewtopic.php?t=228741
Accept all suggested settings - then log out and clear cache and cookies in your browser.
Close and restart browser and then log in.


Jim


Hi Jim,

yes I have run the cookie mod a lot of times, tried all sorts of setting and never got any results from it and was still always logged out.

There is a 10 page thread on the matter:

http://www.phpbb.com/phpBB/viewtopic.php?t=337066


Finally now I have reverted back to the 2.0.17 version of the sessions.php file it seems to stop logging me out when i close the browser.

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK »

Hi
Can we try and keep this to the original problem of the upgrade.
mad72
If you are not bothered about those mods then this is the best method.
Download the complete 2.0.19 package.
make a complete backup of your board files and database (just in case 8O )
ftp the config.php to your desktop and keep safe.
Unzip the download and then ftp the contents to the correct place to overwrite the files that are there on the server.
Now ftp the config.php back to the server.
Now run the file http://yourdomain/yourphpBB2/install/up ... latest.php
Now delete the install and contrib directories

Now re-install the mods if you want them. The tables and extra fields they may have used will still be there in the database.

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

User avatar
mad72
Registered User
Posts: 74
Joined: Thu Mar 13, 2003 4:20 pm
Location: Milan, Italy
Contact:

Post by mad72 »

thank you very much Jim, very kind help.

I'll try!!

Have a nice day, Marco

User avatar
Lumpy Burgertushie
Registered User
Posts: 67040
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie »

-ds- wrote: http://prdownloads.sourceforge.net/phpbb/

get the patch files for 2.0.18 and 2.0.19


the patch files are only for those that have access to and know how to use the unix command line.

what most people need is the changed files package or the complete package.


robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If a tree falls in the forest and nobody is there, does it make a sound?

mjpd1
Registered User
Posts: 67
Joined: Tue Sep 24, 2002 9:10 pm
Location: Columbus, OH
Contact:

Post by mjpd1 »

Hope this is along the same lines as the original post...

I'm currently running 2.0.17 with several small mods as well. I normally just do the step-by-step updates between versions. But the estimated time for doing that from 2.0.17 to 2.0.18 is 2+ hours! Every other update is 10-15 minutes....20 minutes tops.

Why over 2 hours for this update? I'm thinking it'll just be quicker to back up the db, uninstall, and install a fresh copy of the board.

I'm gonna be more selective of the mods I install from now on, as they're increasingly becoming more of a pain when it comes time to upgrade. I'm hoping phpBB3 incorporates some kind of an "auto-update" feature, although I understand that might be a bit too much to ask.

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK »

Why over 2 hours for this update?


60 files to change and that is if you only have subSilver. There were several template changes as well. This upgrade will work with Easymod however.

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

Locked

Return to “2.0.x Support Forum”