Problem logging in

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
acctman
Registered User
Posts: 103
Joined: Thu Feb 09, 2006 5:48 pm

Problem logging in

Post by acctman » Fri Feb 17, 2006 6:26 pm

hi i can't login, i keep receiving the following message. i was able to login before not sure why it's not working now.

You have specified an incorrect or inactive username, or an invalid password.

User avatar
Jim_UK
Former Team Member
Posts: 18474
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK » Fri Feb 17, 2006 6:28 pm

Is this your own board?
Have you by any chance deleted a user called Anonymous?

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

acctman
Registered User
Posts: 103
Joined: Thu Feb 09, 2006 5:48 pm

Post by acctman » Fri Feb 17, 2006 9:26 pm

yes this is my own board, the user Anonymous is still there with -1 as the ID in the database

User avatar
Jim_UK
Former Team Member
Posts: 18474
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK » Fri Feb 17, 2006 9:32 pm

Please complete as fully as you can the Support Request Template.
http://www.phpbb.com/phpBB/viewtopic.php?t=128123

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

acctman
Registered User
Posts: 103
Joined: Thu Feb 09, 2006 5:48 pm

Post by acctman » Sat Feb 18, 2006 1:55 am

URL: ratemybottom.com/forum/
Template(s) used: aphrodite_english
Any and all MODs: eXtreme Styles mod 2.31
Do you use a port of phpBB: no
Version of phpBB: 2.0.19
Version of PHP: ver 4
Which database server and version: mysql4
Host: servermatrix
Did someone install this for you/who: nope
Is this an upgrade/from what to what: nope
Is this a conversion/from what to what: nope
Have you searched for your problem: yes
If so, what terms did you try: invalid login
State the nature of your problem: login is not being accepted. user acct is valid as well as password. I've reset the db from a back and everything worked. the last thing what was done was a changing of the themes and after the session expired i wasn't able to get back it. Here's what i do know. the board worked without x-mod installed but it also worked with it installed too. I'm thinking it might be when i updated the theme change. Also i didn't make A LOT of changes to phpbb... i changed all user_id entries to m_id and all username to m_user as well as changing the user table to rate_members. that was a big change but, everything works fine without any mods. any ideas, could x-mod be writing something to the users table when the theme is changed?

Do you have a test account for us: no, but i have an acct that can be used

acctman
Registered User
Posts: 103
Joined: Thu Feb 09, 2006 5:48 pm

Post by acctman » Sat Feb 18, 2006 3:16 am

ok i uninstalled extreme-mod and reloaded the back of the phpbb tables i have.

- phpbb works fine with no mods.
- PROBLEM phpbb stops excepting logins with aphrodite_english theme installed

what i noticed, any new theme i install seems to make the login process invalid. when a theme is installed what new info is it writing to the user table and config file? i'm trying to figure out why it would make the login process invalid.

Psychotic_Carp
Registered User
Posts: 556
Joined: Fri Dec 03, 2004 1:45 pm

Post by Psychotic_Carp » Sat Feb 18, 2006 3:19 am

This might not work but its worth a try, throw the login tpl from another working them into a non working theme.

They may be made for an older version.

acctman
Registered User
Posts: 103
Joined: Thu Feb 09, 2006 5:48 pm

Post by acctman » Sat Feb 18, 2006 3:30 am

ok i think i may of found the problem... the .tpl FORM post for the login use name=username and name=user_id. i changed the DB reference to be m_id and m_user for my intergrate into my existing rate_members table.

can i make a suggestion for the next release of phpbb3 this make intergration into existing user tables a lot easier. the constants.php file defines all the tables. why not allow it to define the USERS fields as well. for example i changed the users define from
define('USERS_TABLE', $table_prefix.'users'); to
define('USERS_TABLE', 'rate_members');

then i had to manual find and replace all username and user_id reference in php to m_id and m_user when would make phpbb references my existing user tb. final i copied all the extra user fields from phpbb_users to my rate_members tb using the ALTER TABLE ADD command. last i just inserted the anonymous and admin user into the rate_members.

it was a long process not knowing if it would work but it did. If there could be some how a reference so that the user can change Username = m_user or whatever that would help people intergrate phpbb into existing user tables faster.

Locked

Return to “2.0.x Support Forum”