Has anyone here created a template or made buttons for board

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
Kristie
Registered User
Posts: 66
Joined: Thu Feb 24, 2005 10:06 am

Has anyone here created a template or made buttons for board

Post by Kristie » Sun Apr 30, 2006 9:20 pm

I have made a new look for my board, and I created new buttons to match...for the post, reply to post, etc, buttons. I have them sized the same as subsilvers buttons of which I used to actually create the new look, it was mostly just color changes, but when I put my button images up, they display fine at the bottom of the board where it tells the button meaning, but in the board forum rows they are distorted. I have yet to find a solution to this distortion and figured someone who has created buttons for a template may be able to help.

I am pretty php illiterate, but I do web design and graphics. When I have this problem in html pages, typically removing any dimension settings in the html solves it, since the image is the correct size already and then will display as correct size. Sometimes programs such as frontpage or dreamweaver will always want to sixze the images for you, distoring them so you just manually remove the dimensions. But this being php, I have no html to work with, so I am lost on a solution. There is no understandable reason to me why my image which is the exact size as the subsilver image is distorting in the columns, when the subsilver ones display correctly.

Appreciate any help and thanks in advance.

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29253
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty » Sun Apr 30, 2006 9:24 pm

It is actually HTML that you have to work with. The dimensions for the images are in the .tpl files in the templates folder. If you post a link to your board, I'll tell you exactly what to edit.
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK » Sun Apr 30, 2006 9:27 pm

open templates/subSilver/index_body.tpl
and find
<td class="row1" align="center" valign="middle" height="50"><img src="{catrow.forumrow.FORUM_FOLDER_IMG}" width="46" height="25" alt="{catrow.forumrow.L_FORUM_FOLDER_ALT}" title="{catrow.forumrow.L_FORUM_FOLDER_ALT}" /></td>

That in red is causing you the problems.
Change those figures to the dimensions of your images.

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

Kristie
Registered User
Posts: 66
Joined: Thu Feb 24, 2005 10:06 am

Post by Kristie » Sun Apr 30, 2006 9:32 pm

Ohhhh...thank you. Jim forget my other post. I saw you mention tpl files to another problem so I posted to ask where those files can be found. I got the answer now..thanks.

Here is the board address:
Please do not post links unless absolutely required-Jim

I will also go look for the tpl you mention as well.

Thank you! :-)

Kristie
Registered User
Posts: 66
Joined: Thu Feb 24, 2005 10:06 am

Post by Kristie » Sun Apr 30, 2006 10:43 pm

Sorry Jim, do you know that there are links being posted all over this forum, so really did not know you could not..seeing them everywhere in threads, people asking for them so they can help, and them being given.

I found the file, but when I try to open it tells me that Windows does not recognize it and I need the program used to create the file, then it asked if I wanted it to do a web search, which yielded nothing. How do I open it to remove the dimensions?
Last edited by Kristie on Sun Apr 30, 2006 10:55 pm, edited 1 time in total.

Kristie
Registered User
Posts: 66
Joined: Thu Feb 24, 2005 10:06 am

Post by Kristie » Sun Apr 30, 2006 10:50 pm

I will also post this in my thread...so as not to further hijack. Sorry again, as I did not know I was hijacking anything. I have never seen anyone mind others jumping in on a discussion on any other boards, so didnt know...and yes you did answer my question, it was after I posted on the other thread though, and I noted that above, so again sorry..not meaning to step on anyones toes.

hotrocket
Registered User
Posts: 19
Joined: Thu Jul 01, 2004 10:00 am

Post by hotrocket » Mon May 01, 2006 3:15 am

you can use just about any HTML editor to open a .tpl file - just open the templates folder...choose the file...right click and choose "Open With"..then scroll thru the list and choose your html editor..or you can use notepad too

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK » Mon May 01, 2006 8:52 am

Kristie wrote: Sorry Jim, do you know that there are links being posted all over this forum, so really did not know you could not..seeing them everywhere in threads, people asking for them so they can help, and them being given.


In some cases it is necessary to have a link to a board to be able to see the problem but as the problem had already been identified and a cure delivered then that link was not required.

Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

Locked

Return to “2.0.x Support Forum”