Visual Confirmation Broken

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
User avatar
mattcoady
Registered User
Posts: 12
Joined: Sat Aug 13, 2005 5:08 am

Visual Confirmation Broken

Post by mattcoady » Fri May 05, 2006 12:55 am

When I turn on visual confirmation, and click register, I get to the age question (older or younger than 13). Then on the next page I get this error.

Code: Select all

General Error 
  
Could not delete stale confirm data 

DEBUG MODE 

SQL Error : 1146 Table 'mattcoad_phpbb1.phpbb_confirm' doesn't exist 

DELETE FROM phpbb_confirm WHERE session_id NOT IN ('005706af3c4b187fbaa989abd1cfa8b5',  

......A page full of codes......

Code: Select all

'fd8908c53c065de315c4038bb80a6730') 

Line : 965 
File : usercp_register.php
What can I do to patch this?

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29247
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty » Fri May 05, 2006 1:21 am

  1. Create a fix.php file with the following:

    Code: Select all

    <?php
    define('IN_PHPBB', true);
    include('./extension.inc');
    include('./common.'.$phpEx);
    $page_title = 'phpBB Fix';
    
    $sql = array();
    $sql[] = "CREATE TABLE " . $table_prefix . "confirm (`confirm_id` char(32) NOT NULL default '', `session_id` char(32) NOT NULL default '', `code` char(6) NOT NULL default '', PRIMARY KEY (`session_id`,`confirm_id`)) TYPE=MyISAM;";
    
    $sql_count = count($sql);
    for( $i = 0; $i < $sql_count; $i++ )
    {
       if ( !($result = $db->sql_query($sql[$i])) )
       $echo .= '<b>Query ' . ($i+1) . ': </b><font color="red"><b>Error (' . mysql_error() . ')</b></font><br />';
       else
       $echo .= '<b>Query ' . ($i+1) . ': </b><font color="green"><b>Ran successfully</b></font><br />';
    }
    message_die(GENERAL_MESSAGE, "<table width=\"80%\" class=\"forumline\"><tr><td><u><b>Report:</b></u><br />$echo<br /><br />All queries have been run. If any errors came up above, be sure to post the report in your topic on phpBB.com.<br /><b>You should now delete this file</b></td><tr></table>");
    ?>
  2. Upload the file to your board's root folder (the one with config.php)
  3. Run it by navigating to the file in your browser (ex. http://www.yoursite.com/phpBB2/fix.php)
  4. If any errors come up, post the report here.
  5. Be sure to delete the file; don't leave it on your server
Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

lokilust
Registered User
Posts: 2
Joined: Fri May 05, 2006 1:47 am

Post by lokilust » Fri May 05, 2006 1:53 am

Im having trouble with my visual confirm code, it will not display.
When someone tries to register at the forum it says improper code but you cant see it or put the code in.
Take a look and tell me what i can do http://www.venforum.com/profile.php?mod ... greed=true

Thanx

User avatar
Marshalrusty
Project Manager
Project Manager
Posts: 29247
Joined: Mon Nov 22, 2004 10:45 pm
Location: New York City
Name: Yuriy Rusko
Contact:

Post by Marshalrusty » Fri May 05, 2006 2:01 am

Have comments/praise/complaints/suggestions? Please feel free to PM me.

Need private help? Hire me for all your phpBB and web development needs

pdoehle
Registered User
Posts: 6
Joined: Wed Mar 16, 2005 6:06 am
Location: Old Crow, Yukon, Canada
Contact:

My Visual Confirmation Broken Also

Post by pdoehle » Fri May 05, 2006 3:28 am

My Visual Confirmation is also not working.

Your phpBB board URL: http://www.oldcrow.ca/phpbb2
Template(s) used: subSilver
Any and all MODs: None
Do you use a port of phpBB: ???
Version of phpBB: .20
Version of PHP: 4.4.2
Which database server and version:
Host: blacksun.ca
Did someone install this for you/who: myself
Is this an upgrade/from what to what: .17 to .20
Is this a conversion/from what to what: no
Have you searched for your problem: yes
If so, what terms did you try:
State the nature of your problem: dead link to visual confirmation image
Do you have a test account for us: no

Template check okay: http://www.oldcrow.ca/phpBB2/template_check.php

VC was working with version .17

Any help greatly appreciated.

Thanks

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom » Fri May 05, 2006 3:56 am

VC was working with version .17


Have you read phpbb2.0.20: all fixes in one place yet?
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

pdoehle
Registered User
Posts: 6
Joined: Wed Mar 16, 2005 6:06 am
Location: Old Crow, Yukon, Canada
Contact:

Thanks espicom

Post by pdoehle » Fri May 05, 2006 4:57 am

Have read the fixes thread. Not sure where to go from here.

User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Post by karlsemple » Fri May 05, 2006 4:59 am

how about you all start your own topics as this is going to get confusing as to what help is being directed at which user
Image

pdoehle
Registered User
Posts: 6
Joined: Wed Mar 16, 2005 6:06 am
Location: Old Crow, Yukon, Canada
Contact:

New Topic

Post by pdoehle » Fri May 05, 2006 5:19 am

Okay, will start new topic.

Locked

Return to “2.0.x Support Forum”