Page 1 of 1

Installation of 2.0.20

Posted: Sun May 21, 2006 2:31 pm
by Thy73
Istalled 2.0.20 from 2.0.17 - Full packet
After alot of problems, i finally got it to work.
Then i restored the database in ACP, but it doesn't work. All it has done is ... nothing
How do i recreate the whole forum as it was before ??

Posted: Sun May 21, 2006 2:33 pm
by karlsemple
for a start you did not need to reinstall to update. Did you drop the old database to allow you to reinstall?

Posted: Sun May 21, 2006 2:38 pm
by Thy73
Also, i had to change the $table_prefix = 'phpbb_'; in the config file to $table_prefix = 'phpbb1_'; cause otherwice i got this error that said, some database allready exist. So my brother suggested to rename the phpbb to phpbb1

Could that have something to do with not being able to restore ?

Posted: Sun May 21, 2006 2:40 pm
by Thy73
@ karlsemple
Yes, i had to totally remove the old forum database and then upload the new for 2.0.20 and run the install.php

Posted: Sun May 21, 2006 2:40 pm
by karlsemple
open config.php in a text editor and in that file change the table prefix back to phpbb_ and this should point the new forum back at the old database assuming it is still there.

Posted: Sun May 21, 2006 2:42 pm
by Thy73
This is what i get when changing the prefix back to phpbb_

Code: Select all

phpBB : Critical Error 

Error doing DB query userdata row fetch

DEBUG MODE

SQL Error : 1146 Table 'blitzteam.phpbb_sessions_keys' doesn't exist

SELECT u.* FROM phpbb_users u, phpbb_sessions_keys k WHERE u.user_id = 2 AND u.user_active = 1 AND k.user_id = u.user_id AND k.key_id = 'e22462c732975657c3974b3235c95a05'

Line : 89
File : sessions.php

Posted: Sun May 21, 2006 2:44 pm
by beatme101
You're almost done.

Upload the install folder from the 2.0.20 package. Run the contained update_to_latest.php file by browsing to it (the way you always run php files). Finally, delete the install folder.

Posted: Sun May 21, 2006 2:49 pm
by Thy73
Dooh ... I thought i'd allready ran that, but now it actually did work and everything is back in place.

Thanks alot for the help

Posted: Sun May 21, 2006 3:36 pm
by Thy73
Okay, now i got another weird error that just occured after a little while

Code: Select all

Error in obtaining userdata

DEBUG MODE

SQL Error : 1054 Unknown column 'user_login_tries' in 'field list'

SELECT user_id, username, user_password, user_active, user_level, user_login_tries, user_last_login_try FROM phpbb_users WHERE username = 'XXXXX'

Line : 65
File : login.php
So now it won't let me login to the forum !!

Posted: Sun May 21, 2006 3:39 pm
by karlsemple
you could try running the update_to_latest.php again as this should of added this or give this a go

  1. Create a fix.php file with the following:

    Code: Select all

    <?php
    define('IN_PHPBB', true);
    include('./extension.inc');
    include('./common.'.$phpEx);
    $page_title = 'phpBB Fix';
    
    $sql = array();
    $sql[] = "ALTER TABLE " . USERS_TABLE . " ADD COLUMN user_login_tries smallint(5) unsigned NOT NULL default '0'";
    
    
    $sql_count = count($sql);
    for( $i = 0; $i < $sql_count; $i++ )
    {
       if ( !($result = $db->sql_query($sql[$i])) )
       $echo .= '<b>Query ' . ($i+1) . ': </b><font color="red"><b>Error (' . mysql_error() . ')</b></font><br />';
       else
       $echo .= '<b>Query ' . ($i+1) . ': </b><font color="green"><b>Ran successfully</b></font><br />';
    }
    message_die(GENERAL_MESSAGE, "<table width=\"80%\" class=\"forumline\"><tr><td><u><b>Report:</b></u><br />$echo<br /><br />All queries have been run. If any errors came up above, be sure to post the report in your topic on phpBB.com.<br /><b>You should now delete this file</b></td><tr></table>");
    ?>
  2. Upload the file to your board's root folder (the one with config.php)
  3. Run it by navigating to the file in your browser (ex. http://www.yoursite.com/phpBB2/fix.php)
  4. If any errors come up, post the report here.
  5. Be sure to delete the file; don't leave it on your server

Posted: Sun May 21, 2006 4:02 pm
by Thy73

Code: Select all

Report:
Query 1: Error (Duplicate column name 'user_login_tries')
And then it tells me to delete the file again !!