Page 1 of 1

Hacked!

Posted: Sun May 28, 2006 3:49 am
by culturetrash
Yikes, my forum has been hacked a few times. It was cool the last few times because I could easily change things back. But now some *&^$#$ has changed the admin's name and password, and I can't get in. Can anyone help me with getting rid of this nuisance? Thanks.

lyz

Posted: Sun May 28, 2006 4:55 am
by Hynee
A) this shouldn't be in discussion, so I the thread will probably be moved.

B) if it has happened once and you don't change anything, it will happen again!

C) If you want to restore, you need to edit your DB directly. Backup your database before you do all this, and it is pretty advanced.

The table is _users, your ID wll probably be a low number, and admin accounts have the field user_level set to 1.

You'll need to change username back to your old username, and user_password back to a md5'ed password.

Make sure no other admin accounts have been added.

Posted: Tue May 30, 2006 6:04 am
by culturetrash
Hynee wrote: A) this shouldn't be in discussion, so I the thread will probably be moved.

B) if it has happened once and you don't change anything, it will happen again!

C) If you want to restore, you need to edit your DB directly. Backup your database before you do all this, and it is pretty advanced.

The table is _users, your ID wll probably be a low number, and admin accounts have the field user_level set to 1.

You'll need to change username back to your old username, and user_password back to a md5'ed password.

Make sure no other admin accounts have been added.


Ahh, didn't know it was in the wrong place, sorry.

Under what folder/file would this be? Thanks.

Posted: Mon Jun 05, 2006 1:00 am
by culturetrash
<bump>

Posted: Mon Jun 05, 2006 1:12 am
by StefanL
Donwload Starfoxtj toolkit in my sig to solve your problems.