Quote and quoting problems suddenly have returned in .21

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
User avatar
HarpuaFSB
Registered User
Posts: 38
Joined: Sat Jun 25, 2005 12:00 am

Quote and quoting problems suddenly have returned in .21

Post by HarpuaFSB »

Your phpBB board URL:
www.walkingcarpet.net/phpBB2

Template(s) used:
Conundrum
Nosebleed
subSilver
comicBook
HardMetal
Macinscott2
SoftMetal

Any and all MODs:
Template switching
Birthday
ConfusaBOT
Online/offline indicator
Quick Reply

Do you use a port of phpBB:
No

Version of phpBB:
.21

Version of PHP:
4

Which database server and version:
MySQL 5

Host:
Brinkster.com

Did someone install this for you/who:
No

Is this an upgrade/from what to what:
No

Is this a conversion/from what to what:
No

Have you searched for your problem:
Yes

If so, what terms did you try:
quoting, quotes

State the nature of your problem:
The well documented problem with quotes and quoting has out-of-nowhere returned on my board. I thought I had squashed this a while ago with the support threads here but today, all of a sudden it's back.

Very confusing as nothing has changed.

I went through the fixes that have been posted for this problem and they're all in my code.

Just to summarize, when posting something with quotes, slashes get added:

"Test" shows up as:

Code: Select all

\"Test"\
When using the quote tag with a name in quotes, this is what shown along with the fact that it completely breaks h scroll and messes up the template.
Test wrote: Test


shows up as (note that the end quote tag is completely gone)

Code: Select all

[quote:25a6c3af74=\"Test"\]Test
Do you have a test account for us:
Yes
Kajin
Registered User
Posts: 112
Joined: Wed Jun 15, 2005 5:06 am
Location: Moonside
Contact:

Post by Kajin »

I'm having the same issue. :(
Image
The KaN
Registered User
Posts: 380
Joined: Mon Mar 13, 2006 12:49 am

...

Post by The KaN »

If you have recently upgraded read this...

http://www.phpbb.com/phpBB/viewtopic.ph ... 97#2169697
phpBB3 User
User avatar
HarpuaFSB
Registered User
Posts: 38
Joined: Sat Jun 25, 2005 12:00 am

Re: ...

Post by HarpuaFSB »

The KaN wrote: If you have recently upgraded read this...

http://www.phpbb.com/phpBB/viewtopic.ph ... 97#2169697


I've been through that thread already and my functions_post.php code is all up to spec.

FWIW, this is happening without HTML enabled.

:?
User avatar
Lumpy Burgertushie
Registered User
Posts: 68126
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie »

If you had previously fixed these problems in .20 , then you need to undo those changes before you upgrade to .21.

if not, then you wind up with duplicate lines of code and other problems.

however, you most likely can just upload fresh .21 copies of the relevant files, as most MODs do not affect those files.

anyway. as always, rename your existing files before uploading new ones.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
Locked

Return to “2.0.x Support Forum”