Posting HTML to link to amazon

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
oldlock
Registered User
Posts: 255
Joined: Mon Feb 28, 2005 7:47 am

Posting HTML to link to amazon

Post by oldlock »

I have enabled HTML on my forum, and allowed the tag - iframe src

But all I get in the preview box is the code, no link ??

--

<iframe src="http://rcm.amazon.com/e/cm?t=antilockco ... ffff&f=ifr" style="width:120px;height:240px;" scrolling="no" marginwidth="0" marginheight="0" frameborder="0"></iframe>

I am probably missing something really basic ...
oldlock
Registered User
Posts: 255
Joined: Mon Feb 28, 2005 7:47 am

Post by oldlock »

- bump -

Anyone ??
User avatar
Lumpy Burgertushie
Registered User
Posts: 68314
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie »

I don't know if it will work at all, however, the tag should only be iframe

not <iframe and no src .

just iframe with a comma before it

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
oldlock
Registered User
Posts: 255
Joined: Mon Feb 28, 2005 7:47 am

Post by oldlock »

Thanks, changed the tag etc but still nothing, It simply posts whatever text I have pasted ...

I would expect an X or file not found etc ?

Unless I am missing something fundamental ..
User avatar
Lumpy Burgertushie
Registered User
Posts: 68314
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie »

do you have html turned on in the admin panel and in your profile?

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
User avatar
karlsemple
Former Team Member
Posts: 39802
Joined: Mon Nov 01, 2004 8:54 am
Location: Hereford, UK
Contact:

Post by karlsemple »

have a read through the userguide http://www.phpbb.com/support/guide/ as using html is covered in there :)
Image
mfest
Registered User
Posts: 18
Joined: Sat Mar 20, 2004 5:36 am
Location: New Jersey, USA
Contact:

Post by mfest »

Try adding this in your iframe tags to see what happens,

<iframe src="http://rcm.amazon.com/e/cm?t=antilockco ... ffff&f=ifr" style="width:120px;height:240px;" scrolling="no" marginwidth="0" marginheight="0" frameborder="0"><!-- Alternate content for non-supporting browsers -->Sorry, your web browser doesn't support the iframe tag.</iframe>


Hope this at least gives you something to work with.
Learning to fly is easy, just throw yourself at the ground and miss.
User avatar
Lumpy Burgertushie
Registered User
Posts: 68314
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie »

mfest wrote: Try adding this in your iframe tags to see what happens,

<iframe src="http://rcm.amazon.com/e/cm?t=antilockco ... ffff&f=ifr" style="width:120px;height:240px;" scrolling="no" marginwidth="0" marginheight="0" frameborder="0"><!-- Alternate content for non-supporting browsers -->Sorry, your web browser doesn't support the iframe tag.</iframe>


Hope this at least gives you something to work with.


no, don't do this, that is crazy. the only thing you ever add to the allowed tags, is html tags. the only thing in that complete html code that is a html tag, is the very first thing, which is what I already said. iframe.

< is not a tag and nothing after the word iframe is a tag.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?
oldlock
Registered User
Posts: 255
Joined: Mon Feb 28, 2005 7:47 am

Post by oldlock »

Lumpy Burgertushie wrote: do you have html turned on in the admin panel and in your profile?

robert


Yes, HTML is enabled.
oldlock
Registered User
Posts: 255
Joined: Mon Feb 28, 2005 7:47 am

Post by oldlock »

karlsemple wrote: have a read through the userguide http://www.phpbb.com/support/guide/ as using html is covered in there :)


Yes , I had read that ..
oldlock
Registered User
Posts: 255
Joined: Mon Feb 28, 2005 7:47 am

Post by oldlock »

No further ideas ??

...
User avatar
SpongeWeb
Registered User
Posts: 766
Joined: Thu Jan 27, 2005 2:57 pm
Location: End of the Universe
Contact:

Post by SpongeWeb »

I just tried it on my board,

works fine for me,

do you specify which tags are allowed in ACP?
A friend is someone who knows the song in your heart, and will sing, when you forget the words..
mama_soap
Registered User
Posts: 71
Joined: Thu Jun 02, 2005 9:35 pm

Post by mama_soap »

Well, at the risk of sounding redundant:

1. Go to your ACP, make sure HTML is enabled, and the list of allowed html tags should look akin to this: b,i,u,pre,iframe.

2. When you're posting, try to post something simple to begin with, like
<iframe src="http://www.phpbb.com"></iframe>


If you're sure you've done this to the letter earlier, then just ping back here. For the record, this works on my local v2.0.19 install all right.

Good luck in the meantime :)
oldlock
Registered User
Posts: 255
Joined: Mon Feb 28, 2005 7:47 am

Post by oldlock »

Still no luck and the weird thing is I just added a Paypal button to another part of the forum with no problems at all ?
oldlock
Registered User
Posts: 255
Joined: Mon Feb 28, 2005 7:47 am

Post by oldlock »

- bump -
Locked

Return to “2.0.x Support Forum”