error with search.php

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
slayer1011
Registered User
Posts: 129
Joined: Sun Jul 03, 2005 11:02 pm
Location: Hamilton, Ontario Canada
Contact:

error with search.php

Post by slayer1011 » Wed Jul 05, 2006 10:14 pm

when i try to search on my forum i get the following error

it was a fresh install of 2.0.19 and i want to get everythign workign before i upgrade (dont liek broken upgrades lol)

thank you
anyoen else had this error?

Could not delete old search id sessions

DEBUG MODE

SQL Error : 1054 Unknown column 'search_time' in 'where clause'

DELETE FROM phpbb_search_results WHERE search_time < 1152133283

Line : 657
File : search.php


P.S. the code in search.php is as follows (un-edited from installation time)

Code: Select all

		//
		// Delete old data from the search result table
		//
		$sql = 'DELETE FROM ' . SEARCH_TABLE . '
			WHERE search_time < ' . ($current_time - (int) $board_config['session_length']);
		if ( !$result = $db->sql_query($sql) )
		{
			message_die(GENERAL_ERROR, 'Could not delete old search id sessions', '', __LINE__, __FILE__, $sql);
		}

AMD Power
Registered User
Posts: 2044
Joined: Tue Jun 27, 2006 2:16 pm
Location: Kuala Lumpur, Malaysia
Contact:

Post by AMD Power » Thu Jul 06, 2006 2:50 am

I guess your forum database version is not the same as your forum files version. Did you update your forum version?

slayer1011
Registered User
Posts: 129
Joined: Sun Jul 03, 2005 11:02 pm
Location: Hamilton, Ontario Canada
Contact:

Post by slayer1011 » Tue Jul 11, 2006 1:08 am

hmm. you know what.. i installed a new version, got it all running then brang my database over to that forum... would that be the problem? im going to update my databases and see what is going on... thanks, i would have never caught that
totally slipped my mind


Edit: Fixed, thank you!

Locked

Return to “2.0.x Support Forum”