log-in error

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
fcas
Registered User
Posts: 36
Joined: Wed Aug 23, 2006 7:27 am

log-in error

Post by fcas » Wed Aug 23, 2006 7:46 am

hi! i hope someone can help me with this. i'm obviously not a programmer so i need everything explained to me. when i try to access my forum i get this message:

Warning: mysql_connect(): Access denied for user: 'name@localhost' (Using password: YES) in /home/name/public_html/forum/db/mysql4.php on line 48

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in /home/name/public_html/forum/db/mysql4.php on line 330

Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in /home/name/public_html/forum/db/mysql4.php on line 331
phpBB : Critical Error

Could not connect to the database

please help! :?:

AcousticJames
Registered User
Posts: 970
Joined: Wed Jul 13, 2005 5:59 am
Location: St. Cloud, MN
Contact:

Post by AcousticJames » Wed Aug 23, 2006 7:52 am

It means that phpBB cannot establish a connection to your databse. Have you made sure that the information in config.php is correct? You need the hostname of the database server, the name of the database, the username and the password for the database server.

amir abbas
Registered User
Posts: 113
Joined: Fri Mar 31, 2006 2:26 pm
Contact:

Post by amir abbas » Wed Aug 23, 2006 7:52 am

your database information is not correct

please check

database host
database username
database name
database password

fcas
Registered User
Posts: 36
Joined: Wed Aug 23, 2006 7:27 am

Post by fcas » Wed Aug 23, 2006 8:11 am

the forum was working fine until i changed my cpanel password. does this affect the database? i removed cong & install files because this was the instruction. should i reinstall it?

thanks for the help guys! :D

User avatar
Jim_UK
Former Team Member
Posts: 18478
Joined: Tue Oct 12, 2004 5:36 pm
Location: Darwen N.West UK

Post by Jim_UK » Wed Aug 23, 2006 8:16 am

That is exactly what the problem is. Download config.php from the server and open in a text editor. Correct the password inside and upload back to the server.
All should then be ok.


Jim
The truth is out there.
Unfortunately they will not let you anywhere near it!

fcas
Registered User
Posts: 36
Joined: Wed Aug 23, 2006 7:27 am

Post by fcas » Wed Aug 23, 2006 8:23 am

thank you! thank you! thank you! it works now! :lol:

i'm so happy i could jump up & dance! :D

you're my savior joe! :D

fcas
Registered User
Posts: 36
Joined: Wed Aug 23, 2006 7:27 am

Post by fcas » Wed Aug 23, 2006 8:29 am

i mean JIM :D

Locked

Return to “2.0.x Support Forum”