New PHPBB install problem

This is an archive of the phpBB 2.0.x support forum. Support for phpBB2 has now ended.
Forum rules
Following phpBB2's EoL, this forum is now archived for reference purposes only.
Please see the following announcement for more information: viewtopic.php?f=14&t=1385785
Locked
The Snoman
Registered User
Posts: 63
Joined: Sun Dec 04, 2005 7:39 pm

New PHPBB install problem

Post by The Snoman »

I setup a new site with PHPBB 2.0.20 clean install and upgraded it to 2.0.21 and added EZmod and firefox password fix. I just realized that it will not save changes to config, Allow automatic logins (defaults to No), Search Flood Interval (default blank), Allowed login attempts, (default blank) and Login lock time (default blank) I can make changes and save them and it says it has been saved but when page reloads it is as stated above. It had this problem before I did the upadte and few mods I just never realized it until now. It is not sending out email comfirmation to new users either. Anyone have any idea as to what the problem is?

The Snoman
Registered User
Posts: 63
Joined: Sun Dec 04, 2005 7:39 pm

Post by The Snoman »

Does anyone have a suggestion or a solution for this problem?

Eric1234
Registered User
Posts: 11
Joined: Sun Jan 21, 2007 4:15 am

Post by Eric1234 »

I am having this same problem- but no mods have been installed.

Occurring on v2.0.22

It saves other changes- but not the fields mentioned by Snoman.

Anyone have an answer/idea?

espicom
Registered User
Posts: 17905
Joined: Wed Dec 22, 2004 1:14 am
Location: Woodstock, IL

Post by espicom »

http://espi.com/text/validate_phpbb_v22.php.txt

RIGHT click on the link above, and select "save as". Save it to your local disk. You then upload it as "validate_phpbb_v22.php" to your PHPBB directory, and run it with your browser. The results will tell you what fields and/or tables are missing.

It is likely you're missing a number of configuration items in your database, and there is no way for the programs to add them; they have to be inserted through a tool like phpmyadmin.
Jeff
Fixing 1016/1030/1034 Errors | (obsolete link) | MySQL 4.1/5.x Client Error | phpBBv2 Logo in ACP
Support requests via PM are ignored!
"To be fully alive is to feel that everything is possible." - Eric Hoffer

Eric1234
Registered User
Posts: 11
Joined: Sun Jan 21, 2007 4:15 am

Post by Eric1234 »

OK- ran the check. The results of what is missing:

"Database reports it is version 2.0.22.
Required configuration keys allow_autologin, max_autologin_time, max_login_attempts, login_reset_time, search_flood_interval, rand_seed are missing!"



phpMyAdmin is installed (part of the hosting service's value adds)- but I have no idea where, and what values should be created in the db. Anywhere I can find a "phpMyAdmin for morons" guide?

Eric1234
Registered User
Posts: 11
Joined: Sun Jan 21, 2007 4:15 am

Post by Eric1234 »

Alright- I figured out how to add/remove/change db tables/fields- but where should the missing keys listed be located? As complete tables on their own- or as fields in which table(s)?

User avatar
Lumpy Burgertushie
Registered User
Posts: 67212
Joined: Mon May 02, 2005 3:11 am
Contact:

Post by Lumpy Burgertushie »

you need to upload the install folder from the lastest .22 version of phpbb.

then, in your browser, go to:
yourdomain.com/yourphpbb/install/update_to_latest.php

then delete the install folder.

this should add all those missing parts to your database. IF not,
then you may have to do them manually.

robert
I'm baaaaaccckkkk. still doing work on donation basis. PM your needs.

Premium phpBB 3.3 Styles by PlanetStyles.net

If nobody is in the forest, does a tree really fall?

Locked

Return to “2.0.x Support Forum”