Page 1 of 1

2.01 to 2.03 problem

Posted: Fri Oct 04, 2002 7:23 am
by CyberSpy
I updated to 2.0 when it first came out. Then tonight when I went to update from 2.01 to 2.03 I ran a patch since I have many mods and got quite a few errors (hunk failed, etc). Then noticed that you have to have 2.02 first. I looked here and couldn't find it. So I did a search. Saw that I should go to sourceforge, and I got the 2.02 patch from there. I went to run it, and had massive errors again.. it seems the 2.02 patch on sourceforge is the cvs version.. look at this error:

Code: Select all

sh-2.04$ patch -p0 < phpBB-2.0.2-update.patch
can't find file to patch at input line 8
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|Index: install.php
|===================================================================
|RCS file: /cvsroot/phpbb/phpBB2/Attic/install.php,v
|retrieving revision 1.41.2.1
|diff -u -r1.41.2.1 install.php
|--- install.php        13 May 2002 13:18:17 -0000      1.41.2.1
|+++ install.php        8 Aug 2002 18:12:56 -0000
--------------------------
What do I do, my backup I made before the attempt won't restore, and I need to know what I should do to upgrade with the patch? I think the 2.03 from 2.02 was too quick and 2.02 should have remained here for a bit after 2.03 was released. Can someone help me?

Posted: Fri Oct 04, 2002 5:31 pm
by Techie-Micheal
You should have gotten 2.0.2 patch from here: http://prdownloads.sourceforge.net/phpb ... p?download

Same error

Posted: Fri Oct 04, 2002 6:37 pm
by CyberSpy
I tried that link, got that patch, and it's the same error..

It looks into /cvs/phpbb/attic I have no idea what dir that is.

Posted: Fri Oct 04, 2002 6:53 pm
by Techie-Micheal
I don't know either. I did the patch on both 2.0.1-2.0.2 and 2.0.2-2.0.3 and it works fine for me.

Posted: Fri Oct 04, 2002 6:56 pm
by Flipper
The Attic directory of CVS, is a place for files deleted from CVS (like a Windows Recycle Bin).

Fixed (sort of) please delete these posts.

Posted: Fri Oct 04, 2002 7:20 pm
by CyberSpy
I downloaded the 2.0.1 and 2.0.2 changed files, and just lost some mods and went back to origina1 2.0.1 files, did the same for 2.0.2 and then ran the patch for 2.0.3, It says 2.0.3 at the bottom of my pages, and I don't see any major errors so far, so I guess it worked. Now to find all the tweaks I made, heh